1. kunalashar#CB's Avatar
    I'm using a BlackBerry 7100g.

    All of a sudden, my keypad seems to have gone wonky. When I press the delete key, it types (adds on) "sxvc" instead of deleting a character. Similar weird characters appear when I press the ',', '.' and enter keys (for example, it types "aad" when I press the "L" key.

    I've tried changing the language to English, but it doesn't stay that way! It keeps changing it back to Afrikaans, I think.

    Do I need to reinstall the OS?

    It appears that the 4 rightmost keys (comma, period, delete and enter) behave as the 4 keys in the second column of the keypad.

    That is, when I pres ".". it behaves like the "E R" key. When I press "," it behaves like "D F", etc.

    Weird! Anyone seen this problem and know how to deal with it? I've tried resetting the blackberry by removing the battery and SIM card for a few minutes.
    06-09-07 03:50 AM
  2. anon(153966)'s Avatar
    After making sure the num / caps is not on (am sure you've already done this), I'd say, do a backup and then reload with the latest O.S. from T-Mobile,
    06-09-07 07:02 AM