1. jeremytfa's Avatar
    Hi,

    I've got a 7250 that i am trying to reset, but i am getting an error 507. The old user left a password on it, so i put in 10 bogus passwords to get it to wipe, but this might have been the wrong thing to do. I want to set it up for a new user. How do I restore the software?

    Thanks!
    07-13-07 01:36 PM
  2. anon(153966)'s Avatar
    No, doing a wipe will clear all the data, like it's new. But, if you have a white screen with the 507 error, the you have to reload the OS...

    Go to Verizons website and look for the OS for that model, and install it...
    07-13-07 03:03 PM
  3. networkjoe's Avatar
    Fix that worked for me (recovering from a 507 error):

    Disconnect phone from PC.
    Make sure USB cable is connected directly to PC (i.e., no USB HUB or docking station, etc.)

    Pull battery from phone.
    Connect phone to computer.
    Go through upgrade (or downgrade) process as usual - you know, the one that didn't work earlier and got you into this mess.

    When desktop manager says "Connecting to JVM": PUT IN THE BATTERY AT THAT TIME! (which means don't start upgrade and go to the corner store)

    From this point it's straight-forward. However, it seems to take a long time when it goes to connect to device (this is when you should go to the corner store).

    This has worked for me after a failed upgrade from 4.2 to 4.5 then recovery back to 4.2...twice (before carrier supported it), and also again to finally successfully upgrade to BBOS 4.5
    02-25-09 10:14 AM
  4. wierdguywithaknife's Avatar
    Thank you this also worked for my 7100i wich had gone far past the 507 screen. It would do nothing except flash the led, no screen at all.
    09-09-10 06:06 PM
  5. brew4s2's Avatar
    Hello,

    I'm having a very similar problem. My Storm 9530 seems to have a corrupted OS.

    I have tried nearly everything, including your suggestion of replacing the battery at the "Connecting to JVM" stage of OS update. At that point, I am perpetually given the error message (on desktop): "Application Loader was unable to connect with your device. Please reconnect your device and click retry." My Storm keeps connecting and disconnecting from the desktop manager in ~10 second intervals.

    I have also walked through several our processes to fix this including the 101 tutorial on nuked berrys.

    When I attempt manually using app loader, it recognizes my device's PIN, and brings me to the Device Application Section. However, it says that my desktop software doesn't have any software for my device... I have a raw download of the 5.0 OS, but it is in .rar (unfamiliar to me) and won't allow me to add it at the above mentioned screen.

    Whhhhat should I do? I'm about to give up.

    Thanks for any help!
    09-13-10 09:26 AM
LINK TO POST COPIED TO CLIPBOARD