1. jericho 2550's Avatar
    Hello,

    6 months ago, I purchased a Z30.

    Really a phenomenal phone. But with a deadly flaw (in my case).

    http://forums.crackberry.com/blackbe.../#post10150594

    International formatted numbers do not appear in the caller ID, all my numbers are internationally formatted. So for most of the 6 months, I have the Z30 gathering dust.

    With every update, I run to it and update it in hopes this silly caller ID issue has been resolved, only to be disappointed it hasn't.

    So I would like to ask, does anyone know if 10.3 has made any changes in that area? The dialer and possibly caller ID changes?

    Thanks.
    08-14-14 12:10 AM
  2. Serbanescu Daniel's Avatar
    Have you tried 10.2.2 ?
    I made some tests just now and both times ( with number saved with country code and without) the caller ID appeared

    or... may be a problem with the carrier
    cosmotzr likes this.
    08-14-14 04:17 AM
  3. Banco's Avatar
    That's odd. My international numbers appear named without any issues at all.

    Posted via CB10
    08-14-14 04:20 AM
  4. Big_Ern's Avatar
    That's odd. My international numbers appear named without any issues at all.

    Posted via CB10
    Mine too. Most of my numbers are saved in international format, but not all. Yet they all show up fine on caller ID.
    Must be your carrier Jericho 2550

    Z30STA100-3/10.2.1.2180

    Posted via Z30 on CB10
    08-14-14 04:40 AM
  5. jericho 2550's Avatar
    Have you tried 10.2.2 ?
    I made some tests just now and both times ( with number saved with country code and without) the caller ID appeared

    or... may be a problem with the carrier
    I really hope 10.2.2 solves it!

    I'll wait for the update.

    Thank you.
    08-14-14 04:44 AM
  6. jericho 2550's Avatar
    Mine too. Most of my numbers are saved in international format, but not all. Yet they all show up fine on caller ID.
    Must be your carrier Jericho 2550

    Z30STA100-3/10.2.1.2180

    Posted via Z30 on CB10
    I doubt it's the carrier because all the phones I use with the same carrier don't have this issue.

    I do hope 10.2.2 solves it!
    08-14-14 04:45 AM
  7. Banco's Avatar
    I doubt it's the carrier because all the phones I use with the same carrier don't have this issue.

    I do hope 10.2.2 solves it!
    It's really odd though. As I say, I don't have this problem and I'm guessing we're both on the latest official OS. I'm at a loss as to understand why this is an issue for you.

    Let's check something, do you store your numbers as 00 then the number, or + then the number? Just trying to rule things out here...

    Posted via CB10
    08-14-14 04:49 AM
  8. jericho 2550's Avatar
    It's really odd though. As I say, I don't have this problem and I'm guessing we're both on the latest official OS. I'm at a loss as to understand why this is an issue for you.

    Let's check something, do you store your numbers as 00 then the number, or + then the number? Just trying to rule things out here...

    Posted via CB10
    Thank you for the support!

    I store all my numbers with a +.
    08-14-14 07:56 AM
  9. Banco's Avatar
    Thank you for the support!

    I store all my numbers with a +.
    OK....I just checked my most frequent ones and it's appearing as 00 in the contacts (it may just change the default appearance). So why not change say your home/office number - wherever you currently are - to 00 and then call the handset, and see if that makes a difference?
    08-14-14 08:02 AM
  10. Akainzo's Avatar
    Hello,

    6 months ago, I purchased a Z30.

    Really a phenomenal phone. But with a deadly flaw (in my case).

    http://forums.crackberry.com/blackbe.../#post10150594

    International formatted numbers do not appear in the caller ID, all my numbers are internationally formatted. So for most of the 6 months, I have the Z30 gathering dust.

    With every update, I run to it and update it in hopes this silly caller ID issue has been resolved, only to be disappointed it hasn't.

    So I would like to ask, does anyone know if 10.3 has made any changes in that area? The dialer and possibly caller ID changes?

    Thanks.
    Not sure what the issue with your particular phone is, but ALL my contacts are in international format due to the nature of my work and my Z30 has shown the Caller ID for calls and texts.

    Ensure you set your Country and phone number length correctly in the PHONE APP Settings.


    Posted via CB10
    08-14-14 08:13 AM
  11. tHe.iR1sH's Avatar
    Not sure what the issue with your particular phone is, but ALL my contacts are in international format due to the nature of my work and my Z30 has shown the Caller ID for calls and texts.

    Ensure you set your Country and phone number length correctly in the PHONE APP Settings.


    Posted via CB10
    What he said and perhaps provide an example format you are using that does not work properly.


    Posted via CB10
    08-14-14 02:12 PM
  12. bobshine's Avatar
    I'll buy your Z30 for 150$!


    Posted via CB10
    08-14-14 02:22 PM
  13. BCITMike's Avatar
    I doubt it's the carrier because all the phones I use with the same carrier don't have this issue.

    I do hope 10.2.2 solves it!
    There can be caller ID issues per account that needs to be fixed by carrier. I wouldn't assume it it's not a problem on the providers side.

    Posted via CB10
    08-14-14 02:42 PM
  14. jericho 2550's Avatar
    Well BB still has this page up.

    Could this be the issue and I should just continue to wait until they fix it?

    KB33685-Caller ID does not show associated contact when country code is included in phone number
    08-15-14 12:45 AM
  15. jericho 2550's Avatar
    The country I'm in is Yemen.

    So in smart dialing I have Yemen. It doesn't give me the national number length option.

    Numbers in Yemen are formatted like this:

    +967 123456789

    Now I store all numbers as above.

    Incoming numbers come in as 123456789 (without the country code)

    When this happens, the phone doesn't display the name.

    Any ideas?
    08-15-14 02:50 AM
  16. ealvnv's Avatar
    The country I'm in is Yemen.

    So in smart dialing I have Yemen. It doesn't give me the national number length option.

    Numbers in Yemen are formatted like this:

    +967 123456789

    Now I store all numbers as above.

    Incoming numbers come in as 123456789

    Any ideas?
    If you have a space between the country code and the number remove said space and see if that fixes it
    Instead of +967 123456789 use +967123456789 and see if that makes any difference
    08-15-14 03:33 AM
  17. jericho 2550's Avatar
    If you have a space between the country code and the number remove said space and see if that fixes it
    Instead of +967 123456789 use +967123456789 and see if that makes any difference
    Thanks, just tried that. Most of my numbers have no space, but I tested on the ones with and without. No luck.

    I also added and removed spaces in some numbers. Still no luck.
    08-15-14 08:10 AM
  18. Banco's Avatar
    Thanks, just tried that. Most of my numbers have no space, but I tested on the ones with and without. No luck.

    I also added and removed spaces in some numbers. Still no luck.
    Is it possible this is somehow carrier related? It's such a strange problem, and one that the rest of us aren't facing.
    08-15-14 08:13 AM
  19. Supa_Fly1's Avatar
    The country I'm in is Yemen.

    So in smart dialing I have Yemen. It doesn't give me the national number length option.

    Numbers in Yemen are formatted like this:

    +967 123456789

    Now I store all numbers as above.

    Incoming numbers come in as 123456789 (without the country code)

    When this happens, the phone doesn't display the name.

    Any ideas?
    Country you're in nor an example of the numbers or their format their in!

    Caller ID is heavily based on the carrier and settings within your phone.

    1. Please post a screenshot (edit if you will) of your smart dialing settings.

    2. Does this issue occur with local numbers in your city/country?

    3. Your using a SIM card from your carrier not a very old one from years ago?

    4. You?ve contacted your carrier to have them resend SIM card settings from the switch right?!

    5. Does your Z30 or company have a Wifi/PBX software to route your office number to your phone? And you do NOT have a VOIP application installed, right?

    6. Are YOU the only Bb10 user affected? I find this odd that this entire thread or the other you linked you've not yet stated anyone else in your company is affected.

    ? BlackBerry Z30 ? If it Don't Make Dollars, It don't Make Sense ?
    08-15-14 08:32 AM
  20. jericho 2550's Avatar
    Thank you for taking the time to help!

    1. All I have in smart dialing is the country Yemen, and 9 in national digits.

    2. This issue only occurs in local numbers.

    3. Sim card was brand new when I got the Z30.

    4. Contacted the carrier, they said they don't send any settings. "Just put the Sim card in and you're done!"

    5. No VOIP or PBX.

    6. I haven't seen a BB10 user around here. Everybody is on iOS or Android.

    I appreciate your help, but it seems 10.3 is my only hope right now.
    08-17-14 04:14 PM

Similar Threads

  1. Replies: 6
    Last Post: 08-25-14, 10:10 PM
  2. Verizon Z30 on Back Order till 8/22
    By Camelhmpz in forum BlackBerry Z30
    Replies: 4
    Last Post: 08-20-14, 11:02 AM
  3. Replies: 56
    Last Post: 08-15-14, 08:48 PM
  4. Spotify coming to Canada soon.
    By Saulii in forum Android Apps (Amazon Store & APK Files)
    Replies: 5
    Last Post: 08-15-14, 03:19 AM
LINK TO POST COPIED TO CLIPBOARD