1. rai187's Avatar
    I have a z10 which was originally on the Fido network. I got it unlocked and started to use it with a Telus sim for about a week. After wiping the device I tried to use my Fido sim card and it won't being detected. I have tried Bell as well and it's not being detected either.

    To sum it up, I unlocked a Fido Z10 and used it on the Telus network and now it seems to be locked to Telus but it says "unlocked" in the mobile network.

    I tried another security wipe that didn't work. I also tried to reload the software via BlackBerry Link and that didn't help either.

    Help needed! Thanks!
    12-06-14 05:35 AM
  2. priceless819's Avatar
    Just a suggestion, have you started up the phone with the sim that does work, and once it boots up, and is running fine, switch out the sim that you want to use, and see if it takes it.
    Shucks, you have to remove the battery to change the sim on a Z10? Shucks, there goes my idea.

    Posted via CB10
    12-06-14 02:42 PM

Similar Threads

  1. Best app for Z10 you installed?
    By SureshMurugan in forum BlackBerry Z10
    Replies: 39
    Last Post: 07-16-15, 01:05 PM
  2. The only way to keep your Z10 running fast is
    By jmee_mo in forum BlackBerry Z10
    Replies: 12
    Last Post: 12-12-14, 05:09 PM
  3. How can I copy contacts from Z10 to Outlook?
    By CrackBerry Question in forum Ask a Question
    Replies: 8
    Last Post: 12-06-14, 05:27 PM
  4. How do I fix the bottom bar not working while running the apk on Q5 BB10?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 12-06-14, 04:08 AM
LINK TO POST COPIED TO CLIPBOARD