1. Papaguan's Avatar
    Hey Crackberry Nation!

    tl;dr: There was a text message bug on 10.2 and 10.2.1 where if you tried to load a text message thread as a new text message from that thread came in, the thread would freeze up. Temporary workaround was to switch the background of the text message app. Is this bug fixed on the newer OS revisions? (10.3, 10.3.1)

    I'm a platform agnostic guy. I've tried started my smartphone journey with a iPhone 3GS, then a Lumia 900, and last summer, a Q10...and I loved the hub, the keyboard, the battery life, and the gesture controlled OS. The thing about me is that communication is most important to me, not apps. And while BB10 was superior for communication on the other platforms I tried, the text message bug, as described above, was a deal breaker for me. At the time I was at my final year as a computer engineering major, I opted to get an Android device to develop on for some of my courses, so I bought a Nexus 5 to switch over to. I don't regret it as it was helpful for my academic career, but Android is NOT comparable to BB10 in terms of communication, and I knew I had to switch. Now working in the industry, the company I work for is a chip supplier, and one of our big customers is Apple, so I decided to give iOS one more try with the iPhone 6+. The phone itself is great, but in the end, the touch screen keyboard is decent at best, and the lack of the hub style of reply to notifications leaves something to be desired.

    So now I'm asking you guys: is this text message bug still present? I will likely not use my Q10 anymore (different sim card size anyway), and would opt for a Passport or the new full touch device, but do not want to switch back unless people who have experienced this bug can say with confidence that they do not see it present. As an engineer, I was slightly offended that a bug like this can sneak its way into several OS releases without a fix.

    Thank you for reading.
    11-23-14 11:46 AM
  2. Joshu42's Avatar
    Q10SQN100-3/10.2.1.3442 here. I tried multiple times to reproduce the bug you described without success. Maybe the sync between the reception of the new SMS and the opening of the thread was not perfect, or maybe the thread was not long enough... I tried many times, no lags or freeze.

    Either it was an issue with your specific phone and software environment, either 10.2.1.3442 solves the problem. I can't say if I've already have the same pattern with previous OS, but no lags or freeze either for sure.
    Papaguan likes this.
    11-23-14 12:13 PM
  3. Papaguan's Avatar
    Hi Joshu42,

    Thank you for your reply! I appreciate your feedback. One thing about this bug is that if the text thread is not very long, the bug is very hard to reproduce. If you have never seen the bug before, it might be hard to try to do on your own...and I would like to believe it was an isolated issue, but there have been several topics in the past about this bug (which is how I found out about the workaround), and its definitely a software issue.

    If you would like to really try to replicate it, you need a really long text message thread (a month of two of daily conversation, really), and try to open the text thread right as a new thread comes in. I know it sounds like a ridiculous situation, but I am a very heavy text message user and if I'm involved with multiple conversations at once, I get frustrated because I eventually end up hitting this bug.

    Here's what a quick Google search found:

    http://forums.crackberry.com/blackbe...es-q10-866614/

    http://forums.crackberry.com/blackbe...ze-q10-859427/
    11-23-14 02:30 PM
  4. howards's Avatar
    I'm on this forum quite often every day and I haven't seen anyone post anything in recent memory regarding the bug issue you've described. The only thing I can take away from that is either it's no longer an issue with the latest OS releases, or no one has long text message threads like you do. I'd bet it's the former.

    Z30 / STA 100-3 / 10.2.1.3289
    Papaguan likes this.
    11-23-14 03:47 PM
  5. mad_mdx's Avatar
    Hey I know exactly the bug you are talking about. It's absolutely gone for me in Z30STA100-5/10.3.1.1151
    But this version is still a leaked version and not an official release and the text app has other similar bugs, but since updating to the latest leak that big seems to be gone as well.

    I used to have the same exact issue you had BTW. Super annoying.

    Posted via CB10
    Papaguan likes this.
    11-23-14 03:55 PM
  6. rjk123's Avatar
    It's gone. No more issues.

    Posted via CB10 using Z30 STA100-5/10.2.1.3247
    Papaguan likes this.
    11-23-14 04:05 PM
  7. D3C0D3R's Avatar
    I remember i used to have that issue on my Z10, and yes, it was annoying as heck and I'd have to delete my entire text message thread with the person just to be able to get their text messages conversation to load -.-

    I'm pleased to announce that between NOT restoring from BlackBerry Link and 10.3, this issue has been fixed!

    It could just be 10.3, it could also just be that we had restored from BlackBerry Link and it be one of those many cases where the restore files damaged core BlackBerry 10 files..

    Always do fresh installs or updates (meaning never use Link to restore to a different OS version (meaning you can if you're not currently having any issues with your current install, you're just reinstalling the OS or switching phones (has to stay the same model!), then you can use Link, just avoid Backup restoring onto different OS versions))

    That's all the advice i can give on that matter :P

    Praise be unto our Lord Squircle | Passport SQW100-1/10.3.0.1418
    Papaguan likes this.
    11-23-14 04:18 PM
  8. Papaguan's Avatar
    Thanks for the replies guys! It means a lot to know that the bug is gone

    Hey I know exactly the bug you are talking about. It's absolutely gone for me in Z30STA100-5/10.3.1.1151
    But this version is still a leaked version and not an official release and the text app has other similar bugs, but since updating to the latest leak that big seems to be gone as well.

    I used to have the same exact issue you had BTW. Super annoying.

    Posted via CB10
    What other bugs does the text app have currently?
    11-23-14 06:00 PM
  9. joekavorski's Avatar
    10.3.1 is fantastic so far.

    My gf has a Q10 running 1151 and she still has this problem. I recently wiped my device, restoring only system files and rebuilding anything from scratch and I haven't run into it again, but my gf has it and has never wiped her device the same way.

    It may have something to do with old text data that's bad or something, however I think it was resolved. It IS a thing though.

    EDIT: not to discourage you, since you won't likely be restoring text data, but I felt it was relevant enough to share!

    Posted via CB10
    11-23-14 07:20 PM
  10. mad_mdx's Avatar
    Well 10.3.1 at some point was giving me a problem which I found out would go away if I closed BlackBerry blend from the device monitor. But that was in the earlier leaked versions of 10.3.1.

    As of updating to the newest leak I have no real problems with sms.

    Posted via CB10
    11-25-14 11:56 AM
  11. gogogadgets's Avatar
    I never saw that bug or any other with SMS. What's this "text message app" of which you speak?
    11-30-14 10:42 AM
  12. mrfreeze's Avatar
    I saw it on my Z30. I'm on 10.3.1.1154 leak and have had no sms issues since upgrading.



    Posted via CB10
    11-30-14 11:16 AM
  13. mad_mdx's Avatar
    I never saw that bug or any other with SMS. What's this "text message app" of which you speak?
    Regular texting is done with the sms app within the hub, just that

    Posted via CB10
    11-30-14 12:02 PM
  14. D3C0D3R's Avatar
    Regular texting is done with the sms app within the hub, just that

    Posted via CB10
    Just to clarify, the "text message app" is really just a macro to going to the hub then switching to sms only view. It's not actually an app :P

    Praise be unto our Lord Squircle | Passport SQW100-1/10.3.0.1418
    11-30-14 01:04 PM

Similar Threads

  1. latest backup file not recognized in Link
    By browenb in forum BlackBerry Z30
    Replies: 6
    Last Post: 11-24-14, 10:58 AM
  2. No arrow showing direction in bbmaps?
    By Bledar Kalemi in forum BlackBerry Passport
    Replies: 6
    Last Post: 11-23-14, 04:00 PM
  3. Group texts
    By jpoirier8 in forum Ask a Question
    Replies: 2
    Last Post: 11-23-14, 12:28 PM
  4. Natwest for Android bug report
    By Acvdm in forum BlackBerry 10 Apps
    Replies: 0
    Last Post: 11-23-14, 11:19 AM
LINK TO POST COPIED TO CLIPBOARD