1. Anonymous2039's Avatar
    In Settings > Language and Input > Prediction and Correction > Word Substitution there are several examples of the macro %b being used, but it doesn't work! %b is supposed to act as a backspace prompt to remove the preceding character in word substitutions, and as far as I'm aware it works fine on BBOS, but not BB10.

    For example, one of the default options is rb > %b) which means that if you type "rb" as a new word with a space in front of it, then press the spacebar to autocorrect, the preceding space should be erased and the "rb" replaced with a right bracket ")". The way it is now, that extra space doesn't get erased, so you end up with a space where there isn't supposed to be one, like this: "(qwerty )" instead of this: "(qwerty)".

    This macro is useful for providing quick shortcuts to symbols by using the letter key the symbol is on without having to use the Alt key (on the Q10, ie b > %b! or v > %b?), but it doesn't work, and it only frustrated me more to discover that it doesn't work on 10.2 either!

    Who else has noticed this bug, and does it annoy you as much as it does me? BlackBerry is supposed to have the best keyboard in the business, yet there is this glaring bug that has yet to be fixed. Did anyone make use of it on their old BlackBerrys? This needs to be fixed, and soon!


    Word Substitution Macro "%b" Broken in BB10-img_00000246.png

    --Q10 and Canadian all the way!
    Last edited by chaz95; 09-07-13 at 10:55 AM.
    09-06-13 01:44 AM
  2. Zedi Master's Avatar
    With the official 10.1 OS, I noticed things working perfectly in the substitution area. But with the leaked 10.2 I noticed the question mark doesn't tighten up to the end of a word.

    I'm hoping when the official 10.2 is released all will. Be back to normal.

    Posted via CB10
    09-06-13 02:32 AM
  3. Zedi Master's Avatar
    P.S. My ) (rb) works in 10.2.0.1047.

    Posted via CB10
    09-06-13 02:35 AM
  4. psarna's Avatar
    Mine doesn't seems to be ( working )!

    Posted via CB10 STL-100-1/10.2.0.1047
    09-06-13 02:48 AM
  5. Anonymous2039's Avatar
    It's odd that it works for some people but not for others. For me, it didn't work on 10.0, 10.1, 10.1 MR, or the leaked version 10.2.0.1443. I really hope BlackBerry fixes this issue.

    --Q10 and Canadian all the way!
    Last edited by chaz95; 09-14-13 at 08:19 PM.
    09-06-13 09:08 AM
  6. blackout626's Avatar
    Yea I noticed while setting up my phone on the first day that the %b command doesn't work. It's annoying as all heck because I used to use it to make possessive nouns where typing "s" and hitting the space key would back space and enter "'s". Now I gotta do the swipe, apostrophe, then s. On top of that, it doesn't really work with auto correct either. So if you're misspelling a name and auto correct is correcting it for you, you think, "cool, I'll just continue typing...," but as soon as you hit the apostrophe auto correct goes away and you're left with a misspelled possessive name. Gotta delete and retype the whole name correctly OR auto correct and add the "'s" manually which means the additional step of deleting the space auto correct added after the name. It's annoying.

    Posted via CB10
    09-06-13 10:17 AM
  7. Anonymous2039's Avatar
    They should make their Auto-Correct even smarter by taking into account these possibilities (id est, that if the user puts an apostrophe right after the word, include that in the wordlist).

    --Q10 and Canadian all the way!
    09-06-13 06:45 PM
  8. deiop's Avatar
    The funniest thing is: rb even works when it is not in my substitution list ;-)



    Q10&Z10 via BES10.X
    Northernlady01 likes this.
    09-07-13 12:41 AM
  9. Anonymous2039's Avatar
    Bump. Does anyone know if this problem was fixed in the official 10.2 on the Z30?

    --Q10 and Canadian all the way! Posted via CB10 on 10.2.0.1443. #IChooseBlackBerry10
    09-26-13 07:52 PM
  10. geenaxion's Avatar
    The funniest thing is: rb even works when it is not in my substitution list ;-)



    Q10&Z10 via BES10.X
    Same as mine. I deleted it but still works. New words don't work.

    Keepin' it Chill Z10
    09-27-13 10:19 AM
  11. queshw's Avatar
    It is a important issue for me. I hope BB fixing it with the next update.
    10-17-13 04:44 AM
  12. D3C0D3R's Avatar
    Okay so just tested this and it works perfectly on the Passport, I do believe it was just the leaked original 10.2.1 that showed those issues!

    Before:

    Word Substitution Macro "%b" Broken in BB10-img_20141011_192027.png

    After a space:

    Word Substitution Macro "%b" Broken in BB10-img_20141011_192029.png

    Hope that answers your question!

    Praise be unto our Lord Squircle | Passport SQW100-1/10.3.0.1154


    Edit:
    To clarify, it didn't do that for me prior to me adding it to the word substitution list!
    10-11-14 06:21 PM
  13. ZeroBarrier's Avatar
    Okay so just tested this and it works perfectly on the Passport, I do believe it was just the leaked original 10.2.1 that showed those issues!

    Hope that answers your question!

    Praise be unto our Lord Squircle | Passport SQW100-1/10.3.0.1154


    Edit:
    To clarify, it didn't do that for me prior to me adding it to the word substitution list!
    Try typing something in front of "rb", such as "qwerty rb". You're going to get "qwerty )" instead of "qwerty)" which is what it's supposed to be.

    Posted via CB10
    10-11-14 10:58 PM
  14. SharonRD's Avatar
    Yup, that's exactly what I've been trying to explain in my thread...but not doing a great job of it. lol Thanks ZB! And I gather it's still broken in 10.3.1. OS, from a reply I got about in the OS Leaks forum.

    Posted via CB10
    10-11-14 11:15 PM
  15. lifesupport's Avatar
    Yup, that's exactly what I've been trying to explain in my thread...but not doing a great job of it. lol Thanks ZB! And I gather it's still broken in 10.3.1. OS, from a reply I got about in the OS Leaks forum.

    Posted via CB10
    Sharon,

    Did you try it in a text message? BBM? I am finding that it is only not working in email. Works fine in text messages and BBM. (10.3.1.1154)
    12-08-14 02:21 PM

Similar Threads

  1. TunnelBear for BB10!!! EMAIL THE DEVS TO PUSH ITS RELEASE!
    By Dave Bourque in forum BlackBerry 10 Apps
    Replies: 7
    Last Post: 06-12-14, 02:37 AM
  2. The (In)Famous Battery Pull
    By Steve54 in forum BlackBerry Z10
    Replies: 68
    Last Post: 09-09-13, 09:21 PM
  3. Fairfax Financial interested in BlackBerry
    By freedomx20a in forum News & Rumors
    Replies: 16
    Last Post: 09-08-13, 09:31 AM
  4. BeBuzz from Bellshare for BB10
    By TheQuietRioter in forum BlackBerry 10 Apps
    Replies: 7
    Last Post: 09-06-13, 12:33 PM
  5. Unable to type in password? Help, please!
    By Kate Mac in forum BlackBerry Z10
    Replies: 4
    Last Post: 09-05-13, 11:30 PM
LINK TO POST COPIED TO CLIPBOARD