1. itzJustMeh's Avatar
    Ok, so I've had this issue since 10.2 or 10.2.1 and persists on 10.3.1. I have both English and Slovenian keyboard, but when I write "do" or "ok" it substitutes with ')' and '(' when I press space. As you might imagine it's a bit annoying. Any ideas? Wipe doesn't help.

    Word substitution bug?-img_20150314_123520.pngWord substitution bug?-img_20150314_123529.png
    03-14-15 07:43 AM
  2. baarn's Avatar
    I don't know the thinking as to why it does this with Slovenian , but you can work around it by using word substitution.
    Go to system settings->language and input->prediction and correction->word substitution->add shortcut.
    Add shortcuts mapping " ok" to "ok", and "so" to "so", adjusting the capitalization setting as you see fit, then you should be good to go.
    HTH.
    03-14-15 07:58 AM
  3. itzJustMeh's Avatar
    Yeah I thought about that solution, but.. does it really have to come to this? I'm thinking of reporting the bug
    03-14-15 01:25 PM
  4. baarn's Avatar
    If you think it's a bug, then report it if you can.
    03-14-15 02:48 PM
  5. Thorsten Heinsight's Avatar
    Ok, so I've had this issue since 10.2 or 10.2.1 and persists on 10.3.1. I have both English and Slovenian keyboard, but when I write "do" or "ok" it substitutes with ')' and '(' when I press space. As you might imagine it's a bit annoying. Any ideas? Wipe doesn't help.
    To identify the root of the problem, a quick google search tells me that the Slovenian word for 'bracket' is 'oklepaj' so I'm guessing this is a default word substitution set on the device in Settings > Language and Input > Prediction and Correction > Word Substitution. I assume there is a similar word related to brackets that starts with 'do'? Either removing these default word substitution or, as baarn said, mapping a new word substitution should fix your problem.
    It's interesting that you say this issue persists on 10.3.1 because I know on 10.2.1 "br" used to be a default word substitution that changed to a bracket, but they took it out of the default list on 10.3.1 as far as I can tell, so I'm surprised they didn't do the same for the Slovenian equivalent.
    03-16-15 12:02 PM
  6. itzJustMeh's Avatar
    To identify the root of the problem, a quick google search tells me that the Slovenian word for 'bracket' is 'oklepaj' so I'm guessing this is a default word substitution set on the device in Settings > Language and Input > Prediction and Correction > Word Substitution. I assume there is a similar word related to brackets that starts with 'do'? Either removing these default word substitution or, as baarn said, mapping a new word substitution should fix your problem.
    It's interesting that you say this issue persists on 10.3.1 because I know on 10.2.1 "br" used to be a default word substitution that changed to a bracket, but they took it out of the default list on 10.3.1 as far as I can tell, so I'm surprised they didn't do the same for the Slovenian equivalent.
    I don't think they would use works like these for substitution since 'do' is commonly used. I have reported this to JIRA, let's see what happens. But "ok" could be used as short for 'oklepaj' although it just sounds stupid
    03-16-15 03:07 PM

Similar Threads

  1. MAJOR Bug
    By SeanKent in forum BlackBerry 10 OS
    Replies: 14
    Last Post: 03-30-15, 11:54 AM
  2. Word Substitution Bug [10.3.1.2267]
    By RJMarc in forum BlackBerry Passport
    Replies: 1
    Last Post: 03-13-15, 10:58 PM
  3. Password Keeper bug? 10.3.1.2267
    By DocDRM in forum BlackBerry Passport
    Replies: 0
    Last Post: 03-13-15, 08:23 PM
  4. Is there a fix for BB 10.3.1 OS Screen flickering Bug?
    By CrackBerry Question in forum Ask a Question
    Replies: 5
    Last Post: 03-13-15, 01:06 PM
  5. Replies: 0
    Last Post: 03-12-15, 10:51 AM
LINK TO POST COPIED TO CLIPBOARD