1. rgordon44's Avatar
    Why can't BB bite bullet and fix Win 10.3 & BB Link incompatibility?

    Its ridiculous that I need an old Win 7 computer to backup BB 10.3!!
    05-29-17 09:10 AM
  2. anon(9742832)'s Avatar
    Why can't BB bite bullet and fix Win 10.3 & BB Link incompatibility?

    Its ridiculous that I need an old Win 7 computer to backup BB 10.3!!
    Because link is dead, that's why. It went with OS 10.
    05-29-17 12:09 PM
  3. joeldf's Avatar
    Why can't BB bite bullet and fix Win 10.3 & BB Link incompatibility?

    Its ridiculous that I need an old Win 7 computer to backup BB 10.3!!
    BB Link works fine on my Win 10 machine and Z10 with 10.3.2.

    Tell us more about your situation and maybe we can help you out.

    Did it ever work for you on Win 10? Have you tried un-installing and reinstalling Link? Do you have iTunes?

    Have you tried all the other previous suggestions on this forum about this issue over the past year?

    Joel
    05-29-17 01:38 PM
  4. rgordon44's Avatar
    Yes it worked on Win 10 prior to last 10.3.3.1435 BB OS update. OS Version 10.3.3.2163.
    Have uninstalled/reinstalled Link as well as itunes.
    BTW I have BB Leap.
    Thanks
    Last edited by rgordon44; 05-29-17 at 03:48 PM.
    05-29-17 03:31 PM
  5. joeldf's Avatar
    Sorry, I meant 10.3.3. I'm on 10.3.3.2205 (SR 10.3.3.1463).

    ITunes has broken Link in the past. Renaming one of its files solves it. I don't know which since I don't use iTunes. The two big Win 10 updates: the Anniversary update last year and the Creators update a couple months back also kills Link. But, a simple un-install, reboot, and reinstall fixes that (if it worked before the update).

    But, there are some instances where Link won't work and a resolution was never found. We don't know that the situation is that makes working impossible, but it's not consistent.

    Joel
    05-29-17 05:09 PM
  6. Henry Jr's Avatar
    I was trouble free until after a Windows update earlier this month. To resolve I uninstalled everything BlackBerry related, then rebooted. Then I downloaded and installed the Blend/Link/Drivers suite from BlackBerry and all was well again.

    Good luck!!

    Q10 (SQN100-3 : 10.3.3), Passport (SQW-100 : 10.3.3.1463)
    05-31-17 01:37 PM
  7. KemKev's Avatar
    I was trouble free until after a Windows update earlier this month. To resolve I uninstalled everything BlackBerry related, then rebooted. Then I downloaded and installed the Blend/Link/Drivers suite from BlackBerry and all was well again.

    Good luck!!

    Q10 (SQN100-3 : 10.3.3), Passport (SQW-100 : 10.3.3.1463)
    The whole thing is a bit of a crap shoot. Link works for some people on Windows 10. It no longer works for me on that OS and the application crashes on a freshly installed Windows 7 PC.
    05-31-17 01:52 PM
  8. rgordon44's Avatar
    I have BB 10.3.3, not 10.3.2.
    07-09-17 06:31 AM
  9. tipplex's Avatar
    For me it stopped working since I updated to 10.3.3

    Even if you install windows8.1 it doesnt work

    Posted via CB10
    07-09-17 11:12 AM
  10. joeldf's Avatar
    Again, it's hit and miss.

    I have a Win 8 Pro machine at work, and a Win 10 Home with Creators Update machine at home.

    Both 64-bit.

    Link works fine on both machines with my Z10 running 10.3.3.2205.

    I'm not running iTunes on either machine, but I did have to uninstall and reinstall Link after the Creators Update in the Win 10 PC.



    Joel
    07-09-17 01:45 PM
  11. scrannel's Avatar
    I thought it worked on Win 7, not 8.1 and again, does work on 10. Mine works fine.
    07-09-17 01:46 PM
  12. oystersourced's Avatar
    Link hasn't been able to backup for a long time my end, which is quite concerning.

    One of the most important things when running an old device is to ensure the data is recoverable when the inevitable happens, BlackBerry's failure to provide a suitable backup solution will be yet another commercial blunder.

    Posted via CB10
    07-10-17 01:31 PM
  13. oystersourced's Avatar
    I thought it worked on Win 7, not 8.1 and again, does work on 10. Mine works fine.
    Link worked fine on 8.1, it's never been supported on 10 but has occasionally worked flawlessly.

    Posted via CB10
    07-10-17 01:32 PM

Similar Threads

  1. Please i need solution to this (BB z10- STL-1) ?
    By romaan1231 in forum Ask a Question
    Replies: 47
    Last Post: 05-28-17, 05:10 PM
  2. How to Install BB pc suite without connecting Phone
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 05-28-17, 06:21 AM
  3. Moving Apps on BB Priv
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 05-27-17, 04:39 PM
  4. BBM Enterprise update for BlackBerry 10 and Android brings new features and improvements
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 05-26-17, 11:50 PM
LINK TO POST COPIED TO CLIPBOARD