10-08-16 06:23 PM
29 12
tools
  1. The Big Picture's Avatar
    Has anyone had any luck connecting their BlackBerry 10 phone with a WiFi enabled Sony, canon or panasonic camera?

    The only one which works for me so far is the nikon app.

    The rest gives me a password loop and I'm unable to complete the connection. I've been trying since 10.1

    Posted via CB10
    03-12-15 04:19 PM
  2. Tornado99's Avatar
    I got Olympus wifi to connect to all my BlackBerry devices. Trick was to disable data service prior to making the first connection. The Olympus wifi on the camera acts as a wifi Hotspot which the phone needs to detect, connect to then the app is launched by a Web url. If data plan is on, the Web url tries to open first via data plan on the Internet, not on the camera wifi Hotspot. Turning data off forces phone to look for the Web url on the camera hotspot.

    I'm pretty sure this is how most camera wifi's work.


    This Passport takes me places!
    03-13-15 12:14 AM
  3. The Big Picture's Avatar
    I got Olympus wifi to connect to all my BlackBerry devices. Trick was to disable data service prior to making the first connection. The Olympus wifi on the camera acts as a wifi Hotspot which the phone needs to detect, connect to then the app is launched by a Web url. If data plan is on, the Web url tries to open first via data plan on the Internet, not on the camera wifi Hotspot. Turning data off forces phone to look for the Web url on the camera hotspot.

    I'm pretty sure this is how most camera wifi's work.


    This Passport takes me places!
    Thank you for your input but i just tried this using my passport running 10.3.1.2248 and my sony nex6 camera with the playmemories app but its not working for me.

    The password loop is still there.
    03-14-15 02:11 PM
  4. gizmou's Avatar
    EOS Remote Android app for Canon works too

    Posted via CB10
    03-14-15 07:12 PM
  5. The Big Picture's Avatar
    EOS Remote Android app for Canon works too

    Posted via CB10
    That's great! Howw did you get it working? Which OS are you on?

    Posted via CB10
    Last edited by The Big Picture; 03-15-15 at 03:52 AM.
    03-15-15 12:28 AM
  6. presean's Avatar
    EOS Remote Android app for Canon works too

    Posted via CB10
    How did you do? Does all functions working, please tell us the process step by step

    Posted from my flawless BlackBerry Passport
    03-15-15 05:15 PM
  7. ferchu's Avatar
    Wmu for Nikon camera not work!
    03-15-15 06:26 PM
  8. The Big Picture's Avatar
    Wmu for Nikon camera not work!
    WMU for nikon works for me. Use WiFi and NOT WiFi direct. Which OS are you on?

    Posted via CB10
    03-16-15 12:55 AM
  9. ferchu's Avatar
    WMU for nikon works for me. Use WiFi and NOT WiFi direct. Which OS are you on?

    Posted via CB10
    Z10 10.3.1.2558 STL-1
    In my P600, run WiFi and in my Z10 try to connect to WiFi camera using SSID / Password of the camera. But not connect and WMU always say "camera not connected"
    03-16-15 09:02 AM
  10. The Big Picture's Avatar
    Has anyone managed to get canon's app to work? If so how? Any input would be much appreciated.

    Posted via CB10
    03-20-15 03:58 AM
  11. ALToronto's Avatar
    I'm struggling with the same issue with my Passport and the Sony QX100. There are two native apps in BlackBerry World that are supposed to work, and the dev of one of them has been helping me, but no success so far. I also downloaded two apps from 1Mobile, haven't tried them yet.

    Playmemories definitely will not work. Does anyone have contact info for the Sony development team? It really annoys me when developers deliberately ignore or shut out devices that are perfectly capable of running their peripherals, just to be jerks about it. So I'm in a letter writing mood.

    Posted via CB10 from my awesome Passport
    03-20-15 08:55 AM
  12. MPG Vancouver's Avatar
    Remote Shutter Pro works on my Z30 with 10.3.1 and my Sony a6000. The free version did not work, and Cristian, the developer, sent me a debug version which did work. I then happily bought the Pro version to support him.

    BTW, I read somewhere else on CB that the PlayMemories app makes a call to an unsupported function on the BlackBerry Android runtime.

    Posted via CB10
    03-20-15 12:02 PM
  13. presean's Avatar
    Has anyone managed to get canon's app to work? If so how? Any input would be much appreciated.

    Posted via CB10
    Me, you have to disable the cell network keep wifi and connect the through the SSID and pwd and launch the Canon Connect app you are ready to go!

    Posted from my flawless BlackBerry Passport
    03-20-15 04:26 PM
  14. The Big Picture's Avatar
    Me, you have to disable the cell network keep wifi and connect the through the SSID and pwd and launch the Canon Connect app you are ready to go!

    Posted from my flawless BlackBerry Passport
    Thanks man I'll try this.

    Posted via CB10
    03-21-15 10:33 AM
  15. tmf06's Avatar
    Thanks man I'll try this.

    Posted via CB10
    any update - did this work for you as well?

    Also, is your Nikon app still working with the latest 10.3.1?
    04-18-15 11:28 AM
  16. clsaah's Avatar
    Anyone get the panasonic image app to work?

    Posted via CB10
    04-18-15 11:57 AM
  17. Sergeant_Im's Avatar
    Z10 does not support wifi direct. You'll need to connect both the phone and camera to a hotspot or router to get em working together.

    Posted via CB10
    04-19-15 09:44 AM
  18. The Big Picture's Avatar
    any update - did this work for you as well?

    Also, is your Nikon app still working with the latest 10.3.1?
    I couldn't get Sony playmemories to work with my PassportSQW100-1/10.3.2.500.

    Nikon WMU has always worked for me.

    When I get the chance I'll test canon and panasonic

    Posted via CB10
    04-20-15 12:41 PM
  19. ferchu's Avatar
    I couldn't get Sony playmemories to work with my PassportSQW100-1/10.3.2.500.

    Nikon WMU has always worked for me.

    When I get the chance I'll test canon and panasonic

    Posted via CB10
    I have no luck !
    04-20-15 01:23 PM
  20. ferchu's Avatar
    Z10 does not support wifi direct. You'll need to connect both the phone and camera to a hotspot or router to get em working together.

    Posted via CB10
    Can you just do it with WMU and Nikon camera?
    04-23-15 08:28 AM
  21. tmf06's Avatar
    So I picked up a Nikon wifi camera for my wife yesterday. The camera connected easily to her Q10 on 10.2.1 with the Android wmu app (well, easily after I realized it needed an SD card inserted in order to connect).

    I didn't spend a lot of time, but it would not work with my z10 on 10.3.1. It would connect, but hang up. The camera would say "negotiating" for a long time and eventually disconnect.



     Posted via Z10 
    04-23-15 12:27 PM
  22. ferchu's Avatar
    So I picked up a Nikon wifi camera for my wife yesterday. The camera connected easily to her Q10 on 10.2.1 with the Android wmu app (well, easily after I realized it needed an SD card inserted in order to connect).

    I didn't spend a lot of time, but it would not work with my z10 on 10.3.1. It would connect, but hang up. The camera would say "negotiating" for a long time and eventually disconnect.



     Posted via Z10 
    IDEM
    04-23-15 12:50 PM
  23. Sergeant_Im's Avatar
    Can you just do it with WMU and Nikon camera?
    I don't have a Nikon camera or ever used one, so can't confirm on that.

    Posted via CB10
    04-25-15 01:26 AM
  24. Thasitis's Avatar
    Same here. Nikon WMU is running on my Passport (10.3.1.2708) but the WIFI-Connection to my Nikon 1 V3 and to my Nikon D750 is not working. It starts connecting to the camera but after a while it is failing. This was working on my Z10 running 10.2.2.

    Posted via CB10
    04-25-15 04:39 PM
  25. The Big Picture's Avatar
    I can confirm now that Nikon wmu only works with 10.2.1

    Posted via CB10
    ferchu likes this.
    06-26-15 08:19 AM
29 12

Similar Threads

  1. z30 or Leap?
    By JoseMercedes in forum BlackBerry Leap
    Replies: 145
    Last Post: 12-13-16, 07:13 PM
  2. Replies: 15
    Last Post: 03-17-15, 10:47 AM
  3. New App: myHomeScreen with REAL Widgets
    By Smiley88 in forum App Announcements
    Replies: 13
    Last Post: 03-13-15, 01:29 AM
  4. How do I send a video to my email with my Blackberry Bold 9900?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 03-12-15, 04:55 PM
LINK TO POST COPIED TO CLIPBOARD