12-22-15 12:58 PM
30 12
tools
  1. steve85grrr's Avatar
    Greetings,

    I bought a z30 a few days ago. Up until now I am really satisfied from the device. However I'm facing an issue with the Wifi connection. It might work fine for hours, but suddenly the connection drops and I get a "limited Internet connectivity " message. The strange thing is that all the devices on the same network get disconnected. For example in my laptop I get prompt to enter the Wifi password. The connection will remain down unless I restart the router. It seems like a Wifi security issue. However both the router and the phone are configured to have wpa/2 security.

    Any help is welcome. I would not like to change that phone because in general I'm satisfied from it.

    Best Regards,
    Asterios

    Posted via CB10
    11-24-13 06:55 AM
  2. Branta's Avatar
    It sounds like you are seeing a problem at the router if all devices lose service at the same time. I had a similar problem recently, finally resolved by replacing the router. It seems that the ISP had "upgraded" the service and dropped compatibility with older implementations of ADSL.

    If you still have connection between your router and a computer (most routers have a browser interface), login the the router and take a look at the status, router log, etc for more clues. If my guess is right the router log will show frequent attempts to authenticate and reconnect to the ISP.
    11-24-13 09:14 AM
  3. joelwsmith84's Avatar
    Agreed - this does point to a router issue.

    My z10 will receive the same alert when the WiFi connection starts dropping too many packets. This could be due to a failing router or you're overloading the radio stream. I've seen this happen when I'm moving a lot of traffic over the wireless connection from another PC in the network.
    11-24-13 09:27 AM
  4. crackbb10's Avatar
    This also happens a lot when multiple routers are in close proximity of each other.. the different signals interfere with each other causing you to lose the connection on all devices...

    A simple reset of the router does the job mostly, but it will keep happening.. Check if your main router can be placed away from other routers and see if your problem keeps occurring...

    From the Z...
    11-24-13 09:34 AM
  5. steve85grrr's Avatar
    Unfortunately guys I don't think that is the router's fault. Everything works fine when the phone is not connected. Only when I connect the z30 the network collapse. Probably there is a clash between them.
    The same thing happened when I went to a friends house for half a day.

    Best Regards,
    Asterios

    Posted via CB10
    11-24-13 03:12 PM
  6. kshehab's Avatar
    I face this problem often. I usually restart my router every time the message occurred. This is really annoying! My laptop, iPad and iPod work fine except my Z10.

    Posted via CB10
    11-24-13 03:31 PM
  7. steve85grrr's Avatar
    Oh f**k.. I hope that there will be a solution to this problem. In my opinion it will have to do with the configurations...

    Posted via CB10
    11-24-13 03:41 PM
  8. crackbb10's Avatar
    I must say that my problem of limited network access has disappeared since I removed all other routers... On the other hand, I also logged off BlackBerry Link on my desktop since then.. It could be that BlackBerry Link was causing the problem because it's constantly trying to connect and maintain the WIFI...

    I'll log back in on BlackBerry Link to see if the problem returns..

    From the Z...
    11-25-13 07:19 AM
  9. steve85grrr's Avatar
    I have not even installed blackberry link. My device is a few days old! This problem begun from the first day.

    Regards.

    Posted via CB10
    11-25-13 10:00 AM
  10. crackbb10's Avatar
    Okay, that's really weird... Have you also tried deleting your WIFI from the device and set it up again..?

    From the Z...
    11-25-13 11:22 AM
  11. Couver81's Avatar
    There is a similar thread about this issue in the Z10 forums. For some people it seemed that switching over to a WPA connection worked but for others including myself the problem remained. I think crackbb10 outlined the issue. I think it is too many routers confusing the phone. I live in an apartment so a lot of tenants have routers that the phone can pick up.

    I usually don't restart the router though when the connection drops. You should be able to go in and just have it connect again. Under the Wi-Fi settings just hit either the connect option in the upper right corner or the connect option at the bottom of the screen. It authenticates again and then connects.
    11-25-13 11:30 AM
  12. steve85grrr's Avatar
    Greetings guys,
    I don't think that my case is the same. I live in a rural area and there are only 2-3 more networks with different names (ssids). When I try to reconnect I have no result. The only way is to restart the router :/. As I said before on my phone I get the limited connection message and on my laptop I get a prompt to enter the Wifi password but even if I give the password nothing happens until the router is restarted.

    Regards

    Posted via CB10
    11-25-13 11:47 AM
  13. ppeters914's Avatar
    Brand & model of your router?
    11-25-13 04:57 PM
  14. steve85grrr's Avatar
    TP-LINK, Model : TL-WR740N
    Although the router works fine when the phone is not connected. I had the same problem when I went to a friend's house who has a completely different modem.

    Regards

    Posted via CB10
    11-25-13 05:44 PM
  15. lord_hibiskus's Avatar
    TP-LINK, Model : TL-WR740N
    Although the router works fine when the phone is not connected. I had the same problem when I went to a friend's house who has a completely different modem.

    Regards

    Posted via CB10
    I had exactly same problem with same router model and Z10. It's not router fault, it has something to do with bb10, i resolved issue with changing wifi mode to b/g (without n) and changing channel. This solution solved 90% of my router hangups. Hope it helps
    11-25-13 06:05 PM
  16. Branta's Avatar
    I had exactly same problem with same router model and Z10. It's not router fault, it has something to do with bb10, i resolved issue with changing wifi mode to b/g (without n) and changing channel. This solution solved 90% of my router hangups. Hope it helps
    I don't see how a problem in BB10 could cause the OP's notebook to drop connection AND request the WiFi password. Password is normally saved in each device's wifi settings and doesn't normally need to be entered again - and a different device should not be able to cause the laptop to dump stored password.

    The only other possible solution that comes to mind is to check software versions, for both the router and possibly for the Z30 (is there an update or good leak for Z30 yet?). After that it gets to heavy duty troubleshooting, maybe shutting down wifi on all devices then testing one at a time to see which one (or combination) causes the problem.
    11-25-13 09:30 PM
  17. crackbb10's Avatar
    There is a similar thread about this issue in the Z10 forums. For some people it seemed that switching over to a WPA connection worked but for others including myself the problem remained. I think crackbb10 outlined the issue. I think it is too many routers confusing the phone. I live in an apartment so a lot of tenants have routers that the phone can pick up.

    I usually don't restart the router though when the connection drops. You should be able to go in and just have it connect again. Under the Wi-Fi settings just hit either the connect option in the upper right corner or the connect option at the bottom of the screen. It authenticates again and then connects.
    I can confirm this.. I would go into troubleshooting on my laptop and it would automatically reconnect, although I had to resort to restarting the router from time to time as troubleshooting didn't always resolve the problem...

    You can try the troubleshooting method and see if that helps you in any way...

    From the Z...
    11-25-13 10:11 PM
  18. qwerty4ever's Avatar
    This also happens a lot when multiple routers are in close proximity of each other.. the different signals interfere with each other causing you to lose the connection on all devices...

    A simple reset of the router does the job mostly, but it will keep happening.. Check if your main router can be placed away from other routers and see if your problem keeps occurring...

    From the Z...
    Two neighbours have WiFi which interferes with my WiFi routers. Since I have multiple WiFi routers I configure them on widely dispersed channels. I can guarantee that my neighbours' routers are broadcasting on a very high power level since I can be outdoors and their signals are strong.

    Posted via CB10 from the BlackBerry Z10
    11-26-13 05:43 AM
  19. menshawy's Avatar
    I don't think BlackBerry can have impact on your home network and the devices connected to it.

    Open your router settings, check the other wifi networks around you on which channels they are and figure out a clean channel for your self
    11-26-13 05:50 AM
  20. steve85grrr's Avatar
    Guys it has to do with the blackberry. When the phone is not connected I don't have these problems. This issue started the last few days since I bought the device.

    Hibiskus could you please tell me where exactly on the router's page I can find these configurations and what channel do you use now as well?? I will check it out later in the day as I'm at work at the moment

    Posted via CB10
    11-26-13 06:48 AM
  21. i_hiker's Avatar
    You'll most likely need the default address for your router. You can "google" your model number and get it as well as default passwords. You might need them. Enter the address in your browser and router setting pages should pop up. This is where you might need a password to change any setting. The page to change the channel should be easy to find. You'll want to go to channel 1 or 11. The default is channel 6.

    I agree there is something amiss with the BlackBerry WiFi. I've spoken with tech support and they seem to be in denial. There are other threads and symptoms about this. Good luck.

    Posted via CB10
    11-26-13 07:26 AM
  22. crackbb10's Avatar
    Guys it has to do with the blackberry. When the phone is not connected I don't have these problems. This issue started the last few days since I bought the device.

    Hibiskus could you please tell me where exactly on the router's page I can find these configurations and what channel do you use now as well?? I will check it out later in the day as I'm at work at the moment

    Posted via CB10
    What you say is true.. I've also only had this problem since the Z moved in with me.. However, there are workarounds... I don't recall having this issue since I started to make some changes to my network... Try out the router settings from your browser as explained in the previous post... It shouldn't be this way, but it is what it is...

    From the Z...
    11-26-13 08:17 AM
  23. lord_hibiskus's Avatar
    I don't see how a problem in BB10 could cause the OP's notebook to drop connection AND request the WiFi password. Password is normally saved in each device's wifi settings and doesn't normally need to be entered again - and a different device should not be able to cause the laptop to dump stored password.

    The only other possible solution that comes to mind is to check software versions, for both the router and possibly for the Z30 (is there an update or good leak for Z30 yet?). After that it gets to heavy duty troubleshooting, maybe shutting down wifi on all devices then testing one at a time to see which one (or combination) causes the problem.
    I am quite sure there is something within BB10 that makes some router models to crash, cause so far i unintentionally managed to crash at least 5 different models, including big mess I made when f... up router in journalists lounge on my nationals team soccer game. All journalists(20) were unable to send anything through wifi.
    11-27-13 09:25 AM
  24. lord_hibiskus's Avatar
    Hibiskus could you please tell me where exactly on the router's page I can find these configurations and what channel do you use now as well?? I will check it out later in the day as I'm at work at the moment

    Posted via CB10
    my procedure was:
    1. in browser adress bar i type 192.168.0.1 with is Ip of my router in LAN
    2. type in user name and password(default is admin/admin)
    3. Click wireless, than wireless settings, my settings are Channel: auto, Mode: 11bg mixed, Channel width 20mhz. Click save
    4. wireless security: choose WPA-personal, (put name/password if you didnt do it yet) and that should be it

    With automatic settings I couldn't use wifi at all, cause it crashed after few minutes. With these settings I wrote, i have wifi crash maybe once or twice in 15 days. I actually enabled wifi transfer on phone now (and that was just a wish before).

    Sorry for double post mods.
    11-27-13 09:37 AM
  25. qwerty4ever's Avatar
    I don't think BlackBerry can have impact on your home network and the devices connected to it.

    Open your router settings, check the other wifi networks around you on which channels they are and figure out a clean channel for your self
    The channel bands (B/G/N) can sometimes be affected by a BlackBerry 10 smartphone. I suggest limiting the channel band to only one of the options at first only on the smartphone, then only on the router, and finally on both smartphone and router.
    11-27-13 11:00 AM
30 12

Similar Threads

  1. Bold 9900 Hotel Wifi No BBM
    By 2minutes4 in forum BlackBerry Bold 9930/9900
    Replies: 5
    Last Post: 02-28-14, 11:13 AM
  2. Fix for wifi not working?
    By Puneet Kohli in forum BB10 Leaked/Beta OS
    Replies: 12
    Last Post: 11-23-13, 04:43 PM
  3. Z30 still downloading from network even connected to WIFI?
    By jeremyhass368 in forum BlackBerry Z30
    Replies: 2
    Last Post: 11-22-13, 07:05 PM
  4. Standalone Wifi Calling
    By Danny Ocean in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 11-22-13, 06:34 PM
  5. Wifi App similar to BB Bridge
    By mnhockeycoach99 in forum BlackBerry Z10
    Replies: 1
    Last Post: 11-22-13, 03:46 PM
LINK TO POST COPIED TO CLIPBOARD