1. justinriddoch's Avatar
    I have a Blackberry Classic running 10.3.1 and I just noticed that my sent emails are disappearing from my device. The message does get delivered but no where, neither on my phone or on my email account (Gmail provided by my University) , does the sent email show up. When I send an email from any other device the sent email appears on the email server and on my blackberry. It is only emails sent from the blackberry that disappear. Also, this is only happening with one of my email accounts, all my other accounts, including a second personal gmail account work fine.

    Any help would be greatly appreciated, thank you!
    05-13-15 06:02 PM
  2. jaydee5799's Avatar
    in your gmail account on your PC under AllMail you don't see the sent ones?
    05-13-15 08:31 PM
  3. justinriddoch's Avatar
    I don't have an All Mail folder but I have inbox and sent, and they do not appear in the sent folder. Emails sent from other devices (laptop, desktop, ipad) all appear in the sent folder.
    05-13-15 09:34 PM
  4. joeldf's Avatar
    I don't know about Gmail, but there is something you can check on the BlackBerry.

    While in the Hub, pick the 3 dots at the bottom. Pick "Settings", select "Display and Actions". Make sure that the "Show Sent Emails" toggle is turned on.

    That's all I can suggest.

    Posted via CB10
    05-14-15 09:20 AM
  5. justinriddoch's Avatar
    Thanks for the suggestion, but yeah show sent emails is toggled on. I do see sent emails, so long as they are not sent from the blackberry. Only emails sent from the blackberry disappear.
    05-14-15 10:14 AM
  6. AnnieCP's Avatar
    I have the same problem with my ntlworld email account. Any emails I send from there just disappear as soon as they're sent. They don't show up anywhere. So there are times when I can't use my BlackBerry to send emails if I want definite proof of having sent an email.

    Posted on my Z30, on EE in the UK
    05-14-15 06:30 PM
  7. TheBirdDog's Avatar
    I've also had this happen. However, mine come back after a few minutes. Try refreshing the hub, see if that works.

    I don't know why but it seems like they 'outbox' stage of sending them is bypassed and they, instead, just disappear. They should show up again though.

    Posted via my BlackBerry Passport
    05-14-15 06:52 PM
  8. justinriddoch's Avatar
    Unfortunately mine haven't been reappearing, not on the phone or on the server. Literally disappearing! I think it might have something to do with the folder mapping but I am not sure how to fix it.
    05-15-15 08:40 AM
  9. Stef007's Avatar
    Did you try to remove the account as re-add it?

    Posted via CB10 on my awesome  Z(en) Ten
    05-15-15 09:08 PM
  10. justinriddoch's Avatar
    Yes I have tried removing and re-adding the account, it also didn't work. I'm still looking for a solution, will post back if I find anything out because it looks like there are a few people having the same problem.
    05-18-15 04:40 PM
  11. justinriddoch's Avatar
    If I BCC myself the message will reappear after disappearing and will show up on the server/other devices. Now if only there was an auto BCC option this would be solved....

    Hopefully this information can lead me/others to a real solution. Let me know if anyone has suggestions.
    05-18-15 11:18 PM
  12. Lostfile's Avatar
    I'm having the same problem after my company switched from a Gmail business account to some other service I've never heard of. It's slightly terrifying when I'm sending invoices from my phone and the email just disappears leaving me to have to remember which emails I've sent. 'Show sent email' is also on and my sent folder is empty.
    05-20-15 07:34 AM
  13. VictorRight's Avatar
    Same problem here on my att account with the Sent emails not all are showing up on my BlackBerry. I search for particular ones I had sent from my BlackBerry with no result. I also noticed that not all my incoming email are reaching my BlackBerry. The email shows in the inbox on my desk top and laptop pc units and not on my BlackBerry. Not all messages are failing to arrive on my BlackBerry just some.

    Posted via CB10
    05-21-15 04:00 PM
  14. Dave Bourque's Avatar
    Make sure that the Gmail Sent folder in hubs got a green refresh circle on top of it. I can see my sent emails

    Posted via CB10
    05-21-15 04:10 PM
  15. justinriddoch's Avatar
    Mine is showing a green sync circle, but I only see sent emails sent from my blackberry if I BCC my self. Sent emails from other devices else do get pushed to the blackberry though.
    05-21-15 07:00 PM
  16. Dilian's Avatar
    I had the same problem. I'm runing a classic under 10.3. When i sent an email there was no copy from it on any of the linked devices with my email.
    The solution turned out to be quite simple. On your email account setting when you go in the meny "Edit account" on the bottom of the menu is an option "Append messages to sent folder". You must swith on this option and you will see the sent email on all devices ( for me this is my bb classic, mozzila thunderbird on my lap top and on the email server, where my account is).
    This worked fine for me. I hope this will solve the problem for you too.
    08-21-15 09:35 AM
  17. ppeters914's Avatar
    Must be a Gmail or 10.3.1 thing as that setting doesn't exist for me (Comcast).

    Posted via CB10 / AT&T /Z10 STL100-3 /10.3.2.2239
    08-21-15 10:34 AM
  18. justinriddoch's Avatar
    I had the same problem. I'm runing a classic under 10.3. When i sent an email there was no copy from it on any of the linked devices with my email.
    The solution turned out to be quite simple. On your email account setting when you go in the meny "Edit account" on the bottom of the menu is an option "Append messages to sent folder". You must swith on this option and you will see the sent email on all devices ( for me this is my bb classic, mozzila thunderbird on my lap top and on the email server, where my account is).
    This worked fine for me. I hope this will solve the problem for you too.
    Thanks for the suggestion Dillian but I have already tried that, unfortunately it didn't help.*

    Ppeters, my account with the issue is a Gmail education account. The option does show up (and also shows up for my regular gmail account), so I'm not sure why you don't see it.
    08-21-15 10:45 AM
  19. liapa's Avatar
    thank you Diian! looks like it soved my issue. so annoying!
    02-01-18 04:00 PM

Similar Threads

  1. Replies: 11
    Last Post: 10-06-16, 09:23 AM
  2. Is the selfie stick compatible with blackberry z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 15
    Last Post: 01-30-16, 09:44 PM
  3. Will there be a BB10 flip?
    By Stuartgd in forum BlackBerry Priv
    Replies: 21
    Last Post: 06-07-15, 08:21 AM
  4. Replies: 2
    Last Post: 05-15-15, 01:25 PM
  5. Google/blackberry map data usage abroad
    By amjass12 in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 05-13-15, 05:19 PM
LINK TO POST COPIED TO CLIPBOARD