1. Austin Ralf's Avatar
    Why is it everyone says that BB10.3.x. is faster than 10.2.x? Since March 2015 I have had to deal with this dog of a phone that used to be super fast. Btw I'm using a Z10 that I used to love but now am just stuck with. Nothing about 10.3.x in general is faster than 10.2.x I wish I could downgrade it's that bad. Factory resetting and security wiping did no help. It literally takes 10-15 seconds sometimes to open anything. Browser Sucks now, can't use it with out it lagging and freezing up on me to the point where I have to exit out of the app and reopen it. And my phone randomly locks on me when I try to do stuff now. I have all advanced interactions turned on and screen timeout at 5 minutes. I can't wait till I get the money to buy a priv. Maybe android is the fix to all these issues.
    12-28-15 01:15 AM
  2. gugomat's Avatar
    Z10? You seriously thinks that a phone that was made a few years ago would work as a brand new device? Get the z30 if you enjoy the OS10, or any of the Android device. Just wondering why did you started this thread? To let us know that your phone doesn't work as you have expected? OK, I have got an opposite opinion on my Q10. It works great with the last BlackBerry official OS. But last month I understood that I need to move ahead and got me a brand new Passport. And now both my devices works really great. Guess the BlackBerry OS is just not for you.

    Posted via CB10
    12-28-15 01:59 AM
  3. akavbb's Avatar
    I have a Ζ10 along with my passport and it's superfast. Maybe you have a hardware issue. Or maybe possibly an app lagging your phone.
    You can check in settings and see what is ducking your CPU or your ram.
    If it's the pim services then check if you have a problem with your account settings.

    Nothing like my SE.
    12-28-15 02:08 AM
  4. Austin Ralf's Avatar
    I understand that my phone is from 2013 with 2012 hardware but every time I try to search why it is doing something everyone says that BB10.3 is so fast. I have had my Z10 since 2013 and loved it but it gets slower with every new software release where everyone else claims speed gains. I dreaded the day my Aunt asked me to upgrade her Q5 to 10.3 Because now it is slow to. My Q10 I also own and lost slowed right down on 10.3.2 to. I love BB10 os. I used to brag to people about it and even made a friend buy one. I have factory reset and looked at the apps running using app manager, I'm not new to BB10 and have tried everything I have done in the past to speed it up but nothing seems to work.
    12-28-15 04:06 PM
  5. th.1977's Avatar
    I'm using a z10 and it's quick for the most part. One glitch I that can think of is in some messaging apps I can type faster than my z can put it out and it repeats the previous typed words rather than what I have pounds out. But that's only a few that are android apps from Amazon. Other than that my z is perfect

    Posted via CB10
    12-28-15 04:43 PM
  6. paulwallace1234's Avatar
    10.2.1 was much more stable, speed wise is about the same

    Posted via CB10
    12-28-15 04:45 PM
  7. david7saad's Avatar
    Try a z30. Even on 10.3.xxx os, no laggy and so fast in z30... Z10 is crap

    Posted via the CrackBerry App for Android
    12-28-15 04:54 PM
  8. Austin Ralf's Avatar
    I agree with more stable but speed has decreased for most part.
    Last edited by Austin Ralf; 12-28-15 at 09:49 PM.
    12-28-15 04:58 PM
  9. paulwallace1234's Avatar
    Try a z30. Even on 10.3.xxx os, no laggy and so fast in z30... Z10 is crap

    Posted via the CrackBerry App for Android
    Really?
    My z30 wholeheartedly disagrees, it ran beautifully on 10.2.1 and it runs like a sack of s*ht on 10.3.*

    Posted via CB10
    12-28-15 05:29 PM
  10. Austin Ralf's Avatar
    That's exactly what happened to my Z10. Ran super fast on 10.2.1 and all 10.3 updates run kinda sh**y. On a really good day it's pretty good but most time is sub par anymore. Although it is still faster than my BFF'S iPhone 5C so that's good I guess.
    12-28-15 09:48 PM
  11. mulderlr's Avatar
    Not sure what you're talking about. 10.3.2 is very clean and stable. Sounds like you have apps or games installed that your device doesn't like or something else going on. My 4 kids all have Z10's running the latest 10.3.2 and it runs smoother than anything on 10.2. And trust me, I'm not some fan Boi that would blow smoke on these forums to make someone feel badly about the fact their device isn't performing well. I cannot tolerate a slow device and whenever something comes up, my kids (all teenagers) would tell me right away because they are basically spoiled with bb10. I hope you can track it down because it is totally possible to have a good 10.3.2 experience on a Z10 despite how old the device is - it is still on par with a lot of devices being released today that are 16GB smartphones assuming you keeps app load reasonable and keep enough free space on the device.

    Typed from my AT&T passport
    12-28-15 10:40 PM
  12. pgg101's Avatar
    Why is it everyone says that BB10.3.x. is faster than 10.2.x? Since March 2015 I have had to deal with this dog of a phone that used to be super fast. Btw I'm using a Z10 that I used to love but now am just stuck with. Nothing about 10.3.x in general is faster than 10.2.x I wish I could downgrade it's that bad. Factory resetting and security wiping did no help. It literally takes 10-15 seconds sometimes to open anything. Browser Sucks now, can't use it with out it lagging and freezing up on me to the point where I have to exit out of the app and reopen it. And my phone randomly locks on me when I try to do stuff now. I have all advanced interactions turned on and screen timeout at 5 minutes. I can't wait till I get the money to buy a priv. Maybe android is the fix to all these issues.
    I'm wondering if there is an app causing problems? After you reload the OS, do you restore a backup? If so, try to download apps one by one to see if that is it.

    I have a Z10 on 10.3.2 and it works fine. No lag.

    RedBerry Passport /10.3.2.2876 / Telus
    12-28-15 10:47 PM
  13. Austin Ralf's Avatar
    I'm wondering if there is an app causing problems? After you reload the OS, do you restore a backup? If so, try to download apps one by one to see if that is it.

    I have a Z10 on 10.3.2 and it works fine. No lag.

    RedBerry Passport /10.3.2.2876 / Telus
    I never reinstall back up as I feel like I'm just going to re add the problem. I love the phone when it works. I still refuse to buy anything apple as your just paying for brand name.
    12-28-15 10:49 PM
  14. Austin Ralf's Avatar
    Not sure what you're talking about. 10.3.2 is very clean and stable. Sounds like you have apps or games installed that your device doesn't like or something else going on. My 4 kids all have Z10's running the latest 10.3.2 and it runs smoother than anything on 10.2. And trust me, I'm not some fan Boi that would blow smoke on these forums to make someone feel badly about the fact their device isn't performing well. I cannot tolerate a slow device and whenever something comes up, my kids (all teenagers) would tell me right away because they are basically spoiled with bb10. I hope you can track it down because it is totally possible to have a good 10.3.2 experience on a Z10 despite how old the device is - it is still on par with a lot of devices being released today that are 16GB smartphones assuming you keeps app load reasonable and keep enough free space on the device.

    Typed from my AT&T passport
    See your like me. Everyone I know who has a bb10 device (especially my aunt and her boyfriend) always come to me when they have issues. I am always able to solve their issues no problem. But I can not seem to be able to speed up my device. My Q10 before I lost it was the same way. Lightning fast on 10.2.1 and slow on every 10.3 release (I had my Z10 before Q10, Z10 was first bb10 device I ever owned).
    12-28-15 11:24 PM
  15. Tomisinn's Avatar
    i copied this

    ionutsirbu2020
    Contributor
    ionutsirbu2020
    Posts: 17
    Registered: ‎02-28-2015
    My Device: Q5
    My Carrier: Wifi
    Solution! Re: How to DOWNGRADE from OS 10.3 to 10.2?!
    Options
    ‎03-07-2015 03:47 AM

    Hi Robdob,

    I used an Autoloader to downgrade from OS 10.3 to 10.2.

    Here is the solution that user bhrhr77 gave me: https://supportforums.blackberry.com...no-signal-afte...

    For me it worked with the Autoloader. If you need more details, just contact me.

    I hope you will fix it!
    12-30-15 01:59 AM
  16. paulwallace1234's Avatar
    i copied this

    ionutsirbu2020
    Contributor
    ionutsirbu2020
    Posts: 17
    Registered: ‎02-28-2015
    My Device: Q5
    My Carrier: Wifi
    Solution! Re: How to DOWNGRADE from OS 10.3 to 10.2?!
    Options
    ‎03-07-2015 03:47 AM

    Hi Robdob,

    I used an Autoloader to downgrade from OS 10.3 to 10.2.

    Here is the solution that user bhrhr77 gave me: https://supportforums.blackberry.com...no-signal-afte...

    For me it worked with the Autoloader. If you need more details, just contact me.

    I hope you will fix it!
    You cannot downgrade from 10.3.2

    Posted via CB10
    12-30-15 02:08 AM
  17. Sir Reaper's Avatar
    My Z30's browser is terrible since 10.3.2 it's laggy, regularly bombs out and numerous websites tell me that my browser is outdated and not supported. The rest of the phone works pretty much the same except that when opening any message and starting to type immediately I lose the first word I type and I get the second word twice. Have done all the resets and what not and it still does it.

    Posted via CB10
    12-30-15 02:22 AM
  18. menshawy's Avatar
    That's weird because Z10 runs faster on 10.3 I've seen it myself and my friends too.



    Posted via CB10
    12-30-15 03:01 AM
  19. Austin Ralf's Avatar
    My Z30's browser is terrible since 10.3.2 it's laggy, regularly bombs out and numerous websites tell me that my browser is outdated and not supported. The rest of the phone works pretty much the same except that when opening any message and starting to type immediately I lose the first word I type and I get the second word twice. Have done all the resets and what not and it still does it.

    Posted via CB10
    My browser is like this a lot now but only on certain sites. It'll work like a breeze I accidentally click on something that has to do with Tumblr and it all lags freezes up and I ha e to close the app and reopen it twice.
    12-30-15 10:09 AM
  20. Austin Ralf's Avatar
    That's weird because Z10 runs faster on 10.3 I've seen it myself and my friends too.



    Posted via CB10
    10.3 in general has never been speedy for me and even to this day I find the OS and ui uglier than before. I miss the box around the icons and how they were textured and not flat. Smh.
    12-30-15 10:11 AM
  21. elfabio80's Avatar
    Did your try to reload the firmware via BlackBerry Link? It solved my problems. I had to lose a bit of time in order to reload all the apps, without back up!! You may give a try!

    Posted via CB10
    12-30-15 10:26 AM
  22. Austin Ralf's Avatar
    Did your try to reload the firmware via BlackBerry Link? It solved my problems. I had to lose a bit of time in order to reload all the apps, without back up!! You may give a try!

    Posted via CB10
    Yes. More than once. Tried this also on my Q10 before I lost it.

    Posted via CB10
    12-30-15 10:27 AM
  23. ZeBB45's Avatar
    10.3 in general has never been speedy for me and even to this day I find the OS and ui uglier than before. I miss the box around the icons and how they were textured and not flat. Smh.
    I know how you feel with the flattened-icon, plain OS theme baked into 10.3+ I miss how elegant the OS was on 10.2 .....

    Q10 - 10.3.2.2813/SR .2530  < α∂∂ιт > 
    12-30-15 04:59 PM
  24. Austin Ralf's Avatar
    I know how you feel with the flattened-icon, plain OS theme baked into 10.3+ I miss how elegant the OS was on 10.2 .....

    Q10 - 10.3.2.2813/SR .2530  < α∂∂ιт > 
    I miss the speed most of all.
    12-30-15 05:08 PM

Similar Threads

  1. Uber app finally works with Blackberry 10 OS!!!
    By novapolskas in forum BlackBerry 10 OS
    Replies: 71
    Last Post: 02-22-16, 12:34 AM
  2. Why won't the google play app load?
    By CrackBerry Question in forum Android Apps
    Replies: 1
    Last Post: 12-28-15, 04:49 PM
  3. Instant preview duration. Can it be extended?
    By pohlipit in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 12-28-15, 01:57 AM
  4. My BlackBerry Q10 sent error BB10-0015, how do I fix it?
    By CrackBerry Question in forum BlackBerry Q10
    Replies: 1
    Last Post: 12-27-15, 06:28 PM
  5. Replies: 1
    Last Post: 12-27-15, 05:43 PM
LINK TO POST COPIED TO CLIPBOARD