10-01-14 03:27 PM
36 12
tools
  1. Completing's Avatar
    For some absurd reason, I can only use BBM when connected to WiFi.

    Yes, I have a data plan (everything else, that also uses TCP/IP works just fine), and yes, have done the "About > Network > ... Register Device" song and dance countless times. Has no effect what so ever.

    What makes it really absurd is that Android version of BBM works just fine in this same network with same data plan on a Android phone.

    1) BB phones are not sold by any carriers over here
    2) there is no BB specific data plan (see 1)
    3) Phone is not locked to any carrier
    4) and yes, data connection is available and all the other apps, that need connection to internet work just fine
    5) I can see my BBM contacts status (Available) but messages are not delivered (has a small clock icon)

    Ideas how to resolve this problem are welcome.
    09-15-14 03:32 AM
  2. cycle_wala's Avatar
    Post your device along with software version here. Also, post if you get the "four BlackBerry dots" next to your mobile coverage indicator.

    Posted via CB10
    09-15-14 04:17 AM
  3. Completing's Avatar
    Post your device along with software version here.
    10.3.0.1154
    I had this problem from day one (10.2.something) and it has not changed from version to version.

    Also, post if you get the "four BlackBerry dots" next to your mobile coverage indicator.
    Posted via CB10
    Only, when in WiFi but if I look at Setting > Mobile Network > Available Networks
    I see: H - Voice/Data and everything else works just fine.
    09-15-14 04:25 AM
  4. cycle_wala's Avatar
    Since you mention you are on a leaked OS, I take it that you have tried security wipe already. If not, try again. And was your update to 10.3 a non-destructive one or was it via autoloader?
    You still haven't mentioned which device you have. Maybe you loaded a wrong radio?

    10.3.0.1154
    I had this problem from day one (10.2.something) and it has not changed from version to version.


    Only, when in WiFi but if I look at Setting > Mobile Network > Available Networks
    I see: H - Voice/Data and everything else works just fine.
    09-15-14 06:20 AM
  5. Completing's Avatar
    I have Q10 and it probably has nothing to do with OS version because:
    I had this problem from day one (10.2.something) and it has not changed from version to version.
    10.3 update was non destructive.
    I have done one destructive update and it had 0 effect on this particular problem.
    09-15-14 09:08 AM
  6. Richard Buckley's Avatar
    You haven't said whether you see the BlackBerry logo when on wireless. Did your carrier ever support BlackBerry BIS/BES? If so they may still have the routing which requires BlackBerry activation.

    Posted via CB10
    09-15-14 11:09 AM
  7. AnimalPak200's Avatar
    You haven't said whether you see the BlackBerry logo when on wireless. Did your carrier ever support BlackBerry BIS/BES? If so they may still have the routing which requires BlackBerry activation.

    Posted via CB10
    No he doesn't see it. I've already tried to help the OP out in another thread, but it seems like this is a carrier issue. OP needs to address this with the carrier, unless someone around here knows how to bypass their automatic settings through the e screen.

    Posted via CB10
    09-15-14 11:19 AM
  8. Completing's Avatar
    You haven't said whether you see the BlackBerry logo when on wireless. Did your carrier ever support BlackBerry BIS/BES? If so they may still have the routing which requires BlackBerry activation.
    I answered this in post #3

    Did your carrier ever support BlackBerry BIS/BES?
    No.

    AnimalPak200, do you know what settings I have to look for?

    1) Why do you guys think that the data service offered by carrier is somehow different from regular WiFi?
    2) I get IPv4 and IPv6 addresses form my carrier.
    3) Not a single app seems to complain.
    4) Is BBM using special ports? What are they? I am not aware that any ports are closed by local carrier.
    5) What are the differences in net connection between Andreoid version and BB version of BBM? Or why is Android version working and BB version is not?

    NOT posted via CB10
    09-15-14 12:25 PM
  9. AnimalPak200's Avatar
    I answered this in post #3


    No.

    AnimalPak200, do you know what settings I have to look for?

    1) Why do you guys think that the data service offered by carrier is somehow different from regular WiFi?
    2) I get IPv4 and IPv6 addresses form my carrier.
    3) Not a single app seems to complain.
    4) Is BBM using special ports? What are they? I am not aware that any ports are closed by local carrier.
    5) What are the differences in net connection between Andreoid version and BB version of BBM? Or why is Android version working and BB version is not?

    NOT posted via CB10
    I'm not sure about the e screen settings.

    I also don't understand why some carriers are able to block the entire BlackBerry server connection. Android BBM obviously does not rely on that server conduit. What carrier are you using and where?

    It would be interesting to see if setting up a vpn on your home computer, and connecting through it with your device would allow for the server connection. Obviously it's not practical, but more for experimental purposes.



    Posted via CB10
    09-15-14 12:48 PM
  10. Completing's Avatar
    I am sure my carrier is not blocking port 443 because Android BBM uses that port and as mentioned before, it works with no problems.
    If BBM (BB OS 10) uses same ports to communicate with BBM infra...
    09-15-14 03:07 PM
  11. cycle_wala's Avatar
    I have Q10 and it probably has nothing to do with OS version because:


    10.3 update was non destructive.
    I have done one destructive update and it had 0 effect on this particular problem.
    First of all, try to be a bit ready to take in suggestions and also try answering to people who are trying to troubleshoot your issues.

    Anyway, since you've done a non-destructive update & because you already had the issue on 10.2.1 before the update, my suggestion is to take backup & then 'security wipe' your phone.

    Start from scratch and it'll be easier to isolate your problem.

    Posted via CB10
    09-15-14 03:14 PM
  12. Completing's Avatar
    cycle_wala, I have done destructive updates. It changed nothing in 10.2.*
    So you are sure that security wipe and update with Sachesi will change something?
    If I am going to use my backup to restore after security wipe and update (to same version as I am now), what is expected to change or why do you think this will help.
    Usually backup restores previous state... confusing.
    09-15-14 03:34 PM
  13. AnimalPak200's Avatar
    cycle_wala, I have done destructive updates. It changed nothing in 10.2.*
    So you are sure that security wipe and update with Sachesi will change something?
    If I am going to use my backup to restore after security wipe and update (to same version as I am now), what is expected to change or why do you think this will help.
    Usually backup restores previous state... confusing.
    Yeah, if it never worked... then restoring to a previous point at which it didn't work, probably won't solve anything. Now.. if you wiped/destructive updated and it worked prior to doing a restore, then that would signal an issue with the settings.

    I'm pretty sure it's your carrier. I have actually encountered a carrier (while traveling) that gave me a prepaid "normal smartphone" data plan that wouldn't even let me get 4G (only 4g showed up and had zero data). Swapped the sim to an android device and everything worked normally. They called their central tech center and they told them that the carrier required any BlackBerry device (even BB10) to use one of their BlackBerry data packages. They switched it for me, and instantly everything worked.

    I don't know how many times I'll have to repeat myself about this, but it's up to the carriers whether or not they differentiate between standard and BB10 BlackBerry data plans. The problem with your case is that your carrier supposedly doesn't even have a BlackBerry plan at all.

    Posted via CB10
    09-15-14 03:46 PM
  14. Richard Buckley's Avatar
    Yeah, if it never worked... then restoring to a previous point at which it didn't work, probably won't solve anything. Now.. if you wiped/destructive updated and it worked prior to doing a restore, then that would signal an issue with the settings.

    I'm pretty sure it's your carrier. I have actually encountered a carrier (while traveling) that gave me a prepaid "normal smartphone" data plan that wouldn't even let me get 4G (only 4g showed up and had zero data). Swapped the sim to an android device and everything worked normally. They called their central tech center and they told them that the carrier required any BlackBerry device (even BB10) to use one of their BlackBerry data packages. They switched it for me, and instantly everything worked.

    I don't know how many times I'll have to repeat myself about this, but it's up to the carriers whether or not they differentiate between standard and BB10 BlackBerry data plans. The problem with your case is that your carrier supposedly doesn't even have a BlackBerry plan at all.

    Posted via CB10
    Well said.

    The other issue is that during the heyday of BlackBerry smartphone RIM set up service contracts with many carriers around the world, even with carries who didn't offer BlackBerry service to their customers. RIM did this because their users were business elite and traveled a lot. These services endure to the day and can cause issues like this as AP200 demonstrates.

    Posted via CB10
    09-15-14 04:21 PM
  15. EauRouge's Avatar
    My sisters phone had this problem when we set it up a few weeks ago. You need to call your carrier and have them open the vpn or something. I can't give too specific instructions because the rep immediately knew what I was talking about and took over

    Posted via CB10
    09-15-14 04:24 PM
  16. AnimalPak200's Avatar
    My sisters phone had this problem when we set it up a few weeks ago. You need to call your carrier and have them open the vpn or something. I can't give too specific instructions because the rep immediately knew what I was talking about and took over

    Posted via CB10
    I wish BlackBerry provided some clarity as to what exactly the BlackBerry icon represents (other than, things don't work when it's not there). Does it provide a higher level of security for things like BBM? If it does, then it should be disclosed as a positive feature. Right now, as seen in this thread, it's just more of a headache for the end user. At least if the user knew they were getting some extra security (or something), they would see it as a headache that's worth solving.

    Posted via CB10
    09-15-14 07:12 PM
  17. daves_25's Avatar
    The dots mean that the device can contact the blackberry servers, for things like bbm. There were/are a lot of carriers who were intentionally blocking bbm unless you bought a blackberry phone plan. With bb10, the phone just needs plain old data, but a lot of the carriers haven't caught up, and it breaks some bb10 functionality.

    Posted via CB10
    09-15-14 08:17 PM
  18. cycle_wala's Avatar
    cycle_wala, I have done destructive updates. It changed nothing in 10.2.*
    So you are sure that security wipe and update with Sachesi will change something?
    If I am going to use my backup to restore after security wipe and update (to same version as I am now), what is expected to change or why do you think this will help.
    Usually backup restores previous state... confusing.
    I never suggested you to restore data. I suggested you to start from scratch. Security wipe your phone and set it up as new. If your problem is solved, it could have been a bug you have been carrying from day 1. If it still doesn't work, it definitely is the carrier issue.

    And when you update to a leaked OS via non-destructive, problems always creeps in. And if you're this hesitant to wipe your phone, maybe you should never be using a leaked OS in the first place.

    Posted via CB10
    09-16-14 01:03 AM
  19. xxjavaxx2001's Avatar
    Where abouts are you from?

    Posted via CB10
    09-16-14 01:20 AM
  20. davinci4real's Avatar
    Op. I know your problem. it happened to me too. Truth is, it is from your carrier and the plan you are on. Simple.

    From Zarafet my Z30.
    09-16-14 01:46 AM
  21. Completing's Avatar
    I'll call my carrier and see what BS are they are going to shovel in to my ear.
    Destructive update (wipe, reinstall, waste half a day restoring accounts etc) is the last resort and I am 99% sure this is not the fix in this particular case.
    09-16-14 05:35 AM
  22. Completing's Avatar
    Got some feedback from my carrier and they say, they are not blocking/shaping whatever any traffic.
    Because they have no experience with BB products, they can not help me but he did some research on his own and thinks it's some weird BB/Q10 specific network settings that needs adjusting (that was his guess)
    Not surprised at all.

    So, who is escreen specialist here?
    09-17-14 03:08 AM
  23. cycle_wala's Avatar
    I give you my suggestion again. Before screwing up with escreen settings, simply security wipe your phone and check. This could solve your problem.

    Posted via CB10
    09-17-14 09:12 AM
  24. Completing's Avatar
    Thank you for all your help.
    Case closed.
    I'll use some other app with same functionality that actually works.
    RIP BBM
    09-18-14 02:16 PM
  25. davinci4real's Avatar
    Thank you for all your help.
    Case closed.
    I'll use some other app with same functionality that actually works.
    RIP BBM
    you'll be back one day.

    From Zarafet my Z30.
    09-18-14 04:40 PM
36 12

Similar Threads

  1. Loooooooooongg booting time!! Why??
    By swapnilsj in forum BlackBerry 10 OS
    Replies: 63
    Last Post: 09-26-14, 04:10 PM
  2. Pictures Taken with Z30
    By Jonard Bais in forum BlackBerry Z30
    Replies: 14
    Last Post: 09-19-14, 08:30 PM
  3. What can I do with this Z10?
    By blueshogun96 in forum BlackBerry Z10
    Replies: 6
    Last Post: 09-15-14, 10:46 AM
  4. Use radio file from 10.2.1 on 10.3?
    By hverduyckt in forum BB10 Leaked/Beta OS
    Replies: 1
    Last Post: 09-15-14, 02:42 AM
  5. Trouble with Whatsapp in Blackberry 9900
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-15-14, 02:41 AM
LINK TO POST COPIED TO CLIPBOARD