Home CrackBerry Q&A > BlackBerry 10 OS

Why aren't the email messages I delete in gmail show up in the trash?

Asked: May 11 2014 | 7:00 pm EDT 11108 Views 11 Answers View Best Answer

Hey everyone,
I noticed that when I delete an email on my Z10, it doesnt go into my Trash or [imap]trash. but if I do a seach for an email i deleted on my Z10 2 days ago, it'll come up in the search.

They seem to be residing in the "all Mail" folder on my gmail. is this a bug in gmail or BB10?
How to prevent deleted Gmail messages from archiving when synced using IMAP | CrackBerry.com

Thanks

EDIT - Sorry everyone, I meant to say in the title "Gmail deleted emails dont show up in Trash"


Best Answer

1,427
May 14 2014 | 4:34 am EDT ZeroBarrier

I wish I had something else to suggest. It works on all 3 of my Gmail accounts and for 7 others that I helped set this up.

???
I've finally figured it out! I had over a dozen filters set up to file certain incoming emails under multiple labels of my own creation. When I followed the instructions I only unchecked those labels which the "how to" specifies in the "System labels" section of the label settings tab and left all my personally made labels at the bottom of the label settings tab checked to "Show in IMAP". This prevented those emails from being moved to the trash folder since the settings specify "When a message is marked as deleted and expunged from the last visible IMAP folder" and my filters were auto filtering incoming emails to those labels that were still visible in IMAP. So I went ahead and unchecked "Show in IMAP" on every single label except for "Inbox", "Sent Mail", "Drafts", "Spam" and "Trash" in the entire list in the labels settings tab. Now when I delete from my Q10 the email is correctly sent to my trash folder!

For anyone else having issues with deleting Gmail from you're device and it being archived instead of being sent to trash; just follow the directions as posted on the CrackBerry front page but make sure to also un-check all your personal labels for which you have filters set up to auto-label incoming mail.

Posted via CB10

More Answers

48,168
May 11 2014 | 9:43 pm EDT hamsterwheel

I'd like to know as well, as I've noticed this also.

12,295
May 12 2014 | 7:54 am EDT Ecm

My Gmail messages do go to Trash, when deleted on device -- using the setup in the article to which you've provided the link. Note that you have to have the IMAP settings exactly as shown in the screen cap of the Gmail account, as well as the expunge settings.

I have directed a number of members to that article and all who responded have indicated it is now working fine.

I'd suggest checking each setting again, then reboot. Also check that the Trash folder is set to sync under Account Settings > Edit Folder Settings.

1,307
May 12 2014 | 8:28 am EDT Bash_Man

My Gmail messages do go to Trash, when deleted on device -- using the setup in the article to which you've provided the link. Note that you have to have the IMAP settings exactly as shown in the screen cap of the Gmail account, as well as the expunge settings.

I have directed a number of members to that article and all who responded have indicated it is now working fine.

I'd suggest checking each setting again, then reboot. Also check that the Trash folder is set to sync under Account Settings > Edit Folder Settings.
Oh wow.. it worked this time. I had 1 extra check mark under the Important label. I removed that, did the 5 swipe hub reset, deleted an email on my Z10 and within seconds it showed up in the Trash folder on my gmail.

Thanks

12,295
May 12 2014 | 8:33 am EDT Ecm

Oh wow.. it worked this time. I had 1 extra check mark under the Important label. I removed that, did the 5 swipe hub reset, deleted an email on my Z10 and within seconds it showed up in the Trash folder on my gmail.

Thanks
No problem. I hoped it was something like that.

1,427
May 13 2014 | 3:56 am EDT ZeroBarrier

My Gmail messages do go to Trash, when deleted on device -- using the setup in the article to which you've provided the link. Note that you have to have the IMAP settings exactly as shown in the screen cap of the Gmail account, as well as the expunge settings.

I have directed a number of members to that article and all who responded have indicated it is now working fine.

I'd suggest checking each setting again, then reboot. Also check that the Trash folder is set to sync under Account Settings > Edit Folder Settings.
This has never worked for me, ever. No matter how many times I've tried it, and I've checked the settings to be correct every single time; perhaps two dozen times now.

Posted via CB10

12,295
May 13 2014 | 10:53 am EDT Ecm

I wish I had something else to suggest. It works on all 3 of my Gmail accounts and for 7 others that I helped set this up.

???

12,295
May 14 2014 | 7:01 am EDT Ecm

Excellent detective work!

48,168
May 15 2014 | 8:37 am EDT hamsterwheel

I've finally figured it out! I had over a dozen filters set up to file certain incoming emails under multiple labels of my own creation. When I followed the instructions I only unchecked those labels which the "how to" specifies in the "System labels" section of the label settings tab and left all my personally made labels at the bottom of the label settings tab checked to "Show in IMAP". This prevented those emails from being moved to the trash folder since the settings specify "When a message is marked as deleted and expunged from the last visible IMAP folder" and my filters were auto filtering incoming emails to those labels that were still visible in IMAP. So I went ahead and unchecked "Show in IMAP" on every single label except for "Inbox", "Sent Mail", "Drafts", "Spam" and "Trash" in the entire list in the labels settings tab. Now when I delete from my Q10 the email is correctly sent to my trash folder!

For anyone else having issues with deleting Gmail from you're device and it being archived instead of being sent to trash; just follow the directions as posted on the CrackBerry front page but make sure to also un-check all your personal labels for which you have filters set up to auto-label incoming mail.

Posted via CB10
Woohoo! This worked! Thanks!! Emails now go to trash on the pc!

Still don't on device though. Maybe I have to set it to sync....?

1,307
May 15 2014 | 8:51 am EDT Bash_Man

Woohoo! This worked! Thanks!! Emails now go to trash on the pc!

Still don't on device though. Maybe I have to set it to sync....?
yes, if you go into Edit Folder settings under accounts, sync the Trash folder with your device. Worked for me.