11-27-13 07:41 PM
40 12
tools
  1. STV0726's Avatar
    Hi all,

    Anyone tracked down what causes the seemingly random, highly annoying disconnections of accounts like email which require a reboot to fix?

    It is driving me nuts and happening a lot lately when I changed nothing on my phone. Been on this OS since it was released by Tmo and this has started happening often in just the last several weeks.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-01-13 01:58 PM
  2. BravoZuluDelta's Avatar
    Are you talking about when you're asked to confirm login details? Those don't require a reboot.

    Posted via CB10 on Q10
    11-01-13 02:18 PM
  3. STV0726's Avatar
    Are you talking about when you're asked to confirm login details? Those don't require a reboot.

    Posted via CB10 on Q10

    No. The connection disconnects.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-01-13 03:00 PM
  4. BravoZuluDelta's Avatar
    No. The connection disconnects.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    What message do you get?

    Posted via CB10 on Q10
    11-01-13 03:13 PM
  5. STV0726's Avatar
    No message just all emails stop, you look in accounts and they are disconnected. You reboot and all your day's emails flood in.

    Inexplicably losing email access without warning or notification. Doesn't sound to BlackBerry reliable business tool-like to me.

    FIX ASAP!!

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-01-13 06:15 PM
  6. Bla1ze's Avatar
    No message just all emails stop, you look in accounts and they are disconnected. You reboot and all your day's emails flood in.

    Inexplicably losing email access without warning or notification. Doesn't sound to BlackBerry reliable business tool-like to me.

    FIX ASAP!!

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    You say for BlackBerry to fix it but you don't even know if it's a BlackBerry issue. My iOS Gmail disconnects often, my Outlook email on Android disconnects often. Do I blame Google, Apple or MS? It's not solely a BlackBerry problem and a lot of it is based on the services you use along with the connections your device maintains and hundreds of other variables. Poo Poo happens across the board, your best bet is to start ruling out variables before anything else.
    11-01-13 06:20 PM
  7. STV0726's Avatar
    You say for BlackBerry to fix it but you don't even know if it's a BlackBerry issue. my iOS Gmail disconnects often, my Outlook email on Android disconnects often. It's not solely a BlackBerry problem and a lot of it is based on the services you use along with the connections your device maintains and hundreds of other variables.
    You expect the end user to know that it is an issue across smartphone brands?

    Worse yet, you expect the end user to care?

    The fact is, it is an issue affecting BlackBerry devices and it is therefore BlackBerry's responsibility to at least investigate the issue.

    Regardless of blame, I have found other folks posting about this here and in other locations. No one ever seems to get down to the bottom of this issue.

    So can we come together here perhaps and at least try? Bla1ze, you offered many possible causes but didn't mention any possible suggestions or implications for a solution.

    Also, this never happened to me on BIS / legacy BB OS that I can remember.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-01-13 06:27 PM
  8. STV0726's Avatar
    You say for BlackBerry to fix it but you don't even know if it's a BlackBerry issue. My iOS Gmail disconnects often, my Outlook email on Android disconnects often. Do I blame Google, Apple or MS? It's not solely a BlackBerry problem and a lot of it is based on the services you use along with the connections your device maintains and hundreds of other variables. Poo Poo happens across the board, your best bet is to start ruling out variables before anything else.
    I need do distill your response to make it more usable:

    I. Based on services you use:
    So I have to give up Gmail or put up with this issue? No thanks to either. And what proof do you have that this has anything to do with that if it happens on multiple service providers?

    II. Connections device maintains:
    So a 2013 smartphone is not capable of refreshing a connection to an account when a network hand-off or period of no service occurs? If not automatically it should do it on the selected sync interval.

    III. Rule out variables:
    Starting where? It tends to happen mostly when I'm at college so I'm guessing periods of service interruptions. Also, I thought maybe Mobile Hotspot was causing it but that doesn't seem to be the case.


    Lastly, while I recognize that the underlying issue may not be BlackBerry's doing, what is their responsibility 150% is finding a way to implement a fix into their OS such as an automatic refresh and reconnecting attempt baked in so that a full reboot is not necessary everytime this happens. Because you know, that's crazy.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-01-13 06:41 PM
  9. BravoZuluDelta's Avatar
    What this sounds like is the error I've encountered, where you get a message that the account has disconnected, and when you tap that message, it takes you to the account setup screen. Within that screen, you're asked to enter your password again. If you know that your password has not changed, you don't need to enter it again. Go to a dropdown box like the Encryption selection and select the same setting again (i.e., hit Encryption and choose SSL again). This will enable the Save button up top - hit Save and your account should connect again. You don't need to wait for a reboot, and on the latest leaks the Save button is always enabled so that saves the "SSL" step as well.

    This happens when the connection drops in the middle of a sync. The phone fails to get a proper response, and thinks the server has rejected your login credentials. In order to prevent a server-side lockout, your account is disabled on the phone until you can validate the settings.

    This used to happen a lot with my Yahoo accounts, but I don't remember it happening again since I switched to 10.2.1. On the other hand, other people have reported this happening on 10.2.1, so there may be two separate causes or I've just been really lucky.
    11-01-13 06:41 PM
  10. STV0726's Avatar
    Ah, so to distill that theory down:

    This issue may occur when the BlackBerry device happens to be in the middle of syncing accounts either from a manual refresh or based on the selected sync interval, and then network data service is lost.

    So with this theory, this should NOT happen just from losing data connectivity. Only if data connectivity is lost during a sync process, right?

    I can brainstorm ways they could fix this and automatically reconnect your accounts without causing a lockout or requiring resaving or rebooting, because both of those two things are inconvenient and require end user interaction and therefore render the email and account system unreliable in that regard.

    By the way, and this is critical: I never get an error message in the Hub or at all when this happens. I've only gotten those when I legitimately change account credentials and they do need updating. So in my experience, this issue happens silently and is only detectable by lack of incoming account communications. Not good!!!

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-01-13 06:48 PM
  11. BravoZuluDelta's Avatar
    Ah, so to distill that theory down:

    This issue may occur when the BlackBerry device happens to be in the middle of syncing accounts either from a manual refresh or based on the selected sync interval, and then network data service is lost.

    So with this theory, this should NOT happen just from losing data connectivity. Only if data connectivity is lost during a sync process, right?

    I can brainstorm ways they could fix this and automatically reconnect your accounts without causing a lockout or requiring resaving or rebooting, because both of those two things are inconvenient and require end user interaction and therefore render the email and account system unreliable in that regard.

    By the way, and this is critical: I never get an error message in the Hub or at all when this happens. I've only gotten those when I legitimately change account credentials and they do need updating. So in my experience, this issue happens silently and is only detectable by lack of incoming account communications. Not good!!!

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    I get a message right at the top of my Hub that doesn't go away unless I 'X' it out. I can't remember if it makes a noise or activates the LED, it's been a while since I've had to deal with one.

    I agree there are ways around it, such as checking network connectivity both before and after a failed sync. I think the 10.0-10.2 method was just KISS with a security-oriented twist, in that it refuses to bombard the server with possibly incorrect login details (could be treated as unauthorised access and lock the account) and instead waits for user intervention.

    I'm pretty sure this has changed in recent builds, as I no longer deal with this issue. Same as 10.2.0 brought in a fix that no longer required me to authenticate my Yahoo account through the browser before adding it through the Hub.
    11-01-13 06:56 PM
  12. STV0726's Avatar
    Bump for either those who may have things to share or for some BlackBerry connected person to see this and get a light bulb idea.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-02-13 05:00 PM
  13. STV0726's Avatar
    Happened again this morning in my home while I was sleeping.

    I don't ever loose coverage here.

    Arg this is so annoying.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-03-13 11:04 AM
  14. STV0726's Avatar
    This is still happening almost on a daily basis and I'm running blind here.

    Can't anyone offer some suggestion as to why this is happening?

    Glitch in Z10STL100-3/10.1.0.4780?

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-05-13 11:35 AM
  15. Detective M Downs's Avatar
    I have no cure, but this does happen to me regularly.... I have Gmail, Yahoo and Me (iCloud) accounts linked.
    11-05-13 11:40 AM
  16. PD in T-DOT's Avatar
    I seem to only lose LinkedIn. It disappears from the hub and account list.

    I think it disconnects from the BB after I login using a PC and subsequently log out. I haven't tested the theory.

    Facebook, IMAP / exchange emails no issues.

    STL-3 Z10 | Rogers | 10.2.1.575 w/.641/725 bars
    11-05-13 12:53 PM
  17. Gearheadaddy's Avatar
    Google and Yahoo have had issues in the last few weeks. It's not a BlackBerry Issue most of the time...My desktop computer needed sign ins too...Gosh...that you can't blame on BlackBerry!

    Trusted Member Genius
    11-05-13 06:13 PM
  18. Benjamin_NYC's Avatar
    You say for BlackBerry to fix it but you don't even know if it's a BlackBerry issue. My iOS Gmail disconnects often, my Outlook email on Android disconnects often. Do I blame Google, Apple or MS? It's not solely a BlackBerry problem and a lot of it is based on the services you use along with the connections your device maintains and hundreds of other variables. Poo Poo happens across the board, your best bet is to start ruling out variables before anything else.
    S
    M
    H

    Posted via CB10
    11-05-13 10:47 PM
  19. STV0726's Avatar
    Google and Yahoo have had issues in the last few weeks. It's not a BlackBerry Issue most of the time...My desktop computer needed sign ins too...Gosh...that you can't blame on BlackBerry!

    Trusted Member Genius
    If this was true wouldn't this be much more widespread?

    You may be rite - after all it has been happening for the past week or two.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-05-13 11:01 PM
  20. STV0726's Avatar
    S
    M
    H

    Posted via CB10
    At Bla1ze or me?

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-05-13 11:01 PM
  21. southlander's Avatar
    For the account that disconnects, do you have multiple other devices, PCs accessing the same account?

    Z10STL100-4/10.2.0.1767
    11-05-13 11:06 PM
  22. STV0726's Avatar
    For the account that disconnects, do you have multiple other devices, PCs accessing the same account?

    Z10STL100-4/10.2.0.1767
    No. One BlackBerry Z10. And yes I occasionally log onto Gmail or my university email from a computer. I don't forsee that being the cause, though.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-05-13 11:17 PM
  23. southlander's Avatar
    No. One BlackBerry Z10. And yes I occasionally log onto Gmail or my university email from a computer. I don't forsee that being the cause, though.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    No it's not a likely cause then.

    Z10STL100-4/10.2.0.1767
    11-05-13 11:37 PM
  24. STV0726's Avatar
    I refuse to delete and re-add accounts right now.

    First, I went into each account and added a character to a field then back spaced it to allow me to resave and verify each account.

    We shall see if this holds up.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-06-13 12:00 AM
  25. STV0726's Avatar
    It has been a few days with no account disconnects. I had a typical long day at college where coverage is on and off, too.

    All I did prior to this testing period was go into each account, type in one digit in "update password" then backspace just so it would let me re-save and verify the accounts.

    -STV on Z10STL100-3/10.1.0.4780 TMO US
    11-08-13 01:24 PM
40 12

Similar Threads

  1. Sprint Spark - what do you think - Too late?
    By Ducati-88 in forum General Carrier Discussion
    Replies: 15
    Last Post: 01-18-14, 11:55 AM
  2. What leak you can recommend me?
    By blackberriquero in forum BlackBerry 10 OS
    Replies: 32
    Last Post: 11-06-13, 06:26 AM
  3. Logout of T-Mobile My Account?
    By cbvinh in forum BlackBerry Z10
    Replies: 9
    Last Post: 11-04-13, 09:36 PM
  4. What are you guys doing to bring new users to BBM?
    By diogoteixeira87 in forum General BBM Chat
    Replies: 29
    Last Post: 11-04-13, 11:53 AM
  5. Now what?? Oh boy
    By olga421 in forum General BlackBerry News, Discussion & Rumors
    Replies: 5
    Last Post: 11-03-13, 08:14 PM
LINK TO POST COPIED TO CLIPBOARD