1. mcwolfmm's Avatar
    Hello,
    I'm a Linux user and fan of BlackBerry. But lately I had problems with the combination of the two. So I decided to share decisions on the two issues that I met.

    The first problem was that Sachesi stopped binds with the phone. The problem is indicated that in the NetworkManager. The solution is to delete the USB interface it and then be configured manually.
    Code:
    sudo dhclient usb0
    When so configured interface Sachesi connects without any problems.

    The second problem was with Internet tethering. When configured network indicated that under Linux no Internet. Ping and HTTP requests even for small packages but has not fully functioning network. The problem here is showing the value of MTU. When configuring interface so set on 1428. But this is indicated too small size package. The solution for me is to use package with a maximum size 9000.

    First you need to run Internet tethering feature on your phone. And then configures the second USB interface.
    Code:
    sudo dhclient usb1
    sudo ifconfig usb1 mtu 9000
    Use the DNS 8.8.8.8 and 8.8.4.4

    This is a test of Q10 with OS 10.3.2.2252 and Ubuntu 15.04 (x64) installed with KDE 4.14.6
    Gerii likes this.
    07-31-15 02:30 AM
  2. vader42's Avatar
    Hmmm, I'm using an older version of mint at work with no problems. I just modify the usb setting to what I need (charge only, mass storage, tethering etc...)

    Must be something in newer kernels being overly clever. You can adjust your udev settings to correctly identify the phone.

    Posted via CB10
    07-31-15 03:31 AM
  3. mcwolfmm's Avatar
    Actually, I did not understand what causes the problem. Upgrade Ubuntu or upgrade BBOS.
    I played a long time with udev but from there I could not find a solution. I noticed that other users have trouble connecting to sachesi example.

    The phone recognizes correctly.

    Code:
    usb0      Link encap:Ethernet  HWaddr 4a:9d:24:01:40:e7  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:25 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:15352 (15.3 KB)  TX bytes:0 (0.0 B)
    
    usb1      Link encap:Ethernet  HWaddr 4a:9d:24:01:40:ea  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    But the interfaces are not configured correctly.
    Code:
    usb0      Link encap:Ethernet  HWaddr 4a:9d:24:01:40:e7  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:73 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:39098 (39.0 KB)  TX bytes:0 (0.0 B)
    
    usb1      Link encap:Ethernet  HWaddr 4a:9d:24:01:40:ea  
              inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::489d:24ff:fe01:40ea/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1428  Metric:1
              RX packets:55 errors:0 dropped:0 overruns:0 frame:0
              TX packets:88 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:17736 (17.7 KB)  TX bytes:14829 (14.8 KB)
    This is tethering. When automatic configuration is set MTU = 1428 and should be changed to 9000 to have correctly functioning network.

    Can you look at what MTU works with you?
    07-31-15 04:00 AM
  4. vader42's Avatar
    Will have a look tomorrow.

    Posted via CB10
    08-04-15 04:18 AM
  5. gariac's Avatar
    FWIW, I'm using MTU=1428. I didn't set it. That is the default value. OS is opensuse 13.1



    Posted via CB10
    08-06-15 05:04 PM

Similar Threads

  1. Error on cobalt's google play services
    By earloi in forum BlackBerry Q10
    Replies: 6
    Last Post: 09-10-15, 02:04 AM
  2. Replies: 5
    Last Post: 08-01-15, 10:57 PM
  3. Google play service
    By Badal Modi in forum Ask a Question
    Replies: 1
    Last Post: 07-30-15, 12:12 AM
  4. Google play services snap update
    By unknown_johny in forum Ask a Question
    Replies: 2
    Last Post: 07-29-15, 06:01 AM
  5. USB music issue
    By mmarksx19 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 07-28-15, 07:20 AM
LINK TO POST COPIED TO CLIPBOARD