1. Denny_Crane's Avatar
    Why is is that the local search on my Q10 shows me browser history items that have long been cleared both from within the Browser settings, and from within the Search menu within BlackBerry settings? I just cleared my browser history/passwords/cookies, as well as my Search history (Settings > Search > Delete Search History); but as you can see, typing "how" from my home screen brings up all sorts of browser history on my device.

    Anyone else notice this? Any way to clear it out? I attempted to deselect 'Browser' from the search items in the settings menu; that works, but the results re-appear as soon as you re-enable it.

    08-02-13 05:35 AM
  2. pkcable's Avatar
    Bug or design flaw maybe?
    08-02-13 01:37 PM
  3. wtz11's Avatar
    I just checked on my Z10 and all is well, I am not sure what the problem could be.
    08-02-13 01:40 PM
  4. Denny_Crane's Avatar
    Not only does it defeat the purpose of clearing your history, but it makes you wonder what else is on your phone that you thought was deleted! Has to be a bug. I'm not sure if was present before upgrading the software recently. I hope BlackBerry does something about it.
    08-02-13 02:06 PM
  5. VR6's Avatar
    Don't worry, NSA is keeping them in their logs too!

    Fired from my Z10
    08-02-13 04:03 PM
  6. Gerii's Avatar
    This should be removed when the search index is being refreshed the next time. Don't know how often that happens. Probably when the phone is not in use. (The search is keeping its own index to speed up search instead of searching through all your files whenever you search)
    08-02-13 04:19 PM
  7. Denny_Crane's Avatar
    This should be removed when the search index is being refreshed the next time. Don't know how often that happens. Probably when the phone is not in use. (The search is keeping its own index to speed up search instead of searching through all your files whenever you search)
    I'm not sure that it does happen to be perfectly honest with you. I have search history all the way back to May 3rd which is when I got my device if I remember correctly. Plus you'd think that clearing the search history (not from the browser, but from the actual 'Search' menu item from within the core settings) would clear it out.
    08-02-13 06:01 PM
  8. Gerii's Avatar
    I'm not sure that it does happen to be perfectly honest with you. I have search history all the way back to May 3rd which is when I got my device if I remember correctly. Plus you'd think that clearing the search history (not from the browser, but from the actual 'Search' menu item from within the core settings) would clear it out.
    When did you first clear your browser history?
    Clearing the search history just removes what you've typed into the search box, not what the search has indexed.
    08-02-13 09:36 PM
  9. Denny_Crane's Avatar
    My browser history is only stored for 1 day, so it should be purging daily. I can't recall when, but I've definitely manually cleared it since May as well though.

    In addition to not being able to clear out the log, I also wonder if search history would be logged if Private Browsing isn't enabled. I don't use it, but I may give it a try.
    08-02-13 10:21 PM
  10. Undbiter65's Avatar
    Yeah. And also the keyboard remembers all websites you've entered. Pretty useless. Lol

    Posted via CB 10 on my naked Z10
    08-02-13 10:39 PM
  11. Gerii's Avatar
    Just visited one site, searched for it, removed the site from the browser history and when I searched again it's gone.

    Posted via CB10
    08-03-13 03:34 AM
  12. Denny_Crane's Avatar
    Just visited one site, searched for it, removed the site from the browser history and when I searched again it's gone.

    Posted via CB10
    Did you search from the home screen via universal search?
    08-03-13 03:43 AM
  13. Gerii's Avatar
    Yes.

    Posted via CB10
    08-03-13 08:20 AM
  14. anonymous9283741's Avatar
    I just updated my Q10 with OS10.2 and I'm having this same issue

    Did you find a solution?
    11-05-13 07:41 PM
  15. Denny_Crane's Avatar
    No solution that I could find. I just disabled search history. This is a huge flaw IMO, and I can't believe it hasn't been resolved yet.
    11-08-13 12:16 AM
  16. anonymous9283741's Avatar
    Performed a security wipe and problem solved.

    Didn't restore my backup from Blackberry Link, just reinstalled the apps I use. Not sure if restoring the backup would cause the problem to occur again or not.

    Also took out my media card out before wiping - not sure if a wipe affects a media card or not but this is where all my photos are saved.

    Hopefully this is helpful
    11-08-13 06:09 PM
  17. Denny_Crane's Avatar
    Yes, I should have mentioned that a wipe without backup/restore is the best way to go. Not an ideal solution though.
    11-10-13 12:30 PM

Similar Threads

  1. SiriusXM Browser Streaming Problem
    By lohikaarme in forum BlackBerry 10 Apps
    Replies: 8
    Last Post: 09-18-13, 01:47 AM
  2. Name in the contact can't show after updating OS10.1.0.4633
    By TomXcution in forum BlackBerry Z10
    Replies: 2
    Last Post: 08-08-13, 11:58 PM
  3. Videos ad pop ups in the browser
    By doubleuc in forum BlackBerry Z10
    Replies: 2
    Last Post: 08-02-13, 03:28 AM
  4. can you search this rom 7.1.0.1054 on 9930 or 9900?
    By Royhoentor in forum BlackBerry Bold Series
    Replies: 2
    Last Post: 08-02-13, 12:25 AM
  5. Pictures aren't showing up, broken file?
    By HigherThanMars in forum BlackBerry Z10
    Replies: 2
    Last Post: 08-01-13, 04:37 PM
LINK TO POST COPIED TO CLIPBOARD