02-09-18 11:05 PM
40 12
tools
  1. radiata's Avatar
    A novel twist to a recent challenge.

    Finally able to connect wirelessly and via USB to Z30 on Mac OSX El Capitan. Unfortunately dropped and smashed screen of Z30 and decided to replace with an unused Z30 sourced on eBay. Sadly, Link and Blend happy to speak to the old but not the new..

    Upgraded thereafter to MacOS Sierra (beta) and Link seemed to be responding wirelessly but not via USB.

    Decided to delete and reinstall Link and Blend. Now, curiously, unable to install Blend or Link at all despite numerous attempts on MacOS Sierra. Downloaded .dmg again from Blackberry but equally unsuccessful..

    Has anyone been able to successfully install Blend/Link on MacOS Sierra?..
    08-07-16 05:51 PM
  2. TheForth99's Avatar
    I have the same problem. Upgraded to macOS Sierra with Blend installed and running fine. Once the update finished, Blend/Link did launch, but never connected to the BB Z10 anymore. Deinstalled Desktop/Blend, but reinstallation is not possible. No Error Messages. :-(
    Delia1023 likes this.
    09-22-16 04:10 AM
  3. Balgam's Avatar
    Same problem here my BlackBerry Leap is no longer recognized and BlackBerry software can not be installed.
    09-23-16 05:51 AM
  4. Vladislavt's Avatar
    I don't believe it's the only problem with macOS Sierra.

    As I could read all around the web and twitter, million of users are reporting various malfunctions with the newest Sierrs and iOS 10.

    I believe that Apple will send some upgrade soon for many reported problems.
    09-23-16 06:34 AM
  5. Del Mar Dial's Avatar
    Here is what I did to install both BlackBerry Link and Blend on Mac OS Sierra.
    1. Right click or command click on "Install BlackBerry 10 Desktop Software.app" Icon.
    2. Select from the contextual menu "Show Package Contents"
    3. Go to Resources directory and Double Click on "BlackBerry Blend.pkg"
    4. When you get to "Installation Type" Select "BlackBerry Link" Checkbox and both will install.

    Hope this works for you as It did for me.

    Goodluck,

    Del Mar
    09-23-16 07:29 PM
  6. Del Mar Dial's Avatar
    Head up this works but if you unplug and replug in your phone it will say you need to install drivers. So sure you can install the software but it has to boot up with the phone connected. I hope that BlackBerry releases a fix. I use Blend all the time and that does not work with Sierra at all. It launches but never connects USB/Wireless.
    09-23-16 10:11 PM
  7. radiata's Avatar
    Thank you very much.

    Flurry of activity on thread in recent days gratifying - assumed most had simply upgraded to Sierra and not deleted Link/Blend hence not encountered problem.

    A pleasure to reinstall and have some Link activity.

    R
    09-24-16 09:03 AM
  8. TheForth99's Avatar
    I can verify this. When launching BB Link it wants to update drivers and when I launch BB Blend then it tries to connect, but fails. I assume that the issue is really with Link, which is why the installer does not want to install in the first place. I will keep my fingers crossed that BB has enough vested interest to fix this for those of us that are not on the latest crop of BB devices.
    09-26-16 12:20 PM
  9. TheForth99's Avatar
    Hi Del Mar, thanks for the installer fix. Works well for the installation, but the result is that it never connects. Let's hope BB issues an update soon.
    09-26-16 12:23 PM
  10. Del Mar Dial's Avatar
    I know so sorry it doesn't work. I did reboot with my phone connected and it did seem to work at times with link but to be honest I just wanted blend more than anything else as it's how I type to my contacts with my phone. Hopefully there will be a fix in the near future but we shall see. I rolled my machine back to El Capitan as Apple in there infamous wisdom decided to drop PPTP VPN option which I need for my job when I work from home. I work in development at my company and yes that is how they do VPN but hey if we want to be less secure that is our decision but to just drop it because its insecure is just BS. Let that be on my company to choose to use it or not.

    Shimo is my only other option and they want $50 bucks. Sorry for the rant but just sort of pisses me off when company do that. Yes I didn't read the release notes so it's on me. But for drivers not to work for my phone that worked on the previous OS's come on WTF. It would be nice if I could run the drivers in El Capitan compatibility mode or at least have that option.
    09-26-16 08:35 PM
  11. Exoskell256's Avatar
    Same experience as TheForth99, the install workaround allows the installation to complete and the device is detected but neither Link nor Blend is able to communicate with the device. No driver errors at least...
    09-27-16 12:29 AM
  12. andre3030's Avatar
    I had no problems. Have you tried deleting the Blend folder within the Library/Application support folder? And reboot, uninstall, reboot and install

    Posted via CB10
    09-28-16 05:43 AM
  13. Del Mar Dial's Avatar
    Amazing how many different scenarios that have been reported. I tried everything. Rebooting reinstalling. I use AppTrap so when I install an app when I throw it away it deletes everything associated with the app installed. It's pretty good as you can also decide to keep the old files. So I know I started clean. Link would work but only if I booted into Sierra with my phone plugged in other wise I got the driver issues. Other people had no luck what so ever. Heck I even synced over all my files to my mac on Sierra. Not really sure what changed with Sierra have not read the release notes but El Capitan is back running until I can figure out a solution to all of my issues.
    09-28-16 10:26 PM
  14. rightsideup's Avatar
    I rolled my machine back to El Capitan
    Any chance you could elaborate on how you did this? I really need BB Blend and Sierra has royally fscked it!
    10-04-16 09:05 AM
  15. PeterC4's Avatar
    I managed to get BB Link working successfully. See my End of the Line post in the Blackberry Passport Forum.
    http://forums.crackberry.com/blackbe...-line-1088365/
    10-10-16 06:07 PM
  16. Del Mar Dial's Avatar
    Greetings rightsideup,

    I have an external hard drive set up and time machine. So I had snap shots with El Capitan saved. So by holding down command R on boot up with my external drive plugged in I select recover from Time Machine and I select a snapshot that has El Capitan and recovered from that time in history and the rest is history. Now granted if you don't have Time machine set up I am not sure how to roll back your OS. But yes that is how I did it.

    Thanks,

    Del Mar
    10-11-16 01:00 AM
  17. Geoaltanis's Avatar
    thank you
    10-16-16 02:49 PM
  18. freddyk56's Avatar
    Thanks a million, worked for me right away, Sierra on a 2015 MacBook pro
    10-18-16 08:29 PM
  19. Diane111's Avatar
    Thanks a million, worked for me right away, Sierra on a 2015 MacBook pro
    What exactly worked for you right away? Blend or Link? I have a Passport and just upgraded to Sierra but can't get Blend to work. I need Blend so bad that I'm thinking of giving up on Blackberry for good (eventhough I really like the Passport) and buying an iPhone.
    Last edited by Diane111; 10-19-16 at 10:44 AM.
    10-19-16 10:33 AM
  20. coryallen78's Avatar
    I have successfully installed Blend on MacOS Sierra and my Classic connected successfully. Thank you!
    11-16-16 03:17 PM
  21. coryallen78's Avatar
    It worked for me with my Blackberry Classic. I turned off Blend on my phone. Turned it back on and it did the security "handshake" to make sure the numbers matched and worked. Have been connecting successfully all day.
    11-16-16 03:19 PM
  22. coryallen78's Avatar
    Blend worked for me. I reinstalled Blend using the instructions in this thread. I turned off Blend on my Blackberry Classic. Then turned it back on. Blend needed to redo the security handshake to make sure the numbers matched. It has been connecting great all day.
    11-16-16 03:21 PM
  23. Del Mar Dial's Avatar
    @Coryallen78 Awesome!!!

    I will attempt this again as I role to Sierra in the near future. Thanks for the heads up on with reestablishing handshake with blend,

    Thanks,

    Del Mar
    11-16-16 03:23 PM
  24. S1lv1o's Avatar
    It worked for me with my Blackberry Classic. I turned off Blend on my phone. Turned it back on and it did the security "handshake" to make sure the numbers matched and worked. Have been connecting successfully all day.
    This is what solved it for me, thanks, I' given up hope!
    11-17-16 09:46 AM
  25. Zebra 99's Avatar
    I found out that blend or link can not working on same Mac. I installed blend and worked via USB or Wifi. However, link will worked at all.
    So, I reinstalled link only. Now it works. But it connects via USB may has difficulty. I tried open network under system reference. Then plus two blackberry en(3) and (4). Reconnect with BB Classic and it working.

    If sometimes it is not work, then you have remove "old" one to reconnect blackberry. Let link found BB. It's worked again.

    My MacOS is 10.12.2 beta 3.
    11-17-16 08:26 PM
40 12

Similar Threads

  1. Alternative to BB10+Bridge+Playbook...
    By Old_Mil in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 08-09-16, 08:18 PM
  2. Virus on phone... HELP!?!?
    By wiz9 in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 08-08-16, 11:55 AM
  3. How to know activation date?
    By raam4u in forum BlackBerry Passport
    Replies: 3
    Last Post: 08-08-16, 09:24 AM
  4. Replies: 1
    Last Post: 08-07-16, 04:53 PM
  5. FancyTran Audio not working on Blackberry Classic
    By norpeter in forum BlackBerry Classic
    Replies: 0
    Last Post: 08-07-16, 12:57 PM
LINK TO POST COPIED TO CLIPBOARD