1. jnak00's Avatar
    I've got a Passport on Rogers and installed the leaked 747 a long time ago. It works OK but I get the annoying flickering screen (a lot lately). I tried updating OTA but the phone tells me I have the latest version. Same thing with Link. I then tried updating using Sachesi to 2708. It seemed to work, but the version stayed on 747. And now my hub doesn't work - if I try to open an email, the screen flickers briefly and stays on the hub, rather than opening the email.

    I've now done a wipe and am restoring from backup, and we'll see if I can get 2708 installed that way.

    Is Rogers pushing the 2708 update to the Passport? Any reason why I couldn't seem to get the 2708 update without wiping the phone?
    03-28-15 04:53 PM
  2. Lostboy5151's Avatar
    Upgrade to OS10.3.1.2582. It'll fix your issues.


    Heres the link:
    http://forums.crackberry.com/bb10-le...pdate-1007097/
    bungaboy likes this.
    03-28-15 05:06 PM
  3. jnak00's Avatar
    Trying that now....I also notice it's impossible to type in caps. Holding the key just makes the letter repeat like on a PC keyboard and pressing the shift or holding the shift doesn't work either. Ugh. Hope this update works.
    03-28-15 06:33 PM

Similar Threads

  1. WTS/WTT: Verizon DROID Turbo 8/10.
    By zehkaiser in forum The Marketplace - Buy, Sell & Trade
    Replies: 17
    Last Post: 04-09-15, 08:14 PM
  2. BB10 App Manager (Chrome) Not Working on Passport
    By RLC3780 in forum BlackBerry Passport
    Replies: 7
    Last Post: 03-28-15, 11:11 PM
  3. Anyone having GPS issues 10.3.1?
    By lnichols in forum BlackBerry Z30
    Replies: 14
    Last Post: 03-28-15, 08:53 PM
  4. Stylus on future passport devises
    By gilbert khayat in forum BlackBerry Passport
    Replies: 4
    Last Post: 03-28-15, 05:12 PM
  5. Replies: 1
    Last Post: 03-28-15, 02:48 PM
LINK TO POST COPIED TO CLIPBOARD