01-30-16 06:29 AM
36 12
tools
  1. diogoteixeira87's Avatar
    Is this happening to everyone? My biggest problem is that the app takes too long to connect and go online (when it connects), so most of time I have to lesson to "my music", stuff already loaded to my phone. Any help or suggestion? Thanks

    I'm using a Z30 with 10.3.2.2836. Spotify has the latest version downloaded on play store (cobalt)

    Posted with Z30!
    01-15-16 01:57 PM
  2. dvmblues's Avatar
    Yes,it's true,in my blackberry passport equal.

    Posted via CB10
    01-15-16 02:04 PM
  3. TheBirdDog's Avatar
    I haven't been having any problems yet. On any BB10 device. Knock on wood because, as much as I say I'm on of those BB10 users who could care less about Android Apps, I love Spotify and would be hurt without it.

    Posted via CB10
    norton666 likes this.
    01-15-16 02:10 PM
  4. diogoteixeira87's Avatar
    So all the time you open the app, you can browse on random playlists and artist pages without the annoying green circle? That's nice!

    Posted with Z30!
    01-15-16 03:06 PM
  5. Dave Bourque's Avatar
    So all the time you open the app, you can browse on random playlists and artist pages without the annoying green circle? That's nice!

    Posted with Z30!
    The apk posted on the Spotify site worked for me. I don't think it's the same as the one posted on google play but it works correctly from what I've seen so far.

    Z30STA100-5/10.3.2.2876
    01-15-16 03:09 PM
  6. 1Criz's Avatar
    I have Spotify v.1.6.0.952 and it works okaish. Sometimes it's claims off-line when I am not, but usually works. I however don't have premium, so no local cache.

    Posted via CB10
    01-15-16 03:27 PM
  7. yvr2yyz's Avatar
    I also use Spotify from the Play Store and experience long lags as the app tries to pull up playlists or move from one menu item to another. The green circle eventually disappears and once it's been up and running for a bit, it gets faster. I never thought to try the apk of the Spotify site directly and I'll give it a shot this weekend. spotify.com/ca-en/download/other/
    I notice that the download for BlackBerry is a .jad file. Will this format play on BB10?
    01-15-16 03:49 PM
  8. tufcustomer's Avatar
    It's not perfect, but does the job. Feels quite sluggish at times, but being an apk I can live with it.

    Posted via CB10
    01-15-16 04:00 PM
  9. norton666's Avatar
    I have no issues with it. Z30 on 2639, Spotify is the latest version from snap, one free and one premium account.

    Posted via CB10
    01-15-16 05:07 PM
  10. GodGibson's Avatar
    I use it and the application works great on my passport
    even remote connection with the desktop windows app
    It's not laggy im running premium tho so no adverts

    Spotify not working properly on bb10-img_20160115_221730.png

    Posted via CB10
    01-15-16 05:17 PM
  11. diogoteixeira87's Avatar
    The apk posted on the Spotify site worked for me. I don't think it's the same as the one posted on google play but it works correctly from what I've seen so far.

    Z30STA100-5/10.3.2.2876
    Are you referring to this one: android (manual download)?

    Posted with Z30!
    01-15-16 08:51 PM
  12. diogoteixeira87's Avatar
    I use it and the application works great on my passport
    even remote connection with the desktop windows app
    It's not laggy im running premium tho so no adverts

    Click image for larger version. 

Name:	IMG_20160115_221730.png 
Views:	1255 
Size:	113.7 KB 
ID:	387921

    Posted via CB10
    I can use remote connection too. My only problem is the connection one. It takes forever to go online and, sometimes, I give up before that.

    Posted with Z30!
    01-15-16 08:59 PM
  13. Dave Bourque's Avatar
    Are you referring to this one: android (manual download)?

    Posted with Z30!
    Yes.

    Z30STA100-5/10.3.2.2876
    01-16-16 11:55 AM
  14. sulcopete's Avatar
    I have Spotify installed from Amazon app store, version 4.4.0.1008 Works like a charm. Also check your settings....both in Spotify and on your device, for how you download - either over cellular network, downloading while roaming, wifi only, etc. It's all cusomizable to suit your data plan etc. Your settings will affect how fast the program runs. Best is to have wifi. Also there are 4 settings in Spotify for music quality...automatic, normal, high, and extreme quality. Any of these things could be affecting you. Good luck! It's a great app when it works. I have a passport running10.3.2.556
    Last edited by sulcopete; 01-17-16 at 01:23 PM. Reason: add my device/os
    01-17-16 01:19 PM
  15. TheBirdDog's Avatar
    So all the time you open the app, you can browse on random playlists and artist pages without the annoying green circle? That's nice!

    Posted with Z30!
    Yeah, usually it's pretty good. The most 'lag' I experience is when I first load up the app and it's usually only 3 to 5 seconds at most. Afterwards, it runs pretty smooth. I mean, it's not as fluid as the rest of BB10 but the app runs fine and I can listen to music while browsing other content without much interruption. Maybe the green circle pops up every now and again but, if it does, it doesn't annoy me all that much.

    Question: how old are you? There was a time where people had to wait for every single webpage to 'load' and this was before there were even fancy animations and ads that were part of the content. I'd have to wait for over 20 minutes for a high quality movie trailer to load on Apple's 'Quicktime' site back in the day when that was where you watched movie trailers. I'm not trying to make myself sound old because I'm not but I must have learned patience over the years.

    Spotify runs just fine, in my opinion. Yes, it takes a few seconds to load now and again. It's also processing a huge amount of content though and, considering that, I think it's actually quite efficient and I cannot complain with how it performs. Will it run better on a later version of Android? Perhaps, but then I sacrifice the efficiency of many other things that I don't wish to compromise on.

    In the end, I don't really understand your complaint. I can almost guarantee that your app performs the same way it does on anybody else's device and you just have less tolerance than those without issue. It isn't a BlackBerry app so the fact that we can run it on our phones (albeit with a bit of 'lag') is a bonus. It's like a restaurant offers you a free desert and you send the cake back because it isn't moist enough.



    Posted via CB10
    01-17-16 01:43 PM
  16. GodGibson's Avatar
    Yeah, usually it's pretty good. The most 'lag' I experience is when I first load up the app and it's usually only 3 to 5 seconds at most. Afterwards, it runs pretty smooth. I mean, it's not as fluid as the rest of BB10 but the app runs fine and I can listen to music while browsing other content without much interruption. Maybe the green circle pops up every now and again but, if it does, it doesn't annoy me all that much.

    Question: how old are you? There was a time where people had to wait for every single webpage to 'load' and this was before there were even fancy animations and ads that were part of the content. I'd have to wait for over 20 minutes for a high quality movie trailer to load on Apple's 'Quicktime' site back in the day when that was where you watched movie trailers. I'm not trying to make myself sound old because I'm not but I must have learned patience over the years.

    Spotify runs just fine, in my opinion. Yes, it takes a few seconds to load now and again. It's also processing a huge amount of content though and, considering that, I think it's actually quite efficient and I cannot complain with how it performs. Will it run better on a later version of Android? Perhaps, but then I sacrifice the efficiency of many other things that I don't wish to compromise on.

    In the end, I don't really understand your complaint. I can almost guarantee that your app performs the same way it does on anybody else's device and you just have less tolerance than those without issue. It isn't a BlackBerry app so the fact that we can run it on our phones (albeit with a bit of 'lag') is a bonus. It's like a restaurant offers you a free desert and you send the cake back because it isn't moist enough.



    Posted via CB10
    Maybe a phone security wipe would help speed it up
    Along with maybe a poor mobile signal which makes the app buffer solution is get premium and download all the songs offline problem solved
    Posted via CB10
    01-17-16 02:50 PM
  17. TheBirdDog's Avatar
    Maybe a phone security wipe would help speed it up
    Along with maybe a poor mobile signal which makes the app buffer solution is get premium and download all the songs offline problem solved
    Posted via CB10
    There are variables that I didn't consider. Surely, if your phone is running many apps at the same time, performance would be affected. Also, I do have the premium subscription so I don't get plagued with advertisements. This also might improve performance as the app isn't constantly interrupting the stream with content from other sources. And I usually listen to one album at a time rather than preset playlists. This also might make for a smoother experience.

    There are many variables to consider. However, it is easy to see from the comments that the app runs just fine for many BB10 users. As for the ones that don't seem happy with it, I suppose it could be technical variables (many apps running, advertisements causing buffering issues, etc) or it could just be a different level of tolerance.

    Posted via CB10
    01-17-16 04:16 PM
  18. diogoteixeira87's Avatar
    Yes. I did check these options and everything seems to be normal. One thing I should consider is most of people saying that has no issue is using a passport just like you are. Maybe device specs is making the difference here.

    I think I'll try to wipe mine and see what happens.

    Thks

    Posted with Z30!
    01-18-16 07:51 AM
  19. diogoteixeira87's Avatar
    I tried, but still the same. Thanks

    Posted with Z30!
    01-18-16 07:52 AM
  20. si001's Avatar
    I use the version from the amazon store and its working great on my passport.
    01-18-16 07:58 AM
  21. diogoteixeira87's Avatar
    Hahaha... I'm 28. I don't have the teenage issues you just said. I was raised with dial-up Internet too. Tough times.

    My complaint about the app is just the time it takes to recognize Internet connection. It takes a few to open, but that's OK because it's an android app like you said. But most of times I can't browse anything. It takes just too long... minute(s). That's my only problem. Overall the app is good on bb10.

    Well, I don't know about others bb10 devices, but my mom's galaxy s5 Internet connection is always ready when she opens the app. And it's not a carrier issue because she uses the same as I. App performance is similar between our devices except this.

    I'll try a wipe and see what happens

    Thanks

    Posted with Z30!
    01-18-16 08:00 AM
  22. Smokeaire's Avatar
    I don't use Spotify but one thing I noticed in reading these posts is that no one has mentioned Cobalt's apps and patching the Spotify app. Perhaps that is something to be considered.
    I wouldn't do a security wipe (if that is what you are referring to), it can take days. I would use an autoloader to reload you OS version, that will make your phone a clean slate if that is the approach you want to take.
    01-18-16 08:44 AM
  23. TheBirdDog's Avatar
    Yes. I did check these options and everything seems to be normal. One thing I should consider is most of people saying that has no issue is using a passport just like you are. Maybe device specs is making the difference here.

    I think I'll try to wipe mine and see what happens.

    Thks

    Posted with Z30!
    I have it on my Passport but I also own a Classic and I use my old Z10 pretty much exclusively as my "Spotify" player at home as it's pretty much constantly hooked up to my sound system. It works pretty much the same on all devices for me. Sometimes it is faster on the others than the Passport. There doesn't seem to be a rhyme or reason to it.

    Is it possible that you have other Android apps running that you don't know about? Do you have a task manager that will let you see what's running and close down any apps running that shouldn't be? I would try that, if I were you.

    Really, Spotify SHOULD work quite well on your device. And there must be a specific reason that it isn't. What version of Spotify do you have? (you can find it in the 'About' section of your Spotify settings)

    Posted via CB10
    01-18-16 02:20 PM
  24. asiayeah's Avatar
    I use the version from the amazon store and its working great on my passport.
    Same here. It did become slow once a few months ago. I have deleted and reinstalled the app. It becomes fast again.

    Posted via CB10
    01-19-16 07:01 AM
  25. Anti-Iridium's Avatar
    Is this happening to everyone? My biggest problem is that the app takes too long to connect and go online (when it connects), so most of time I have to lesson to "my music", stuff already loaded to my phone. Any help or suggestion? Thanks

    I'm using a Z30 with 10.3.2.2836. Spotify has the latest version downloaded on play store (cobalt)

    Posted with Z30!
    Yeah after weeks of searching I finally found the solution

    There isn't a bug tracker, so I need to post here. *Hopefully "clean install" instructions will be amended so no other users will have to go through this. *The report that follows should have never happened.
    *
    == Begin Report ==
    *
    Brief description of the issue:
    *
    Corrupted Cache/DB junk can persist on between reinstalls of app causing sluggish or broken behavior. *"Delete Cache and Saved Data" is not thorough enough.
    *
    Steps to reproduce the issue:
    Install Spotify
    Use spotify for some years, upgrading OS and Spotify app as expected.
    Spotify app inexplicably gets stuck in loading cycles, with issues persisting across clean reinstalls and in-app setting wipes.
    What steps youve tried already:
    *
    Tried reinstalling app. * Tried reinstalling old app versions. *Tried the Delete Cache and Saved Data. *Tried Log Out From All Sessions. *Restarting app many times would restore interactivity briefly after app startup. *Playback would work as expected but searching would soon stall on both WiFi and 3G/LTE connections. *
    *
    Your device and operating system (e.g. Samsung Galaxy 4, 5.1.1)
    *
    Blackberry Z10 and Blackberry Passport.
    *
    Type of Spotify account you have (Free/ Premium):
    *
    Premium
    *
    The app version of Spotify youre using:
    *
    All releases from late 2013 to Present.
    *
    *
    Workaround/Resolution
    *
    Wipe Android/data/com.spotify.music folder from SD card. *When I checked, I had files in here dating back to early 2014 that the "Delete Cache and Saved Data" button obviously ignores. *App now runs fine after months of terrible behavior.
    *
    == End Report ==*
    *
    Part of the reason I never reported this before is the community kneejerk reaction will inevitably be "oh this is a problem because you use BlackBerry and we don't support their unofficial fork". *No the reality is, a clean install isn't clean and a button in the Spotify app that should remove SD data, doesn't remove SD data.
    *
    I have read through troubleshooting steps now and disagree that SD card removal should be first priority, removing this cache should be first priority (especially on devices that one cannot remove the SD card on)
    I cannot post links yet, otherwise I would
    01-24-16 06:36 PM
36 12

Similar Threads

  1. Why won't my Priv send or receive pictures via text message?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 01-15-16, 02:57 PM
  2. Still stuck on .2474 in South Africa.
    By xueyaotianxia in forum BlackBerry Passport
    Replies: 0
    Last Post: 01-15-16, 01:36 PM
  3. How do I block popup ads on the Priv?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-15-16, 12:56 PM
  4. Cache on CB 10
    By wrubin in forum Ask a Question
    Replies: 1
    Last Post: 01-15-16, 11:56 AM
  5. APN not working
    By tacu23 in forum Ask a Question
    Replies: 1
    Last Post: 01-15-16, 11:44 AM
LINK TO POST COPIED TO CLIPBOARD