03-08-15 03:37 AM
43 12
tools
  1. ryback42's Avatar
    Hey folks,

    First of all, hello.
    Im new to crackberry but BB user since 2006 with Pearl 8xxx and than Pearl 9xxx. And now my personal quantum leap - switching to a Q10

    Ive tried the following and wanna know if someone of the pros here can explain to me where the problem is.

    Ive a new BB Q10 and the Sony QX10 Camera. The problem seems to be clear - this wont run without the sony app.

    First of all, Ive converted the Sony playmemories App from .apk to .bar with an online convert-tool. (APK to Bar Online Converter)
    I load it to my BB and the app runs without problems - well, it seems so.
    Than I connected the Cam via Wifi (direct-mode wont work, but the normal mode works)
    But when I start the app, it doesnt recognize the cam and the whole thing wont work.

    Thoughts:
    1. NFC
    NFC isnt important as it is just used to recognize the cam. I use the cam on my iPad and it runs without problems. And the iPad has no NFC.

    2. Wifi Direct-mode
    I thought not using the Direct Mode on the BB might be the problem, but Im not sure if that could be as the iPad also dont use it. The iPad connects normaly with the Sony as it is a hotspot.

    Well, the road so far. Anyone here who has an idea where the problem is and how it can be solved?
    I really love the Sony-Cam and it would be so great to use it.

    thanx
    nico
    Supa_Fly1 likes this.
    11-07-13 11:42 AM
  2. Elite1's Avatar
    Would running the Q10 as the hotspot instead of the iPad work? Your Q10 does mobile Hotspot too.

    Sorry if that's a ridiculous suggestion. I've never used this software before.

    Have a Sony bluray player and Vaio laptop, but cameras here are Canon.
    11-07-13 12:23 PM
  3. ryback42's Avatar
    Im not sure what you mean?

    Normally you connect the cam direct with the device (iPad, iPhone, Android-Phone usw.)
    So the cam is the hotspot that you connect the phone with. As the cam has no interface, you cant connect it with some other hotspot. I hope that was clear how Ive explained it.

    I think the problem lies in the process of how the sony app communicates with the cam. The sony app is an android-app, that runs in the android runtime but not as a native bb app. So it maybe isnt allowed to "use" the wlan-connection, or, to make it more clear, the app "listen" if there is a qx10/qx100 around, but if the surrounding bb os 10 wont let the app listen, nothing will happen. that seems to be the problem.
    Solutions for that might be to change the app. Maybe if there is someone who can convert the sony app "by hand" instead of using the online converter like me, there will be a possibility to get things running. ...

    Well, if the new 10.2.1 has the google play support, maybe the sony app will communicate direct with the cam as it should be.
    11-12-13 10:36 AM
  4. Just Me's Avatar
    Anyone have any luck with the getting the QX10 pair to their blackberry?

    Need some POW.
    12-10-13 11:54 AM
  5. shreyas7777's Avatar
    OP,can you please try whether this works using the 1925 leak?

    Posted via CB10
    12-27-13 12:24 AM
  6. Supa_Fly1's Avatar
    @Ryback,

    (cool name Btw, a villain against mason storm?)

    Would LOVE to see you get this going to be honest!

    I think Sony has another.specific app to get this working for other Android devices that you need and the WiFi connection is in. MirrorCast mode not adhoc or hotspot mode (the latter would never made sense, the BB10 device is not supposed to.provide modem services lol)

    Posted via CB10
    12-27-13 01:32 AM
  7. presean's Avatar
    OP,can you please try whether this works using the 1925 leak?

    Posted via CB10
    Yes can someone have a test with the last leak?
    12-28-13 09:01 AM
  8. awaisb2012's Avatar
    Yes can someone have a test with the last leak?
    The furthest I have got on the latest leak is the app detecting it, allowing you to select the camera but when you enter the password in it continually remains on "connecting" and eventually times out saying wrong password.
    01-02-14 09:11 AM
  9. Gerii's Avatar
    Does the phone switch back to the mobile network after connecting to the camera?
    If so, try to disable the mo mobile network.

    Posted via CB10
    01-02-14 11:21 AM
  10. presean's Avatar
    Apparently this is due to the fact that the wi-fi and nfc are not yet allowed into the android runtime :-( the same behavior here on 10.2.1.1259.

    I cannot understand why BlackBerry recently allowed bluetooth but not wi-fi and nfc!

    Posted from my flawless BlackBerry Z10
    glamrlama likes this.
    01-02-14 02:04 PM
  11. Pdinos3's Avatar
    I have the same problem with my qx10. Times out and says incorrect password. I wish Sony made an app for BB10. Loaded the Playmemories apk but don't even know if it would work even if password was accepted.

    Via CB10 /Rogers/Z30STA100-5/10.2.1.1925
    01-02-14 02:25 PM
  12. fbloise's Avatar
    I was just about to buy one QX10 but glad i stumble upon this thread. Sad it doesnt work.
    01-11-14 08:15 AM
  13. Supa_Fly1's Avatar
    I was just about to buy one QX10 but glad i stumble upon this thread. Sad it doesnt work.
    Fellow Esato member

    We just have to wait for more testing by those that have the latest BB10 leaks and apps supporting the QX10/100.

    Weapon of choice Z10, Full Metal CB10!
    01-11-14 02:38 PM
  14. Gerii's Avatar
    It would still be nice if someone would answer my question. Because I have a wireless SD card and after connecting to it BlackBerry 10 usually switches back to the mobile network because it can't connect to the internet. Turning the mobile network off while using the card is a workaround for me. So I think it's worth a try on this Sony camera too.
    01-11-14 03:09 PM
  15. presean's Avatar
    It would still be nice if someone would answer my question. Because I have a wireless SD card and after connecting to it BlackBerry 10 usually switches back to the mobile network because it can't connect to the internet. Turning the mobile network off while using the card is a workaround for me. So I think it's worth a try on this Sony camera too.
    Oh thanks this a good alternative meanwhile

    Posted from my flawless BlackBerry Z10
    02-01-14 11:50 AM
  16. Pdinos3's Avatar
    Oh thanks this a good alternative meanwhile

    Posted from my flawless BlackBerry Z10
    Did it work?

    Via CB10 Rogers Z30STA100-5/10.2.1.1925/1926 Radio
    02-01-14 12:03 PM
  17. dejanh's Avatar
    Hey folks,

    First of all, hello.
    Im new to crackberry but BB user since 2006 with Pearl 8xxx and than Pearl 9xxx. And now my personal quantum leap - switching to a Q10

    Ive tried the following and wanna know if someone of the pros here can explain to me where the problem is.

    Ive a new BB Q10 and the Sony QX10 Camera. The problem seems to be clear - this wont run without the sony app.

    First of all, Ive converted the Sony playmemories App from .apk to .bar with an online convert-tool. (APK to Bar Online Converter)
    I load it to my BB and the app runs without problems - well, it seems so.
    Than I connected the Cam via Wifi (direct-mode wont work, but the normal mode works)
    But when I start the app, it doesnt recognize the cam and the whole thing wont work.

    Thoughts:
    1. NFC
    NFC isnt important as it is just used to recognize the cam. I use the cam on my iPad and it runs without problems. And the iPad has no NFC.

    2. Wifi Direct-mode
    I thought not using the Direct Mode on the BB might be the problem, but Im not sure if that could be as the iPad also dont use it. The iPad connects normaly with the Sony as it is a hotspot.

    Well, the road so far. Anyone here who has an idea where the problem is and how it can be solved?
    I really love the Sony-Cam and it would be so great to use it.

    thanx
    nico
    I realize that this thread is a bit old but I would like to leave the answer here for anyone else who may run into the same type of thing, either with the same camera or with another Wi-Fi enabled camera like the Canon 6D or 70D.

    What you are asking is not possible as the Android runtime on BlackBerry 10 currently does not support or allow the CHANGE_WIFI_MULTICAST_STATE manifest property. This property is required for any direct IP connections over Wi-Fi such as those used by many Wi-Fi enabled cameras.

    Posted via CB10
    02-01-14 12:29 PM
  18. presean's Avatar
    It would still be nice if someone would answer my question. Because I have a wireless SD card and after connecting to it BlackBerry 10 usually switches back to the mobile network because it can't connect to the internet. Turning the mobile network off while using the card is a workaround for me. So I think it's worth a try on this Sony camera too.
    What brand of the SD wi-fi did you bought ?

    Posted from my flawless BlackBerry Z10
    02-01-14 01:31 PM
  19. Gerii's Avatar
    The Toshiba FlashAir. It works without an app from any browser. The newer ones can even pass-through other WiFi networks.

    Posted via CB10
    02-01-14 02:10 PM
  20. presean's Avatar
    The Toshiba FlashAir. It works without an app from any browser. The newer ones can even pass-through other WiFi networks.

    Posted via CB10
    Wow thanks a lot, but I didn't get very well the difference between the newer and the old one. What is the model of the new one ?

    Thanks

    Posted from my flawless BlackBerry Z10
    02-01-14 02:40 PM
  21. Gerii's Avatar
    The new ones are Class 10 and they are also available in 16GB and 32GB.
    You can learn more about it here: http://www.toshiba-components.com/FlashAir/index.html

    Posted via CB10
    02-01-14 03:00 PM
  22. The Big Picture's Avatar
    Im use quite a few cameras. Nikon D600, sony nex 5 and panasonic lumix GM1.

    Nikon WMU is the only camera communication app which works on my Q10 and Z30.

    Sony playmemories and panasonic image app does not work. It disconnects after a while.

    Its not a problem with the android runtime wifi because if it is I wouldnt be able to connect my nikon.

    Others have reported that the android go pro app works fine too.

    Z30, Q10, Z10, iP5, SGS3
    02-01-14 03:32 PM
  23. presean's Avatar
    Im use quite a few cameras. Nikon D600, sony nex 5 and panasonic lumix GM1.

    Nikon WMU is the only camera communication app which works on my Q10 and Z30.

    Sony playmemories and panasonic image app does not work. It disconnects after a while.

    Its not a problem with the android runtime wifi because if it is I wouldnt be able to connect my nikon.

    Others have reported that the android go pro app works fine too.

    Z30, Q10, Z10, iP5, SGS3
    Hello does it also works with a z10 or not

    Posted from my flawless BlackBerry Z10
    02-01-14 03:37 PM
  24. presean's Avatar
    The new ones are Class 10 and they are also available in 16GB and 32GB.
    You can learn more about it here: http://www.toshiba-components.com/FlashAir/index.html

    Posted via CB10
    Thanks

    Posted from my flawless BlackBerry Z10
    02-01-14 03:37 PM
  25. The Big Picture's Avatar
    Hello does it also works with a z10 or not

    Posted from my flawless BlackBerry Z10
    The nikon wmu app works fine on the z10 yes. Just remember to update to 10.2.1.1925 OS

    Z30, Q10, iP5. Update CB10 please!
    02-01-14 04:49 PM
43 12

Similar Threads

  1. Make sense to upgrade to 1791 or 1803 leak from the 10.2.1.575 leak?
    By spoonman9696 in forum BB10 Leaked/Beta OS
    Replies: 14
    Last Post: 11-12-13, 07:43 PM
  2. Z10 with PagePlus
    By Adam Fox2 in forum BlackBerry Z10
    Replies: 1
    Last Post: 11-08-13, 01:12 PM
  3. 10.2.0.429 is avaliable in UK
    By mossa210 in forum General BlackBerry Discussion
    Replies: 8
    Last Post: 11-07-13, 08:10 PM
  4. OS 10.2.0.429 on Vodafone Germany
    By Phenylalanin in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 11-07-13, 06:23 PM
  5. 10 hours and I am in the RED!~
    By iloveabersoch in forum BlackBerry Z10
    Replies: 16
    Last Post: 11-07-13, 03:58 PM
LINK TO POST COPIED TO CLIPBOARD