1. jimbo169527's Avatar
    Hi,

    I am struggling with Smart Dialling in BB10 (using the 10.2.1.1925 leak).

    In my company all telephone extensions are 7 digits long and can be accessed publicly by adding a 4 digit code to the front. For this example let's say the access code is 1234 and the extension is 5555555. When I dial 5555555 I want Smart dialing to turn this into 12345555555.

    On my old Bold 9900 I set the Office Extension Access code in Smart Dialling to 1234, the company extension length to 7 digits and the pause option to "no pause". This allowed me to direct dial company extensions by dialling x555555 (adding the x using the Bold's keyboard) whilst calls from from the BES address book just worked (the Bold knew that 7 digit long numbers needed to be prefixed with 1234).

    I've set my Z10 up in the same way but I can't figure out how I get the Z10 to treat the 7 digit 5555555 number as a company extension. There is no option to add an x using the dial pad. If I dial the full number 12345555555 the call works. If I just dial 5555555 the Z10 does not add 1234 so the call fails.

    Has/can anyone get this to work?

    Posted via CB10
    Last edited by jimbo169527; 01-06-14 at 05:33 PM. Reason: typo
    01-06-14 05:06 PM
  2. jimbo169527's Avatar
    Giving this a bump. Has any one succeeded with Smart Dialling for company extension numbers?

    Posted via CB10
    01-09-14 02:12 PM
  3. jmattwood's Avatar
    Trying to get this working on new BB Classic and have had partial success.

    If I create a contact and save the number a X555555, it will dial from the contact (adding the access number automatically).

    I cannot, for the life of me, manually dial the X as I could on the 9900.
    01-14-15 03:12 AM
  4. macdougallc's Avatar
    Try holding down the # key to invoke smart dialling, it then returns a W meaning work, enter ext number and click dial, after a second or 2 it will come back with dial tone and option to dial ext. Click dial and will put call through. Not as smooth as OS7 but works - good luck

    Posted via CB10
    01-14-15 07:07 AM
  5. jimbo169527's Avatar
    Hi, I tried this but it does not seem to work. I thought that "w" by holding down # means "wait" and "p" by holding down * means pause. Wait means wait for you to dial something else, pause means let an amount of time pass before dialling the next number. Unfortunately neither of these seem to be the right thing to invoke smart dialing. On a Bold 9900 you do this by typing x before the company extension. The phone replaces x with the Smart dialing code you have entered into the phone. On the Z10 there is no way to type the letter x when dialing the number.
    04-23-15 05:10 PM
  6. tex3523's Avatar
    After much trial and error. I think I have found a partial solution. First off it only seems to work with a certain type of extension.
    If your company extension is like this: 800-000-1234 x555 it works

    if your extensions are like this:
    800-000-1234
    800-000-1235
    800-000-1236
    meaning i want it to dial 800-000 all the time and just enter the last 4. It doesn't seem to work.

    For the working option. go to phone settings> #smart dialing and enter your phone number in the office extension section: 800-000-1234
    then select your extension length. From my example it would be 3. I also hit the round arrow on the bottom of the screen which says reset smart dialing. Intuitively it seems it would erase the data, but it doesn't not sure if you need to do this to upload the new settings.
    Now you have 2 options
    1) dial the extension from the phone pad by holding # till the w comes up then dial the extension (W555). When you press send, it will dial the 800-000-1234 number. Although it doesn't show up as it actually is dialing that number. Then you will notice on the bottom of the screen it says dial. Once the phone connects you hit dial and the extension will dial. (A pain but it does work)

    2) save your office contact as an extension in the form of X555. Then when you dial the same screen from option 1 will pop up and you have to hit dial once the connection is made to dial the extension.

    Problems:
    these 2 forms are inconsistent.
    1) why does 'w' work from the dial pad but you save it as 'x' in the contacts app. W should mean wait as stated earlier, but it works.
    2) I can't seem to get the extension to automatically dial. It forces me to hit dial once the phone is connected no matter the option of delay or no delay selected.
    3) you must have a valid number in the phone settings>smart dial> office extension access number.

    I don't use it so not a big deal for me, but for a business user this is unsatisfactory, and should be fixed. I don't know how to submit these issues to blackberry, but I'm sure it is in the forums somewhere.
    It should be noted I am on Verizon Q10 still running 10.2.1.3253.
    04-24-15 02:05 PM

Similar Threads

  1. Help with a bold 9780
    By ShahFarrukh in forum BlackBerry Bold 9780
    Replies: 11
    Last Post: 01-27-14, 01:07 PM
  2. Any decent dialer other than Blacada for BB10?
    By jlozada1 in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 01-25-14, 08:26 AM
  3. Use BB10 device to unlock Windows
    By jamusbojangles in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 01-09-14, 12:27 PM
  4. Why do Android Video apps not work with the 1925 leak?
    By jimbo169527 in forum BB10 Leaked/Beta OS
    Replies: 5
    Last Post: 01-07-14, 07:58 AM
  5. Can someone address the FB calendar sync issue on BB10?
    By Satyricrog in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 01-06-14, 02:16 PM
LINK TO POST COPIED TO CLIPBOARD