1. MarkRfitness's Avatar
    My brother in laws has tild.me his z10 has slowed right down after the 10. 3 update. Would anyone know what this would happen and any ideas on what he can do?

    Posted via CB10
    02-20-15 10:12 AM
  2. DaFoxGrey's Avatar
    Give it a few days.
    After an OS update, the device will take time to run all of the background updates and adjustments. That generally takes up to a few days to complete.
    During that time, stuff will be slow and battery life will be shorter.
    Check after a few days to see how it is preforming.
    02-20-15 10:16 AM
  3. rbtg's Avatar
    My brother in laws has tild.me his z10 has slowed right down after the 10. 3 update. Would anyone know what this would happen and any ideas on what he can do?

    Posted via CB10
    you need to remove battery ,if that doesn't do it you need to find out what app it's slowing down the phone
    02-20-15 10:17 AM
  4. imz's Avatar
    Could be his internal memory is low, as with desktops, I think its good practice to not bog it down.

    My Z10 was slow on 10.2
    When updating to 10.3 it said I need more than 1.5GB available to proceed.

    Cleared out my internal storage, moved a few things to SD card, installed 10.3

    Runs very quick, almost like a new device, I'm tempted to hold on to the Z10 a little longer because of it.
    02-20-15 10:17 AM
  5. Doggerz's Avatar
    Also have him do a hard reset.
    Then after a few days if it doesn't speed up have him get to a PC and download SIC Multiwipe and OS 10.3.1.2267 autoloader and then he will have a fresh install.

    Z30STA100-5 /10.3.1.2267 / T-Mobile USA
    02-20-15 10:19 AM
  6. anon1727506's Avatar
    My brother in laws has tild.me his z10 has slowed right down after the 10. 3 update. Would anyone know what this would happen and any ideas on what he can do?

    Posted via CB10
    Mine also is a little sluggish... mostly it is in the UI transitions there seems to be hesitation when a "page" or the HUB is displayed, if I try and click an icon too fast... nothing happens.


    Why it is happening... cutback and poor software implementation? Could be he needs to give it time to settle in, but I've had the issues for a while.

    What you can do.... live with it? You could try doing a clean install of the latest OS using LINK or an Autoloader and see if that clears it up. Or you could downgrade back to 10.2.1.
    02-20-15 10:22 AM
  7. MarkRfitness's Avatar
    Thanks for your replies! I also i have a z10 and no problems with it running slow. So shall forward this on. The only thing I am experiencing is the assistant won't send a message to bbm as it is saying no blackberry pins are connected to my contacts. Same here will give it time to settle down. Thanks again! Mark

    Posted via CB10
    02-20-15 10:38 AM

Similar Threads

  1. Sooo slow..10.3.1
    By muratb in forum BlackBerry Z10
    Replies: 17
    Last Post: 02-21-15, 05:34 AM
  2. Does the Calculator app on the BlackBerry Classic have a sign like Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 02-20-15, 10:39 AM
  3. Update not get properly
    By Uvais A in forum Ask a Question
    Replies: 2
    Last Post: 02-20-15, 10:14 AM
  4. Z10 bluetooth not working on 10.3.1
    By Granrey in forum BlackBerry Z10
    Replies: 1
    Last Post: 02-20-15, 09:55 AM
  5. Chrome after update?
    By hangnthere in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 02-20-15, 09:47 AM
LINK TO POST COPIED TO CLIPBOARD