1. anon(3630135)'s Avatar
    I've done a restore on my device back to 10.0 (clean), reinstall the update to 10.1, add contacts and settings manually and again my maps is unusable!

    I cannot pinch to zoom or even pan across maps application. It stutters, lags behinds and the maps jump all over the screen.

    My next option is to go back to 10.0 and forget the 10.1 update. I also installed the latest maps that came out a few weeks back and thought it would resolve my issue...but nadda..Hence why I did the clean install in the first place.

    Anyone else getting this issue? I am not impressed and this is a major reason for me to have a phone (besides making phone calls)
    06-17-13 08:35 PM
  2. 11pts's Avatar
    I'm having the same issue. Even my sideloaded Google maps runs smoother

    Posted via CB10
    06-17-13 08:37 PM
  3. quangtran1's Avatar
    I've done a restore on my device back to 10.0 (clean), reinstall the update to 10.1, add contacts and settings manually and again my maps is unusable!

    I cannot pinch to zoom or even pan across maps application. It stutters, lags behinds and the maps jump all over the screen.

    My next option is to go back to 10.0 and forget the 10.1 update. I also installed the latest maps that came out a few weeks back and thought it would resolve my issue...but nadda..Hence why I did the clean install in the first place.

    Anyone else getting this issue? I am not impressed and this is a major reason for me to have a phone (besides making phone calls)
    Use Google Maps for Android, you'll be a lot happier.
    06-17-13 08:44 PM
  4. Anonymous94587689's Avatar
    Well... I don't know what to tell you beside that my BB map is working great.
    I am sorry that you are experiencing problems, but it don't...

    Posted via CB10
    06-17-13 09:14 PM
  5. anon(3630135)'s Avatar
    Ok, I'll give that a try...But after a month, they need to really work on this! Having unusable maps application is not something so easily to forgive. At least for my use.

    Thanks for tip
    06-17-13 09:15 PM
  6. tgzgeorge's Avatar
    I've done a restore on my device back to 10.0 (clean), reinstall the update to 10.1, add contacts and settings manually and again my maps is unusable!

    I cannot pinch to zoom or even pan across maps application. It stutters, lags behinds and the maps jump all over the screen.

    My next option is to go back to 10.0 and forget the 10.1 update. I also installed the latest maps that came out a few weeks back and thought it would resolve my issue...but nadda..Hence why I did the clean install in the first place.

    Anyone else getting this issue? I am not impressed and this is a major reason for me to have a phone (besides making phone calls)
    Get an iphone and install google maps, or get a nexus 4
    06-17-13 09:23 PM
  7. IgotsThis's Avatar
    Get an iphone and install google maps, or get a nexus 4
    Lmaoooo oh come on....

    Z10? Why yes it is.
    06-17-13 09:41 PM
  8. Captain_Hilts's Avatar
    I wish people would stop assuming that a problem on one phone means the same problem on all phones. 10.1 does not make maps unusable. I'm on 10.1, and maps works perfectly. Zooming in and out, turn by turn, voice navigation. Clearly, there is an issue with your phone.

    Posted via CB10
    06-18-13 01:37 AM
  9. ESCON's Avatar
    Hey, some more Infos about your device (STL-? OS version Provider ) can help.

    On my device im running Blackberry Maps 10.1.0.790 and have Zero problems... Check your Settings
    06-18-13 01:51 AM
  10. anon(3630135)'s Avatar
    Hey, some more Infos about your device (STL-? OS version Provider ) can help.

    On my device im running Blackberry Maps 10.1.0.790 and have Zero problems... Check your Settings
    I'm running Z10, STL100-3, OS 10.1.0.273, Maps 10.1.0.790 on the Bell network with LTE reception and driving in my car around Toronto (no skyscrapers around). My car even has a sunroof! My wife has a iPhone 5 (Bell also) and I put my phone aside and use hers for navigation instead (flawless). I'm not promoting the iPhone, but her phone does navigation MUCH better. (typing, not so much). The last time my phone was working great, was before 10.1 update. Everything else works fine.

    As I mentioned before, I have restored from scratch, installed latest carrier released OS, and restored my contacts and settings manually with no change.

    I suppose it's my maps processor that's debunked? LOL I would have no idea why my maps would work so terribly and others would not.

    I think I will go back to 10.0 until 10.2 which I may have better luck on (re-activating my maps arm processor?)
    Last edited by shawngt2; 06-18-13 at 06:20 AM.
    06-18-13 06:03 AM
  11. xsacha's Avatar
    Get an iphone and install google maps, or get a nexus 4
    Google Maps also works on Blackberry10.1.
    You just need to side-load the .bar. Everything working.
    06-18-13 06:15 AM
  12. anon(3630135)'s Avatar
    Google Maps also works on Blackberry10.1.
    You just need to side-load the .bar. Everything working.
    Where do you find latest official BAR?
    06-18-13 06:22 AM
  13. Jedi_Blackberry's Avatar
    Having no issues on 10.1.

    Posted via CB10
    06-18-13 06:45 AM
  14. conto_m's Avatar
    I'm running Z10, STL100-3, OS 10.1.0.273, Maps 10.1.0.790 on the Bell network with LTE reception and driving in my car around Toronto (no skyscrapers around). My car even has a sunroof! My wife has a iPhone 5 (Bell also) and I put my phone aside and use hers for navigation instead (flawless). I'm not promoting the iPhone, but her phone does navigation MUCH better. (typing, not so much). The last time my phone was working great, was before 10.1 update. Everything else works fine.

    As I mentioned before, I have restored from scratch, installed latest carrier released OS, and restored my contacts and settings manually with no change.

    I suppose it's my maps processor that's debunked? LOL I would have no idea why my maps would work so terribly and others would not.

    I think I will go back to 10.0 until 10.2 which I may have better luck on (re-activating my maps arm processor?)
    Exact same model and carrier and I also am getting no visuals on my map application. This is going on 4 days of outage for me. I wonder if this is a Bell issue. Picture attached of what my maps looks like.

    Since 10.1, BB Maps is barely usable anymore!-img_00000703.png

    Posted via CB10
    06-18-13 07:07 AM
  15. ESCON's Avatar
    ok and can you try it without your Bell sim card, maybe using your wifi@home ? last time after an update my maps need 4 min on first startup so try to leave maps open for a few minutes
    06-18-13 07:27 AM
  16. anon(3630135)'s Avatar
    We're all not alone. Look at BBM reviews! Lots think it's crap!

    Posted via CB10
    06-18-13 06:57 PM
  17. hondok9's Avatar
    Having similar issues after installing the update in app world.
    Still on 10.0 with Verizon.
    After installing the update all I had was a blue dot in the center of a white screen.
    I went into my maps settings and cleared the history and after two days all seems to be working properly.

    Posted via CB10
    06-18-13 10:20 PM
  18. conto_m's Avatar
    Having similar issues after installing the update in app world.
    Still on 10.0 with Verizon.
    After installing the update all I had was a blue dot in the center of a white screen.
    I went into my maps settings and cleared the history and after two days all seems to be working properly.

    Posted via CB10
    WOW, great tip!, just cleared all history, the app crashed, went back in and now the maps appear again. You are a life saver. What a weird bug. THANK YOU.

    Posted via CB10
    ESCON likes this.
    06-18-13 10:23 PM
  19. Jonathan-Archer's Avatar
    I tried the Maps app for the first time ever just this weekend and I was surprised at how well it worked. So no complaints from me...

    Posted via CB10
    06-19-13 05:32 AM
  20. tgzgeorge's Avatar
    Google Maps also works on Blackberry10.1.
    You just need to side-load the .bar. Everything working.
    Not everything should be side loaded. Native BB10 apps should be develop, maps is one of them.
    06-19-13 02:24 PM
  21. mithrazor's Avatar
    Having similar issues after installing the update in app world.
    Still on 10.0 with Verizon.
    After installing the update all I had was a blue dot in the center of a white screen.
    I went into my maps settings and cleared the history and after two days all seems to be working properly.

    Posted via CB10
    Hmm, thank you for the tip. I'll try it and see if it does the trick.
    07-12-13 12:04 AM
  22. rpmyher's Avatar
    Having similar issues after installing the update in app world.
    Still on 10.0 with Verizon.
    After installing the update all I had was a blue dot in the center of a white screen.
    I went into my maps settings and cleared the history and after two days all seems to be working properly.

    Posted via CB10
    Thanks, clearing all History worked for my problem, which was that Blackberry Maps would crash after any search was performed.
    08-13-13 11:37 AM

Similar Threads

  1. BB Maps is gone off my storm 2
    By barberjon3 in forum BlackBerry Storm2
    Replies: 7
    Last Post: 01-02-10, 06:30 PM
  2. Google Maps... What a Joke.. BB Maps Is Sooooo Much Better
    By torchd in forum General BlackBerry Discussion
    Replies: 19
    Last Post: 09-18-09, 08:51 PM
  3. Just installed Hybrid 3.5 and BB Maps is gone
    By Japultra in forum Legacy Leaked/Beta OS
    Replies: 2
    Last Post: 04-11-09, 09:03 PM
  4. HELP BB MAPS is GONE
    By rdude2332 in forum BlackBerry Storm
    Replies: 6
    Last Post: 03-31-09, 12:26 PM
  5. BB Maps is showing that I am in Mexico
    By rightcoastsurf in forum BlackBerry Storm
    Replies: 14
    Last Post: 11-22-08, 06:24 AM
LINK TO POST COPIED TO CLIPBOARD