08-14-18 11:28 PM
613 ... 1314151617 ...
tools
  1. Rebelllious's Avatar
    I don't need that thing. Otherwise I would have bought it months ago.
    11-09-14 03:11 PM
  2. leticeberry's Avatar
    I deleted It, reinstalled it and it still doesn't work. It still says downloading but nothing is happening.

    Posted via CB10
    11-09-14 05:31 PM
  3. Rebelllious's Avatar
    Please PM me with the details of what you have done and what you get. It seems to me you might have missed some configuration steps.
    11-10-14 01:57 AM
  4. D3C0D3R's Avatar
    On the new address (vpn.sideload.it) I'm only getting a timeout error when trying to connect to the vpn on my Passport... any ideas?

    I updated the .apk in anticipation of this working, but now I can't even connect :/ :s

    Edit!:
    Scratch that, it's connecting now.
    Now I'm getting the 533 file is not a zip file error...

    Edit edit!:
    Okay nevermind, just the SideSwype bar file, all of the other ones I tested worked perfectly!

    Thanks a ton!

    (ps, love the easy-select files now!)

    Praise be unto our Lord Squircle | Passport SQW100-1/10.3.0.1418
    Last edited by D3C0D3R; 11-10-14 at 01:09 PM.
    11-10-14 12:56 PM
  5. leticeberry's Avatar
    Now I have a different problem. I cannot connect sideload.it to the vpn server. I had no problem with that part yesterday, but today I do. I'm about to pull my hair out over this.
    11-10-14 01:42 PM
  6. Rebelllious's Avatar
    Now I have a different problem. I cannot connect sideload.it to the vpn server. I had no problem with that part yesterday, but today I do. I'm about to pull my hair out over this.
    I asked you to get back to me using PM if you needed. You never did.
    For everyone, be sure you either use the latest Sideload.it app (version 1.7, 1.0.7.0 or whatever containing any digits like that) or update the server address to http://vpn.sideload.it to get the app working.
    For those having the app stuck at "Installing, please wait" - sorry, guys, it seems I cannot do anything with this, as this is out of the sphere of my influence. It appears randomly for ones, constantly for others (no dependence on position around the globe), but what I can tell for sure - most people have my service working and this is the real proof it does work. Sorry to disappoint you. If you are hard-working, you could try it from time to time. Otherwise I would encourage you to use any other sideloading tool or service. One more option is to use the scripts and descriptions I made back at the main website to get a working server of your own (using Amazon AWS, for instance) - chances are you will avoid this problem. At least you will be able to say "OK, I did my best and now hell with it!"

    P.S. For those not really lucky with the service because of "Installing, please wait" - you could help me gather more statistics about where you fail by sending an email to suppor@sideload.it I am not sure this will help to resolve the issue, but I will at least have more information on it for possible solution.
    11-10-14 02:23 PM
  7. Rebelllious's Avatar
    (ps, love the easy-select files now!)
    I knew everyone would!
    11-10-14 02:25 PM
  8. annon91221's Avatar
    I was getting that "wait" message.. took a hint from one of your earlier posts and connected over wireless network instead of WiFi and it started working..

    Also.. I believe that the latest apk has http:// svpn.sideload.it instead of http:// vpn.sideload.it as a preloaded setting..

    Posted via CB10
    11-10-14 04:53 PM
  9. leticeberry's Avatar
    Please PM me with the details of what you have done and what you get. It seems to me you might have missed some configuration steps.
    Sorry I didn't PM you but I have no idea how to do that from the passport. Here are screenshots of what I did.

    Sideload.it - sideload any BAR files for FREE (no computer needed!!!)-img_20141110_191418.png
    Sideload.it - sideload any BAR files for FREE (no computer needed!!!)-img_20141110_191411.png
    Sideload.it - sideload any BAR files for FREE (no computer needed!!!)-img_20141110_191403.png
    Sideload.it - sideload any BAR files for FREE (no computer needed!!!)-img_20141110_191349.png
    Sideload.it - sideload any BAR files for FREE (no computer needed!!!)-img_20141110_191044.png

    Posted via CB10
    11-10-14 06:22 PM
  10. GodGibson's Avatar
    I like this app but I only got it to work once. Should the application Auto Detect device IP? , and is the default one correct I would also like a Percentage added to the side loading progress is it possible ?
    11-10-14 07:53 PM
  11. ralfyguy's Avatar
    I like this app but I only got it to work once. Should the application Auto Detect device IP? , and is the default one correct I would also like a Percentage added to the side loading progress is it possible ?
    That's what I experienced. I got it to work the first time, right after I installed the new app. Then I closed everything without making changes to the setups and reopened everything. It didn't work anymore after. Just app closing and closing the connection and the disabling dev mode. Then enable dev mode again, open vpn connection, open app, search for file, tap on the file and tap install. Just the same procedure as before when it worked.
    11-10-14 08:37 PM
  12. GodGibson's Avatar
    That's what I experienced. I got it to work the first time, right after I installed the new app. Then I closed everything without making changes to the setups and reopened everything. It didn't work anymore after. Just app closing and closing the connection and the disabling dev mode. Then enable dev mode again, open vpn connection, open app, search for file, tap on the file and tap install. Just the same procedure as before when it worked.
    I figured it out, if I run the app over mobile network works fine if I switch to WI-FI it breaks it big time. Dev needs to look into this

    And add a % Bar
    11-10-14 08:59 PM
  13. BCITMike's Avatar
    Want a server like Sideload.it belonging to you only? It is only several steps away
    Go Want the same? | Sideload.it and follow the instruction on how to install your own server.
    Enjoy it.
    Rebellious,

    I installed using your script today on Centos 6.6. Two points:

    1. "get $file -O $filename" should also add "--no-check-certificate" to make https downloads more reliable. This could be a source of 0 byte and failed upgrades.
    2. I had to add the following to /etc/httpd/conf/http.conf:
    AddType application/x-httpd-php .php

    Do this before starting httpd.
    11-11-14 01:55 AM
  14. BCITMike's Avatar
    Rebellious,

    How did you solve the filenames with spaces? Or not? Because this issue results in "Installing the app. Please wait a little..."

    Code:
    [Tue Nov 11 01:35:59 2014] [error] [client IP] PHP Notice:  Undefined index: device in /var/www/html/install.php on line 2
    [Tue Nov 11 01:35:59 2014] [error] [client IP] PHP Notice:  Undefined index: password in /var/www/html/install.php on line 3
    [Tue Nov 11 01:35:59 2014] [error] [client IP] PHP Notice:  Undefined index: file in /var/www/html/install.php on line 4
    Error: Host name may not be null
    [Tue Nov 11 02:00:09 2014] [error] [client IP] Directory index forbidden by Options directive: /var/www/html/
    [Tue Nov 11 02:00:10 2014] [error] [client IP] File does not exist: /var/www/html/favicon.ico
    Error: Bar file does not exist or not a file or I cannot read it: /var/www/html/bars/BitTorqueFree
    This is what happens when file on server has space, "BitTorqueFree v1.2.0.bar".
    Edit: I see you removed spaces.


    So then I renamed the files with spaces to underscores and tried again. This time the error_log showed connection refused when trying to access my device:

    Code:
    Error: Cannot connect: Connection to https://192.168.2.102 refused. You may have to reboot the target.
    I disconnected from my VPN, opened the chrome extension and successfully logged into my Z30 without issue. So I'm not sure why it couldn't connect to my phone via the VPN, but this also causes symptom of "Installing the app. Please wait a little...".
    Next to debug that.

    Edit: Ok, I can't get the bar install to work from the command line. The question I have, how does the server communicate with the phone by IP? There is no route on the machine for that subnet, there is no private IP on the network interface (has public IP), so when the bar install goes to talk to 192.168.2.x, how exactly is that occurring? The packets are going no where. It'll only work on your LAN, not on remote VPS. At least not without some addition IP/networking changes.
    Last edited by BCITMike; 11-11-14 at 04:13 AM.
    11-11-14 03:15 AM
  15. Rebelllious's Avatar
    Rebellious,

    I installed using your script today on Centos 6.6. Two points:

    1. "get $file -O $filename" should also add "--no-check-certificate" to make https downloads more reliable. This could be a source of 0 byte and failed upgrades.
    It is possible to add that but it is only needed when a source website does not have a reliable SSL certificate. I wouldn't dare to download anything from such websites. Would you? But I will add that, no problem.
    2. I had to add the following to /etc/httpd/conf/http.conf:
    AddType application/x-httpd-php .php
    Do this before starting httpd.
    Why would you need this? For me, it was never needed and everything worked for most people. You can either publish it here or BBM me.
    11-11-14 06:02 AM
  16. Rebelllious's Avatar
    Rebellious,

    How did you solve the filenames with spaces? Or not? Because this issue results in "Installing the app. Please wait a little..."

    Code:
    [Tue Nov 11 01:35:59 2014] [error] [client IP] PHP Notice:  Undefined index: device in /var/www/html/install.php on line 2
    [Tue Nov 11 01:35:59 2014] [error] [client IP] PHP Notice:  Undefined index: password in /var/www/html/install.php on line 3
    [Tue Nov 11 01:35:59 2014] [error] [client IP] PHP Notice:  Undefined index: file in /var/www/html/install.php on line 4
    Error: Host name may not be null
    [Tue Nov 11 02:00:09 2014] [error] [client IP] Directory index forbidden by Options directive: /var/www/html/
    [Tue Nov 11 02:00:10 2014] [error] [client IP] File does not exist: /var/www/html/favicon.ico
    Error: Bar file does not exist or not a file or I cannot read it: /var/www/html/bars/BitTorqueFree
    This is what happens when file on server has space, "BitTorqueFree v1.2.0.bar".
    Edit: I see you removed spaces.


    So then I renamed the files with spaces to underscores and tried again. This time the error_log showed connection refused when trying to access my device:

    Code:
    Error: Cannot connect: Connection to https://192.168.2.102 refused. You may have to reboot the target.
    I disconnected from my VPN, opened the chrome extension and successfully logged into my Z30 without issue. So I'm not sure why it couldn't connect to my phone via the VPN, but this also causes symptom of "Installing the app. Please wait a little...".
    Next to debug that.

    Edit: Ok, I can't get the bar install to work from the command line. The question I have, how does the server communicate with the phone by IP? There is no route on the machine for that subnet, there is no private IP on the network interface (has public IP), so when the bar install goes to talk to 192.168.2.x, how exactly is that occurring? The packets are going no where. It'll only work on your LAN, not on remote VPS. At least not without some addition IP/networking changes.
    We could discuss all this separately, as here most people understand not more than 5% of what you are talking about. BBM me for discussion. Everything is not as simple as you might think, I guess.
    11-11-14 06:05 AM
  17. Rebelllious's Avatar
    I figured it out, if I run the app over mobile network works fine if I switch to WI-FI it breaks it big time. Dev needs to look into this

    And add a % Bar
    Can't look into traffic routing of your IPS or mobile network provider. This is not what I can physically do. It's their fault, not mine.
    As for the percentage of download, I will try to invent something.
    11-11-14 06:06 AM
  18. Rebelllious's Avatar
    I like this app but I only got it to work once. Should the application Auto Detect device IP? , and is the default one correct I would also like a Percentage added to the side loading progress is it possible ?
    Generally, it should. But if you are not sure it does, you are welcome to double-check it using your About device - Network information screen.
    Concerning download percentage, as I said I will look into this.
    GodGibson likes this.
    11-11-14 06:08 AM
  19. Variante Alta's Avatar
    Hey everyone (and particularly Reb for all the hard work)...I've searched for the VPN settings - what is the current User# and Password? I'm getting an Authentication error. Many thanks.

    Edit: thanks for the tips...got it now!
    11-11-14 08:09 AM
  20. Guyzer's Avatar
    someone earlier posted his vpn settings, one thing I noticed he typed in

    User

    instead of

    user

    case matters, this was the case a few months back. not sure if reb was able to add another "User" to avoid these people who don't follow instructions to a T (not t)
    11-11-14 09:35 AM
  21. leticeberry's Avatar
    I changed vpn settings from User to user as suggested by the previous poster and also turned off wifi to only use the cell network, but that still didn't work.

    Posted via CB10
    11-11-14 10:15 AM
  22. dustmalik's Avatar
    For those who have been making mistakes on the VPN settings page, here it is in screenshots
    Sideload.it - sideload any BAR files for FREE (no computer needed!!!)-img_20141111_172012.png
    Sideload.it - sideload any BAR files for FREE (no computer needed!!!)-img_20141111_172121.png

    Posted via CB10 using my Gorgeous Z30
    leticeberry likes this.
    11-11-14 10:23 AM
  23. leticeberry's Avatar
    For those who have been making mistakes on the VPN settings page, here it is in screenshots
    Click image for larger version. 

Name:	IMG_20141111_172012.png 
Views:	801 
Size:	66.8 KB 
ID:	313653
    Click image for larger version. 

Name:	IMG_20141111_172121.png 
Views:	801 
Size:	73.9 KB 
ID:	313654

    Posted via CB10 using my Gorgeous Z30
    I changed settings to what you said and now I can't even connect to sideload.it. Ugh!

    Posted via CB10
    11-11-14 10:52 AM
  24. ralfyguy's Avatar
    I changed settings to what you said and now I can't even connect to sideload.it. Ugh!

    Posted via CB10
    Same here

    Posted via CB10
    11-11-14 11:43 AM
  25. Rebelllious's Avatar
    There was a temporary problem. It is fixed now and I hope you won't have connection problems now.

    P.S. Now you should be seeing a bit more information on the installation process. Yet, this does not seem to solve the requested percentage of download.
    Tell me if you need it.
    11-11-14 01:53 PM
613 ... 1314151617 ...

Similar Threads

  1. Snap for Amazon Appstore please!
    By CrackberryQ in forum Android Apps (Amazon Store & APK Files)
    Replies: 9
    Last Post: 11-06-14, 04:55 AM
  2. STL100-1 Debrick and core OS files?
    By ahmad habib in forum BB10 Leaked/Beta OS
    Replies: 3
    Last Post: 09-20-14, 06:59 PM
  3. Sachesi Error with 10.3.0.1154 for my Z10?
    By ahmad habib in forum BB10 Leaked/Beta OS
    Replies: 3
    Last Post: 09-20-14, 01:59 PM
LINK TO POST COPIED TO CLIPBOARD