1. palosanto's Avatar
    I have filters in my IMAP gmail acct so that messages get organized depending on sender, project etc. Filters usually are handled with gmail 'tags' which translate in folders in my PC's client, Thunderbird. I don't use filters in Thunderbird but only in gmail right from the web interface.

    New messages show up in Thunderbird in bold in the corresponding folder as processed by the filters in gmail web acct.
    That works great.
    However, In my z10, because the message bypasses the inbox and goes straight into the tagged folder, I don't know that a message has arrived because it doesn't show up in the hub and the notification sound and LED don't execute.
    Is there a way to get the messages to show up on the hub and the notiffication sound and LED to work?
    Thanks
    01-14-14 04:05 PM
  2. Omnitech's Avatar
    I have filters in my IMAP gmail acct so that messages get organized depending on sender, project etc. Filters usually are handled with gmail 'tags' which translate in folders in my PC's client, Thunderbird. I don't use filters in Thunderbird but only in gmail right from the web interface.

    New messages show up in Thunderbird in bold in the corresponding folder as processed by the filters in gmail web acct.
    That works great.
    However, In my z10, because the message bypasses the inbox and goes straight into the tagged folder, I don't know that a message has arrived because it doesn't show up in the hub and the notification sound and LED don't execute.
    Is there a way to get the messages to show up on the hub and the notiffication sound and LED to work?
    Thanks


    First of all, Google's tags are not identical to folders, so you have to keep that in mind. (For example, a message can have multiple tags, but cannot reside in multiple folders unless you create duplicate messages)

    As I recall, "new mail" notifications in BB10 just pertain to the "inbox".

    You could try a 3rd-party notification app like Hub++ and see how that works, it also has a rule engine where you can specify actions based on a limited set of message characteristics (from/to/account/text strings in body/subject, etc.)

    Because folders in synced email accounts are not expanded by default in Hub, the "bolded" aspect that you use in Thunderbird wouldn't be useful.

    You could in theory edit your Gmail rules so that it tags messages with the folder it is sorting them to by placing a defined text string in the subject or body, and then add that text string as a condition in a Hub++ rule.
    01-14-14 04:38 PM
  3. palosanto's Avatar
    First of all, Google's tags are not identical to folders, so you have to keep that in mind. (For example, a message can have multiple tags, but cannot reside in multiple folders unless you create duplicate messages).
    I disagree. If you assign several labels to one message, you will get the same message copied into each folder defined by the label.

    As I recall, "new mail" notifications in BB10 just pertain to the "inbox".
    That's my problem. Only solution I can see is untick the option "Skip the inbox" when I create the filter and I'll have then a copy in the inbox and another in the corresponding label folder. Then I could delete the copy in the inbox after reading.
    Interestingly enough, doing that, a new message always shows up as two symbols: the usual unopened envelope AND a yellow folder. Clicking in the folder, shows the copy located in the folder defined by the label.
    And also the notification chime and LED work normally.
    However, if I have 'skip theinbox' selected, there is nothing in the inbox. I have to go to the folder and then when I open the folder I see the message and the chime/LED go off ...
    Showing archived new gmail messages on hub-img_20140114_150508.png

    You could try a 3rd-party notification app like Hub++ and see how that works, it also has a rule engine where you can specify actions based on a limited set of message characteristics (from/to/account/text strings in body/subject, etc.)
    Because folders in synced email accounts are not expanded by default in Hub, the "bolded" aspect that you use in Thunderbird wouldn't be useful. .
    I haven't tried Hub++ but I will definitely give it a try.

    You could in theory edit your Gmail rules so that it tags messages with the folder it is sorting them to by placing a defined text string in the subject or body, and then add that text string as a condition in a Hub++ rule .
    These are the type of rules that I'm defining right now based on Subject keywords or 'from' field value.
    Thanks
    Last edited by palosanto; 01-14-14 at 05:38 PM.
    01-14-14 05:26 PM
  4. Omnitech's Avatar
    I disagree. If you assign several labels to one message, you will get the same message copied into each folder defined by the label.

    From the context of an IMAP client, that is simply the "folder emulation" that Google does to attempt to represent their labels as folders since IMAP has no concept of "labels". Labels are not folders. Google never stores multiple copies of the same message, no matter how they display a message in their UI.

    There are also some 3rd-party apps which access Gmail directly via a web interface but have special UI customizations that make it work more like an app than just opening Gmail in a web browser. And of course that means preserving more of Gmail's unique features. Here's the one that seems most popular:

    Email for Google Gmail(Nfc HUB-Connected BBM-Enabled) - BlackBerry World
    01-14-14 07:13 PM
  5. palosanto's Avatar
    Hi again. I understand what you are saying about the folders. I was also referring to the fact that thunderbird does have real folders that correspond to the virtual Google folders/labels.
    I'll try the app that you are mentioning
    Thanks again
    01-14-14 07:32 PM
  6. Pranav Thakker's Avatar
    I have filters in my IMAP gmail acct so that messages get organized depending on sender, project etc. Filters usually are handled with gmail 'tags' which translate in folders in my PC's client, Thunderbird. I don't use filters in Thunderbird but only in gmail right from the web interface.

    New messages show up in Thunderbird in bold in the corresponding folder as processed by the filters in gmail web acct.
    That works great.
    However, In my z10, because the message bypasses the inbox and goes straight into the tagged folder, I don't know that a message has arrived because it doesn't show up in the hub and the notification sound and LED don't execute.
    Is there a way to get the messages to show up on the hub and the notiffication sound and LED to work?
    Thanks
    Did you happen to find a solution to your problem?
    I recently started facing the same problem. I don't know what was the scenario before 10.2.1
    Would be happy to know what solution worked for you?
    10-21-14 03:11 AM
  7. Joshu42's Avatar
    Go to email account settings, push the "Edit folder settings", tick the ones you want sync...
    Showing archived new gmail messages on hub-img_20141021_122557.png
    Showing archived new gmail messages on hub-img_20141021_122722.png
    10-21-14 05:28 AM

Similar Threads

  1. At&t slow text messages
    By trooperMoo in forum AT&T
    Replies: 19
    Last Post: 04-12-14, 05:36 PM
  2. Legend 10.2.1.1925 Not Loading on Verizon Q10
    By Gray in forum BB10 Leaked/Beta OS
    Replies: 5
    Last Post: 01-15-14, 07:01 AM
  3. Q10 error - won't turn on
    By Billy Hope in forum BlackBerry Q10
    Replies: 9
    Last Post: 01-15-14, 05:05 AM
  4. Legend 10.2.1.1925 Not Loading on Verizon Q10
    By Gray in forum BlackBerry Q10
    Replies: 2
    Last Post: 01-14-14, 02:56 PM
  5. Replies: 1
    Last Post: 01-14-14, 01:59 PM
LINK TO POST COPIED TO CLIPBOARD