1. mrmarstm's Avatar
    Hello,
    on my Q10 I mounted a Sandisk Ultra 64GB (SDXC, Class 10, UHS-1).

    I formatted it directly from Q10 (it got an exFAT file system), then I connected an USB cable enabling to access phone's SD card from my PC, and I filled the card with about 50GB of music and 5GB of pictures.

    After some restarts (and some days, just in order to be sure it wasn't an indexing issue) I still have the same extremely annoying issue: when I open the "Music" application it takes an average of 10-15 seconds to be able to see songs' list and play them, as well as the songs browsing experience is not so fluid.
    Same as for "Pictures", even thought a bit better than with Music.
    No problems in recording 1080p videos, so at least I verified that the card can support that transfer rate.

    Now I'm with last official OS 10.3 version (but it happened since the very first upgrade to 10.3), but there's to say that with OS 10.2 it was way better, it just took a couple of seconds to access my Music.

    The million dollar question is: it is an endemic problem of BlackBerry OS 10.3 not to be able to quickly handle thousands of songs, or do I have some issue with my SD card?
    Do anyone of you have any experience with "full bodied" SD cards in your phones?
    Do you believe if I upgrade the SD to some extreme or extreme pro model it will completely reverse the situation, or will it be only a matter of gaining a couple of seconds (against those 10-15) cause the root of the problem is anyway in the engine/indexing regardless how fast is the conversation with the card?

    Thanks a lot in advance for your cooperation.
    Best.
    03-08-16 06:26 AM
  2. dangerousfen's Avatar
    I've got a Kingston 64gb card in my Z30 with 18gb of music and 8gb of pictures and it flies with no appreciable lag at all. Never even formatted it, plugged it into the phone straight from the shrink wrap packaging.

    Maybe you've got a cloned card, which is very common with the SanDisk products.


    "Z30 STA100-2 UK" 10.3.2.2836 Get's a Ten from Fen.
    03-08-16 11:33 AM
  3. Djlatino's Avatar
    If you have time, I'd do a test on that SD Card, to see if it's maybe just dying on you, or as dangerousfen suggested, it might be a clone.
    https://sosfakeflash.wordpress.com/2...erfeit-drives/
    Check that link out, downloads are at the bottom.

    p.s. you need a computer for this
    PatrickMJS and moyah8 like this.
    03-08-16 11:36 AM
  4. PatrickMJS's Avatar
    I'm with DJ Latino.

    Not only are his tunes cool, but his remarks are as well.

    I have the SanDisk Ultra 128 GB Class 10 MicroSDXC I. I formatted it with the exFat format using my Windows 10 laptop.

    It works perfectly with no issues and is pretty darn quick at accessing files.

    My z30 is on OS 10.3.2.2639.

    The card currently has 68 GB used out of 119 total capacity.

    Most of the card's contents is comprised of music, video and photos. It has almost all the content since I got my z10 in Feb 2013 so I have had to archive very little since then. When I switched to the z30 I simply transferred my old 64 GB card into the new phone. Then, when I got this new card last year, I just used windows deaf and drop to transfer the old cards contents to the new card. Working beautifully. No lag.

    My daughter's husband has a Note4 with a 32 GB card and they were here on the weekend showing us some pictures of their recent holiday. Out of about 100 pictures, 3 were corrupted such that a large part of the photo was just a grey box. I have never had that happen on mine.

    I recommended he copy the card's contents to a hard drive, reformat it using the "full" not the "quick" format. You should do the same.
    Last edited by PatrickMJS; 03-08-16 at 12:27 PM.
    Djlatino likes this.
    03-08-16 12:08 PM
  5. The_Passporter's Avatar
    If you really want to know just go to Bestbuy or similar store and buy the same card. Be sure to ask if they will take the product back and up until how many days. You should be able to get an answer to whether your card is the problem or not. If not then just return the card to the store and decide on the classic or the Passport

    Posted via CB10
    03-10-16 01:16 PM
  6. mrmarstm's Avatar
    Thanks to all for your suggestions.
    In the end I bought a Samsung Pro+ U3 card, and the improvement was only a small gain of a couple of seconds.
    So I can confirm that's definitely an issue related to 10.3 and large SD cards full of files.
    Regards.
    03-21-16 06:03 AM
  7. PatrickMJS's Avatar
    Did you try reformatting the card as I suggested above.

    I ask because your conclusion about 10.3 is a big stretch given that so many of us have large SD cards without experiencing the issue you have reported.

    Posted via CB10
    03-21-16 12:03 PM
  8. mad_mdx's Avatar
    Thanks to all for your suggestions.
    In the end I bought a Samsung Pro+ U3 card, and the improvement was only a small gain of a couple of seconds.
    So I can confirm that's definitely an issue related to 10.3 and large SD cards full of files.
    Regards.
    You confirm you have a problem but not the general OS. You may need to reload your OS and start from scratch
    PatrickMJS likes this.
    03-21-16 01:33 PM

Similar Threads

  1. How do I get Facebook linked contacts from Z10 to Priv?
    By CrackBerry Question in forum BlackBerry Priv
    Replies: 2
    Last Post: 03-11-16, 02:09 AM
  2. Why is my alarm set off when it is supposed to be on?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-08-16, 06:57 AM
  3. Replies: 0
    Last Post: 03-08-16, 02:22 AM
  4. Any app for nut tracker to use on my z30?
    By CrackBerry Question in forum BlackBerry OS Apps
    Replies: 1
    Last Post: 03-08-16, 01:42 AM
LINK TO POST COPIED TO CLIPBOARD