1. blkbryvegas's Avatar
    Hi I have done a lot of searching and found similar posts but no answers... After 7 days the email in my inbox is gone (sent messages remain) . My email (pop) is not from a free email account and it's downloaded from a business website.
    The main reason I have a blackberry is for the email but I can't get it to work like my old bold and curve where I could always store years of emails! Can anyone help?
    Thank you
    12-07-14 06:43 PM
  2. Dave Bourque's Avatar
    Look at your settings and increase the sync time.

    Posted via CB10
    12-07-14 06:44 PM
  3. anon(9208252)'s Avatar
    If all else fails delete acct and set up again making sure you set your sync to always
    12-07-14 06:46 PM
  4. blkbryvegas's Avatar
    Thanks! But I can't find "sync time". I went to email then "settings" then "display and actions" looked in the other folders as well but nada?
    12-10-14 09:13 PM
  5. INTz's Avatar
    Look for advanced settings

    Posted via CB10
    12-10-14 09:50 PM
  6. jdesignz's Avatar
    Q10 email keeps deleting itself every 7 days-img_20141211_111130.png



    Sent from my Mighty Q10SQN100-3/10.3.1.1154
    12-10-14 10:13 PM
  7. Mathijs Booden's Avatar
    Set sync interval to more than 7 days.

    Posted via CB10
    12-11-14 03:40 AM
  8. blkbryvegas's Avatar
    Thanks but that's exactly where I have been looking (jdesignz) but mine goes from 5 mins to just 24 hours? Also has a "manual" option. Strange... I tried it on manual for a few days but didn't make a difference. Didn't offer me anything further "manual" options either.
    12-11-14 04:24 AM
  9. Henry Jr's Avatar
    I can offer premium hosted exchange which will provide exemplary email performance, reliability and features. PM me if interested.

    Q10 (SQN100-3)
    12-11-14 08:51 AM
  10. Andrew4life's Avatar
    Thanks but that's exactly where I have been looking (jdesignz) but mine goes from 5 mins to just 24 hours? Also has a "manual" option. Strange... I tried it on manual for a few days but didn't make a difference. Didn't offer me anything further "manual" options either.
    Have you tried deleting and setting up your email account again? I re one of the email types you could only set the sync time-frame during setup and not subsequently

    Posted via CB10
    12-11-14 08:59 AM
  11. misterabrasive's Avatar
    Thanks but that's exactly where I have been looking (jdesignz) but mine goes from 5 mins to just 24 hours? Also has a "manual" option. Strange... I tried it on manual for a few days but didn't make a difference. Didn't offer me anything further "manual" options either.
    I believe that you will have to delete the account and set it up again on your Q10. When you configure it, you should have the option to set the "save" time to whatever you want. I'm sure someone will correct me if I'm off base.

    Posted with my Z10 on Verizon 10.2.1.3253
    12-11-14 09:01 AM
  12. conite's Avatar
    Thanks but that's exactly where I have been looking (jdesignz) but mine goes from 5 mins to just 24 hours? Also has a "manual" option. Strange... I tried it on manual for a few days but didn't make a difference. Didn't offer me anything further "manual" options either.
    You're trying to change the interval, not the timeframe.

    Z30STA100-5/10.3.1.1154
    12-11-14 09:04 AM
  13. jdesignz's Avatar
    He should have fixed it now.

    PasaportePilipinasSQW100-1/10.3.1.1154
    12-11-14 09:40 AM
  14. blkbryvegas's Avatar
    I'm still having problems. I deleted my email account and then recreated it. Now it only lasts 2 days. Uhg. I have taken a closer look at the image jdesignz posted (thanks!) and I don't have the option for "Sync Timeframe" it simply not there. Like "conite" said... I was trying to "change time frame" as that is the closest option.
    12-30-14 09:07 PM
  15. bobshine's Avatar
    I'm still having problems. I deleted my email account and then recreated it. Now it only lasts 2 days. Uhg. I have taken a closer look at the image jdesignz posted (thanks!) and I don't have the option for "Sync Timeframe" it simply not there. Like "conite" said... I was trying to "change time frame" as that is the closest option.
    Who's your email host?

    Posted via CB10
    12-30-14 09:09 PM
  16. blkbryvegas's Avatar
    It's a pop email account from my website
    12-30-14 09:16 PM
  17. bobshine's Avatar
    It's a pop email account from my website
    POP email is a "pull" email so it's not possible to have "push" email on it.

    You should check if you can use an "Exchange" server for your email cause POP is rarely used nowadays.

    I'm not sure how many days you can sync with POP. I would assume that "forever" should work since its a one way sync.

    Posted via CB10
    12-31-14 12:59 AM

Similar Threads

  1. Delete Chats on all members BBM
    By Sadsfan in forum General BBM Chat
    Replies: 10
    Last Post: 12-08-14, 08:32 AM
  2. How do I login to a BlackBerry email account?
    By snmZ10 in forum Ask a Question
    Replies: 6
    Last Post: 12-08-14, 06:34 AM
  3. Why can't I delete a text message on my Bold 9900?
    By theredical1 in forum BlackBerry Bold 9930/9900
    Replies: 3
    Last Post: 12-07-14, 08:20 PM
  4. unlocked blackberry passport same for every country?
    By rudra mishra in forum BlackBerry Passport
    Replies: 1
    Last Post: 12-07-14, 01:48 PM
  5. Why am I getting intermittent problem message on emails?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-07-14, 01:45 PM
LINK TO POST COPIED TO CLIPBOARD