09-05-14 10:57 PM
77 123 ...
tools
  1. Akshay Borkar's Avatar
    After reading forums for almost months.. i never ever faced PIM problems... and considered myself lucky...!!
    But after my STL 100-1 on Vodafone IN auto-updated to the latest 10.2.1.2102 software release last week, this PIM beast struck me too..!!
    I searched crackberry forums to find any solution but unfortunately couldn't find one..!!
    So i decided to do some trial and error experiments..!! I failed for numerous times..I learnt that PIM wont stop till it drains the battery to 0% and the phone switches off on its own (NOTE: manual restart wont work, but if the phone shuts down automatically due to PIM battery drainage then it stops.. it wont start back again immediately when you switch on)
    And finally after so many failures.. when i saw the CPU usage of PIM over 50% at that moment... I went to accounts...and did the following:

    1. Deleted the email accounts access to contacts and calender (email part was untouched, Sync interval: 24hrs)
    2. Removed accounts of Twitter, Linkedin, etc
    3. Facebook: Disabled Find Friends, Sync Events. (Notifications and Messages enabled)
    4. Went to Android Settings (via a launcher[Go launcher Ex Pro to be specific]) and enabled airplane mode. (Sometimes android wifi remains on.. turn it off manually, also it wont turn off your BB wifi.. but when you turn on BB wifi.. androids wifi gets enabled too.. so make sure you keep on disabling it for controlling PIM)
    (NOTE: Certain android apps need android wifi to be ON to work properly)

    The moment I did this...PIM which was currently at peak in CPU usage went IDLE..processor stopped heating up and baterry drainge came to halt immediately..!! So idk what worked for me among the 4 things mentioned above, but finally i can use Data Services without any worries..!!
    As far as the data usage is concerned when PIM is active..i found it for hours it would just download or upload in few Mbs (5-9Mb in my case) whereas i am having 10Mbps wifi and 7Mbps 3G. Also if i put the phone in airplane mode it use to pause and would resume again when data services are turned back on. I found this thing strange coz while downloading any app from BW it would finish downloading in seconds.. but PIM takes hours to do so...so i came to conclusion that maybe PIM gets HUNG UP somewhere while Synchronization and doesn't stops till auto-shutdown... If you restart manually it resumes syncing from the hung up point itself. this justifies everything for me..!!

    Your views, suggestions and experiences are welcomed.. Thank You..!!
    Last edited by Akshay Borkar; 03-14-14 at 07:23 AM.
    cuek80 and koolaje like this.
    03-11-14 01:04 PM
  2. anon721037's Avatar
    After reading forums for almost months.. i never ever faced PIM problems... and considered myself lucky...!!
    But after my STL 100-1 on Vodafone IN auto-updated to the latest 10.2.1.2102 software release last week, this PIM beast struck me too..!!
    I searched crackberry forums to find any solution but unfortunately couldn't find one..!!
    So i decided to do some trail and error experiments..!! I failed for numerous times..I learnt that PIM wont stop till it drains the battery to 0% and the phone switches off on its own (NOTE: manual restart wont work, but if the phone shuts down automatically due to PIM battery drainage then it stops.. it wont start back again immediately when you switch on)
    And finally after so many failures.. when i saw the CPU usage of PIM over 50% at that moment... I went to accounts...and did the following:

    1. Deleted the email accounts access to contacts and calender (email part was untouched, Sync interval: 24hrs)
    2. Removed accounts of Twitter, Linkedin, etc
    3. Facebook: Disabled Find Friends, Sync Events. (Notifications and Messages enabled)
    4. Went to Android Settings (via a launcher[Go launcher Ex Pro to be specific]) and enabled airplane mode.

    The moment I did this...PIM which was currently at peak in CPU usage went IDLE..processor stopped heating up and baterry drainge came to halt immediately..!! So idk what worked for me among the 4 things mentioned above, but finally i can use Data Services without any worries..!!
    As far is the data usage is concerned when PIM is active..i found it for hours it would just download or upload in few Mbs (5-9Mb in my case) whereas i am having 10Mbps wifi and 7Mbps 3G. Also if i put the phone in airplane mode it use to pause and would resume again when data services are turned back on. I found this thing strange coz while downloading any app from BW it would finish downloading in seconds.. but PIM takes hours to do so...so i came to conclusion that maybe PIM gets HUNG UP somewhere while Synchronization and doesn't stops till auto-shutdown... If you restart manually it resumes syncing from the hung up point itself. this justifies everything for me..!!

    Your views, suggestions and experiences are welcomed.. Thank You..!!
    Hey good catch, and thanks for letting us know i'm sure a few people will try this out,
    Akshay Borkar likes this.
    03-11-14 01:26 PM
  3. Akshay Borkar's Avatar
    Hey good catch, and thanks for letting us know i'm sure a few people will try this out,
    Let me know if it worked for you..!!
    03-11-14 01:44 PM
  4. DickGoudriaan's Avatar
    I am not sure what is the goal

    No Pim service is for me dumb phone

    But you are right. It us a strange thing.

    Any idea to fix this?

    Posted via CB10
    Akshay Borkar likes this.
    03-13-14 02:10 AM
  5. Akshay Borkar's Avatar
    I am not sure what is the goal

    No Pim service is for me dumb phone

    But you are right. It us a strange thing.

    Any idea to fix this?

    Posted via CB10
    I am not saying to turn off PIM entirely... without PIM any phone is a dumbphone..!! I just removed whatever i didn't need..!!
    whenever PIM is heating up the processor and sucking up on power... its not working.. instead it has HANGED itself.. its stuck somewhere in the syncing process...so we need to cancel it...!!! That's why Possible fix: TURN OFF ANDROID WIFI..!! it works for me...!!
    03-13-14 09:29 AM
  6. Omnitech's Avatar
    After reading forums for almost months.. i never ever faced PIM problems... and considered myself lucky...!!
    But after my STL 100-1 on Vodafone IN auto-updated to the latest 10.2.1.2102 software release last week, this PIM beast struck me too..!!
    I searched crackberry forums to find any solution but unfortunately couldn't find one..!!
    So i decided to do some trail and error experiments..!! [...]


    I think the Android angle is probably the most likely culprit, followed by various sorts of internet syncing activity.

    On my devices I have NFC disabled, "find additional info" or whatever that is called in contacts disabled, and I do NOT sync ANY contacts with ANY internet service.

    There are some architectural issues with the contacts system on BB10 that I wouldn't be surprised if they would cause the device to sometimes deadlock trying to sync or reconcile linked contacts between multiple sources.

    You've done a better job than most at looking at this scientifically, I commend you for that. Most people just start making wild sweeping proclamations without looking at the symptoms logically.

    .
    Akshay Borkar and JAS0NB0URNE like this.
    03-14-14 12:35 AM
  7. Akshay Borkar's Avatar
    I think the Android angle is probably the most likely culprit, followed by various sorts of internet syncing activity.

    On my devices I have NFC disabled, "find additional info" or whatever that is called in contacts disabled, and I do NOT sync ANY contacts with ANY internet service.

    There are some architectural issues with the contacts system on BB10 that I wouldn't be surprised if they would cause the device to sometimes deadlock trying to sync or reconcile linked contacts between multiple sources.

    You've done a better job than most at looking at this scientifically, I commend you for that. Most people just start making wild sweeping proclamations without looking at the symptoms logically.

    .
    thank you very much... and yes android part is the major culprit... but its kinda annoying to turn off android wifi every now and then... and if you are sleeping and this PIM beast attacks your phone...boom you have dead phone in the morning...also about the contact book part.. yes its filled with bugs since the launch (10.0) although its improving with each OS release.. but the progress is very slow (wrt contact book only) anyways i hope they fix this issue asap..!! *waiting*
    03-14-14 07:18 AM
  8. Fret Madden's Avatar
    A couple days ago I noticed my Z10 getting warm, caught an Android calendar component running via Taskmanager - com.calendar.something-or-other. Killing that evened things out; I no longer have an Android launcher installed to check out your WiFi suggestion though. I suspected the launcher (KitKat) or ES file manager contained the calendar component so I deleted them, I haven't had it show up again so I believe them to be the problem.
    03-14-14 07:44 AM
  9. Akshay Borkar's Avatar
    A couple days ago I noticed my Z10 getting warm, caught an Android calendar component running via Taskmanager - com.calendar.something-or-other. Killing that evened things out; I no longer have an Android launcher installed to check out your WiFi suggestion though. I suspected the launcher (KitKat) or ES file manager contained the calendar component so I deleted them, I haven't had it show up again so I believe them to be the problem.
    actually the calendar built on BB10 is somehow related to android... coz when you open any android launcher...you only see icons of ported apps and NOT NATIVE apps.. but every time this calendar app of bb10 shows up in launcher.. that's a bit strange.. m sure it has some connection with qnx android player we have on bb10... also talking about the taskmanager thing... its also a ported app.. so it shows processess running wrt qnx player..and not whole bb10... but i am glad it helped you to solve your problem... i shall give it a try too... and thanks for sharing.. m sure other readers might find it helpful too.. thanks..
    03-14-14 07:57 AM
  10. Pat Andres's Avatar
    I had this problem before, I start experimenting, deleting Facebook and email accounts thinking it would solve the problem, but then I came across to a much better way that works for me. I just turned on the BlackBerry protect, diagnostic and enrypt my z10, after that my device doesn't heat anymore. I have a white z10 and my wife has black. I hope this works for you guys too. If pim services and system still run cpu at 20% after doing this, just wait few minutes and it will settle and never bother you again, just don't turn off data until pim service or system settles. I have all my accounts sync on my phone right now and almost using data all day long. Having almost 10 hrs with data on... thanks.

    Posted via CB10
    Chris Tau and cuek80 like this.
    03-14-14 07:59 AM
  11. Akshay Borkar's Avatar
    I had this problem before, I start experimenting, deleting Facebook and email accounts thinking it would solve the problem, but then I came across to a much better way that works for me. I just turned on the BlackBerry protect, diagnostic and enrypt my z10, after that my device doesn't heat anymore. I have a white z10 and my wife has black. I hope this works for you guys too. If pim services and system still run cpu at 20% after doing this, just wait few minutes and it will settle and never bother you again, just don't turn off data until pim service or system settles. I have all my accounts sync on my phone right now and almost using data all day long. Having almost 10 hrs with data on... thanks.

    Posted via CB10
    well i have my BBprotect turned on... buts its not helping me...in your case..i guess its ENCRYPTION which is saving you...!! Thanks for sharing... shall try this too...!!
    03-14-14 08:02 AM
  12. Pat Andres's Avatar
    Hope could help others who had been troubled finding a way to tame that beast... cheers

    Posted via CB10
    Akshay Borkar likes this.
    03-14-14 08:04 AM
  13. Akshay Borkar's Avatar
    Hope could help others who had been troubled finding a way to tame that beast... cheers

    Posted via CB10
    just post your experiences wherever possible.. those who are in need,, search for it and eventually find it..!! cheers..!!
    stevovr likes this.
    03-14-14 03:01 PM
  14. DickGoudriaan's Avatar
    I tried a lot of things like others for example remove fb some account.

    I suspect a sync circle.

    Any others thinking preferentie knowing the same.

    Posted via CB10
    03-14-14 04:01 PM
  15. Q10Bold's Avatar
    Gonna try

    Posted via BlackBerry Q10Bold
    03-14-14 04:09 PM
  16. DickGoudriaan's Avatar
    I did encrypte the z10. To be sure the encrypting setting is at the menu Security and they protecting yourself data,?



    Posted via CB10
    03-14-14 04:24 PM
  17. DickGoudriaan's Avatar
    I cannot believe this. Encrypting lowers cpu speed.

    ...........




    Posted via CB10
    03-14-14 05:18 PM
  18. Pat Andres's Avatar
    It's good to hear that it helps, if my understanding is right haha. Cheers

    Posted via CB10
    03-14-14 08:36 PM
  19. DeltaEngineering's Avatar
    useless, did this too, will be back in about 1-2 weeks
    03-15-14 02:53 AM
  20. DickGoudriaan's Avatar
    Hi delta. Ok, my Pim service batterij dropes from 45 to 28 now. But it is saterday

    Posted via CB10
    03-15-14 05:54 AM
  21. Omnitech's Avatar
    I suspected the launcher (KitKat) or ES file manager contained the calendar component so I deleted them, I haven't had it show up again so I believe them to be the problem.
    I deleted ES File Manager after a couple of weeks. Its habit of popping up whenever I did a download or app install, combined with being a totally free app with no ads from a company in China with a bunch of employees and no apparent business model or revenue source just finally overstepped my "creepy" threshold.
    Fret Madden likes this.
    03-15-14 03:01 PM
  22. Fret Madden's Avatar
    I deleted ES File Manager after a couple of weeks. Its habit of popping up whenever I did a download or app install, combined with being a totally free app with no ads from a company in China with a bunch of employees and no apparent business model or revenue source just finally overstepped my "creepy" threshold.
    Normally I look into such things when pondering apps, but it came recommended from a friend who usually knows what he installs. Tomorrow I'll tell him in person so I can watch the blood drain from his face.

    Posted via CB10
    03-16-14 02:43 AM
  23. Omnitech's Avatar
    Normally I look into such things when pondering apps, but it came recommended from a friend who usually knows what he installs. Tomorrow I'll tell him in person so I can watch the blood drain from his face.

    Well it's undoubtedly a somewhat handy app, and very popular by all accounts, but in addition to what I mentioned previously I was also a little miffed by the fact that some of the core functionality required an add-on or plugin ("app manager" or something) that came directly from their own website. Well of course that would bypass Google's Play Store scrutiny.

    Color me paranoid.
    southlander likes this.
    03-16-14 02:56 AM
  24. Fret Madden's Avatar
    Well it's undoubtedly a somewhat handy app, and very popular by all accounts, but in addition to what I mentioned previously I was also a little miffed by the fact that some of the core functionality required an add-on or plugin ("app manager" or something) that came directly from their own website. Well of course that would bypass Google's Play Store scrutiny.

    Color me paranoid.
    Little paranoia never hurts - I got it a few weeks ago, after the aforementioned friend and I were comparing file mangers and I recalled ES from that file manager slugfest thread back around Xmas/New Year's. I never really used it, in that I tried it out, then left it installed thinking it could serve as an "example app" for showcasing Android apps. I didn't run into missing plug-ins when using it, but I also had the pop-up happen when installing other apps. I did note that it works over BlackBerry Link (as does Ghost Commander), so I feel a little unclean for having used it to access my desktop.
    03-16-14 03:19 AM
  25. Omnitech's Avatar
    Little paranoia never hurts...
    BTW and apropos to nothing in particular.. love the avatar. FAR too often an accurate depiction of my life...

    Though luckily for me, I'm not a 9-5 cubicle dweller, but still..
    Fret Madden likes this.
    03-16-14 03:59 AM
77 123 ...

Similar Threads

  1. Battery calibration problem
    By itzk3n in forum BlackBerry Z10
    Replies: 8
    Last Post: 04-26-16, 11:00 AM
  2. OVER 30 HOURS battery life with Z10
    By TheFlowFX in forum BlackBerry Z10
    Replies: 18
    Last Post: 04-26-16, 02:41 AM
  3. 2680 mAh "Gold" Battery - Legit?
    By Jman056 in forum BlackBerry Z10
    Replies: 3
    Last Post: 05-16-14, 09:14 AM
  4. Replies: 22
    Last Post: 04-30-14, 01:30 AM
  5. Battery life significantly less on 10.2.1
    By thedocdre in forum BlackBerry 10 OS
    Replies: 9
    Last Post: 04-24-14, 10:46 AM
LINK TO POST COPIED TO CLIPBOARD