1. bobo616's Avatar
    Hi,
    There are options to allow you press the power button and it should take you to the unlock screen but this doesn't seem to be working, is it a bug with my os version 10.2.2102? I have tried this on my z10 and on a q5 and I thought it previously worked. The screen shots of the settings I have are below.
    Power button to unlock not working-img_20140311_075208.png
    Power button to unlock not working-img_20140311_075221.png

    Maybe it only works without a device password, which for some reason I am unable to turn off as it is greyed out.



    Posted via CB10
    03-11-14 03:57 AM
  2. cuek80's Avatar
    Hi. What happen when you press the power button?

    edit:
    With the above setting, with the screen off, When you press power button, the device should unlock ur phone (No need to swipe), and show u the home screen (or last app u open when locking the phone).

    The "allow power/lock key to unlock device" setting only allowing u to unlock the phone without swipe gesture.

    Posted via CB10
    03-11-14 04:03 AM
  3. jafrul's Avatar
    Does it lock if you press it while using the phone?

    Posted via CB10
    03-11-14 04:04 AM
  4. cuek80's Avatar
    Does it lock if you press it while using the phone?

    Posted via CB10
    Pressing power/lock button when the screen is on will always lock the phone, regardless the settings.
    If not, then it's hardware issue, I think.

    Posted via CB10
    03-11-14 04:10 AM
  5. bobo616's Avatar
    Hi,
    If you press the power button it doesn't lock the screen but just turns off the screen, it only locks after the lock timeout which I have set to 2 minutes, this is how it works on bb10 unfortunately.

    If the phone is locked with the screen off and I press the power button it takes me to the lockscreen which I then have to swipe up to bring the password screen up or if the screen is off but the lock timeout hasn't passed yet it shows the lockscreen that I swipe up and that takes me back to where I was previously before the screen went off.

    I am also puzzled why I can't turn off my device lock?

    Posted via CB10
    cuek80 likes this.
    03-11-14 04:22 AM
  6. jafrul's Avatar
    Seems like OS issue.

    And regarding locking the phone to override the (-)minutes set to lock, you can always press the top button for 3 seconds and select lock manually.
    03-11-14 04:25 AM
  7. cuek80's Avatar
    I think both are "lock", the difference is password-locked or not. But yes, BB should put "immediately" as a choice on "lock device after" setting.
    With the setting for "power button to unlock" is off, When we press power button it will show us what we called the lock screen, regardless password protected or not.

    Posted via CB10
    03-11-14 05:35 AM
  8. bobo616's Avatar
    I have found the reason I can't disable my device lock is that I have encryption enabled. I don't want to disable this to check the lockscreen issue though as I think it is an OS problem but wondered if you don't have a password set if you press the power button it will unlock the screen for you? Any volunteers to try?

    Posted via CB10
    cuek80 likes this.
    03-11-14 05:43 AM
  9. polgara59's Avatar
    Mine started not working after the last OS update. No idea why (this is first thread on the issue I've found). Weird.
    07-15-14 12:57 PM
  10. jeanphilt's Avatar
    A few keys on my keyboard never worked (letter A for example) ...
    I was under the impression that the Power button was just poorly implemented (software) but I now realize it's simply another hardware defect ...
    03-30-15 06:25 PM
  11. volentine's Avatar
    Follow this:
    1. System Setting / Security and privacy / Lock Screen / TURN ON Allow power/Lock Key to Unlock Device.
    2. Go to System setting / Display / turn OFF Swipe to Wake
    im sure it can work. Hv a nice day
    08-20-15 06:27 AM
  12. volentine's Avatar
    u need to turn OFF Swipe to Wake on display setting..
    08-20-15 06:30 AM
  13. ZeroBarrier's Avatar
    Incredible how many people are posting without reading all the details.

    You have encryption on, this requires that you have a device password, this is mandatory. Because you have a device password in place, then you obviously can't unlock the phone by just pressing the power button; this would defeat the whole purpose of a device password.

    Posted via CB10
    08-20-15 09:01 PM

Similar Threads

  1. For UK BlackBerry 10 users why not check out the Met Office Android app?
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 2
    Last Post: 06-02-15, 02:33 AM
  2. Z10 Battery life, faults, tips to extend batter life
    By judah_is_SiPS in forum Africa
    Replies: 9
    Last Post: 04-03-14, 12:38 PM
  3. Replies: 4
    Last Post: 03-15-14, 09:52 AM
  4. Problem with jumping to page on Z30
    By uktivo in forum CrackBerry Apps
    Replies: 4
    Last Post: 03-11-14, 01:30 PM
  5. Replies: 1
    Last Post: 03-11-14, 03:07 AM
LINK TO POST COPIED TO CLIPBOARD