1. hannes89's Avatar
    For a few months my proximity and light sensors were not working at all.
    Last week I loaded Z10STL100-2/10.3.2.2639 and everything was perfect.

    Today now the problems are back. It seems that it's a software problem and nothing related on hardware.

    It's totally annoying to press the power button everytime a call is connected to avoid to drop it!!!

    Please repair this.

    Anyone else with this kind of problems?

    Regards Johnny

    Posted via CB10
    09-12-15 12:00 PM
  2. Al moon's Avatar
    i have the same thing when on a call screen doesnt go dark and your talking and pressing numbers and muting the phone without even knowing
    09-12-15 12:31 PM
  3. woofhaven's Avatar
    I find I have this problem when I call someone and I put the phone to my ear before their line starts to ring. If I wait until the ring starts and then put the phone to my ear, the proximity sensor seems to work as expected.

    Posted via CB10
    09-12-15 02:16 PM
  4. dkon1000's Avatar
    Agreed. There is some kind of initial delay. If you pull phone away from head after call starts and then back the screen darkens.

    Posted via CB10
    09-12-15 02:22 PM
  5. Al moon's Avatar
    Seems to be just right right now for BlackBerry fix one thing break another

    Posted via CB10
    andy957 likes this.
    09-12-15 02:32 PM
  6. Stomps01's Avatar
    Ahhh so I see I'm not the only one with this issue......

    Posted via CB10
    09-13-15 09:37 AM
  7. AquaL3o's Avatar
    I had this issue because of Reinforced glass covering my sensor.... maybe that is the issue with some of you... never harms to check.

    I never had this problem myself other than because of glass.

    Z10 STL001
    09-13-15 09:40 AM
  8. hannes89's Avatar
    No protection on the screen. And as written above it works after the installation of 10.3.2.2639 (via Blitz-update)

    Few days after that it's bricked again.

    Posted via CB10
    09-13-15 12:46 PM
  9. Jeroen Vos's Avatar
    Count me in on this one as well. Even replaced the sensor with another that I had left over form a dinged screen. Same result. There seems to be a calibration issue. I can see the sensor in BBVE. It gives "PASS" on FAR. But "WAITING" on NEAR. If I put a bright light directly on the sensor and move that away NEAR goes to "PASS" but not if I wave my hand across it like you normally would.
    09-15-15 02:43 PM
  10. hannes89's Avatar
    In BBVE it gives only "not available" for both proximity and light sensors.
    Let's hope this server/calibration issue whatever it is gets fixed.

    Posted via CB10
    09-17-15 12:47 PM
  11. nappalonia's Avatar
    Same issues here...I've been hung up on a few times because I've muted the phone with my face.
    09-17-15 01:50 PM
  12. mad_mdx's Avatar
    Can anyone with a passport do this test for me on bbve
    Proximity sensor with the phone face up on a table
    Don't cover the sensor
    Does it say far or near?
    09-17-15 04:00 PM
  13. woofhaven's Avatar
    Can anyone with a passport do this test for me on bbve
    Proximity sensor with the phone face up on a table
    Don't cover the sensor
    Does it say far or near?
    Here ya go..


    Please get Proximity sensor working again-img_20150917_172906.png

    Posted via CB10
    09-17-15 05:30 PM
  14. mad_mdx's Avatar
    Here ya go..


    Click image for larger version. 

Name:	IMG_20150917_172906.png 
Views:	696 
Size:	85.2 KB 
ID:	371855

    Posted via CB10
    Thanks! Looks like my proximity sensor was acting weird but it's acting ok now.. damn you BlackBerry and your sensors!!!
    09-17-15 09:40 PM
  15. Stomps01's Avatar
    Thanks! Looks like my proximity sensor was acting weird but it's acting ok now.. damn you BlackBerry and your sensors!!!
    Lol your final comment made me laugh.... sorry I am laughing at your expense...... haha

    Posted via CB10
    09-17-15 09:44 PM
  16. Al moon's Avatar
    Its a bug if you wait for the other person to answer then hold it up it turns the screen off fix one thing and break another

    Posted via the CrackBerry App for Android
    09-19-15 05:14 PM
  17. ctclothbagco's Avatar
    I've been having problems with all the sensors on my Passport. Turning off all the Advanced Interactions seems to have fixed the issue for now

    Posted via CB10 on BlackBerry Passport Silver Edition
    09-23-15 07:33 AM
  18. qalsXJ's Avatar
    I have a same issue also on my pp sensors, both proximity and light sensors is not working, before upgrade its only need to restart and its back to normal, but after the upgrade the sensor is become UNAVAILABLE on BBVE, I already sent a warranty claim to the distributor, but if it is a software issue then it will be nothing to do until it get back again with the same issue on the replacement PP, is it any official announcements from the RIM yet about this?
    10-04-15 10:16 PM
  19. panosdim82's Avatar
    Just this morning, I accepted a call and I noticed that the sensor problem was fixed after almost two months. Using the app total commander, I noticed that the /dev/sensor folder contains prox and light files and next to them the date is 28 October.
    For what it's worth, that day I updated to the newer version of BBM.
    Now I'm totally convinced that the problem is s/w related.
    Please BlackBerry don't screw this up again.

    EDIT: 2 days later, sensors are broken again. Not happy.

    Posted via CB10
    Last edited by panosdim82; 10-31-15 at 09:38 AM.
    10-29-15 09:37 AM
  20. conbrio29's Avatar
    Alright I'll add my story here too. Passport on 2474 and BBVE says my light sensor is working fine but the proximity sensor gets a pass on near but nothing for far. Why would the light sensor tests all pass but the proximity sensor test fail? I thought that they were the same sensor all along?

    Posted via CB10
    12-15-15 01:28 PM
  21. Jeroen Vos's Avatar
    Allright, I had the same problem before. But I got it sorted out. I had a Z10 with a brand new screen replacement that gave the problem. Turns out there is a tiny rubber inlay that seperates the light and proximity sensor from each other. That was missing out on my new screen assembly (which comes with the sensors included). I borrowed it from my shattered old screen and the problem is fixed. It now passes both test without any problem.

    Posted via CB10
    12-15-15 02:09 PM
  22. de2's Avatar
    I've had problems with the proximitysensor and these were caused by the small magnets in a hardcase.

    If you black out the screen with the topbutton, does it stay black on a call?
    My Z10 screen switched on anyway after i blacked it out with the topbutton.
    12-16-15 11:34 AM

Similar Threads

  1. Hold To Stay Awake -- How Does It Work?
    By woofhaven in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 11-07-15, 01:36 PM
  2. Audio is not working on video record but everywhere else is OK?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 09-18-15, 10:00 AM
  3. Stop syncing work emails on weekends?
    By jaus101 in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 09-13-15, 04:40 AM
  4. How do you get Blackberry to actually talk or respond to you?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 09-12-15, 10:06 AM
  5. BlackBerry Z3 gets hot
    By Bibhash Saha in forum Ask a Question
    Replies: 1
    Last Post: 09-12-15, 08:17 AM
LINK TO POST COPIED TO CLIPBOARD