11-12-18 09:29 AM
26 12
tools
  1. goncal's Avatar
    Hi everyone,

    My Passport is on OS 10.3.3.3216 (which self updated in September from 10.3.3.3057 I had installed from scratch with an autoloader in August).

    Mobile is consistenty working well, no battery drain, all native and Android apps behaving, etc.

    I have just started having problems with BB Link for the first time ever, after having been using it with my Passport and Z30 for 4 years.

    I backed up and restored on 10.3.3.3216 on BB Link mid October with no problems. But now my Passport will not back up (No Data to Backup) or restore (stuck on Loading Content) whereas the other two Passports and Z30 I manage (on 10.3.3.3216 too) are still working well on Link and the same computers.

    DBBT and Sachesi also fail to back up or restore to / from .bbb files.

    I have just found out I cannot install BlackBerry Calculator from BB World with the error 'Download failed: Error installing Application' and thought this might just be the root problem. (I can install and uninstall every single other native and Android app I have tried since.)

    I decided to download the Passport Full Blitz for 3126, extract the calculator .bar file, and try sideloading it using the Chrome extension. It won't install, and this is the error message I get every time:

    Install sys.calculator-10.3.3.239.bar: failure 500 OSError: /apps/.old.sys.calculator.gYABgJidBvuZ89m_1j4PV2712.A/native/assets/vGTsvgzgEOlSTrK7Aye5EIKzRno.cnt: [Errno 2] No such file or directory: '/apps/.old.sys.calculator.gYABgJidBvuZ89m_1j4PV2712.A/native/assets/vGTsvgzgEOlSTrK7Aye5EIKzRno.cnt'

    I then tried installing a slightly different version of the .bar file (one I downloaded using Sachesi) and got exactly the same error:

    Install calculator-10.3.3.184-nto+armle-v7+signed.bar: failure 500 OSError: /apps/.old.sys.calculator.gYABgJidBvuZ89m_1j4PV2712.A/native/assets/vGTsvgzgEOlSTrK7Aye5EIKzRno.cnt: [Errno 2] No such file or directory: '/apps/.old.sys.calculator.gYABgJidBvuZ89m_1j4PV2712.A/native/assets/vGTsvgzgEOlSTrK7Aye5EIKzRno.cnt'

    It looks as if there is a stuck /apps/.old.sys.calculator......... app folder and / or its assets (app data?) that the system is looking for / cannot get rid of. Of course I cannot access the /apps folder to try and have a look myself.

    Any help at all would be ever so appreciated... I cannot afford to wipe my device as apps have lots of information I need to keep, in particular BBM (I did find a way to back up and restore all of my chats since day one which I can share if anyone is interested!).

    Thanks so much for going through all this!

    Goncal
    Last edited by goncal; 11-07-18 at 06:46 AM. Reason: trying to improve readability; more accuracy
    11-07-18 06:21 AM
  2. goncal's Avatar
    I've been thinking of blitzing the Passport with 10.3.3.3057 to see if that solves the whole BB Calculator / BB Link issues... I would love some expert advice as to whether this would mean losing my data / nasty issues due to downgrading? Thanks again!
    11-07-18 12:57 PM
  3. brookie229's Avatar
    I have just found out I cannot install BlackBerry Calculator from BB World with the error 'Download failed: Error installing Application' and thought this might just be the root problem. (I can install and uninstall every single other native and Android app I have tried since.)
    Never heard of a problem like this but it seems as if somehow the OS has been corrupted. Are you saying that the native calculator has NEVER worked since your OTA update? You may have to suck it up and reload your device with an autoloader. The other option, I guess, is to just find a 3rd party calculator and leave everything alone but that is not a very elegant solution, I will admit.
    11-07-18 02:14 PM
  4. goncal's Avatar
    It did work a few days ago then all of a sudden it would not open. I uninstalled it, which I had to do a few times, then on reinstall I faced this problem.

    I am not worried about the Calc app at all, rather by the inability to back up and restore using link, and thought by solving the calculator app problem I might solve the BlackBerry link problem as it is just too likely they are related.

    I backed up with Link on 13 October flawlessly.

    Strange indeed.
    11-07-18 02:40 PM
  5. brookie229's Avatar
    Strange indeed.
    My opinion is that you will only get this problem fixed by a total reinstall of the OS which, I know, you are not wanting to do. Somehow the OS has been corrupted by that app. Because it is a default app, I guess it cannot be removed using Sachesi.
    11-07-18 02:46 PM
  6. goncal's Avatar
    My opinion is that you will only get this problem fixed by a total reinstall of the OS which, I know, you are not wanting to do. Somehow the OS has been corrupted by that app. Because it is a default app, I guess it cannot be removed using Sachesi.
    Strangely enough this is an app that can be uninstalled by the user and downloaded and installed from bbw. However it can indeed be found in the 10.3.3.3126 Blitz set.
    11-07-18 02:51 PM
  7. goncal's Avatar
    Strangely enough this is an app that can be uninstalled by the user and downloaded and installed from bbw. However it can indeed be found in the 10.3.3.3126 Blitz set.
    Uninstalled by the user, as in, using bbw or delete app from Device Monitor / App Manager.
    11-07-18 02:52 PM
  8. ppeters914's Avatar
    I've never used the Chrome extension. I thought it unnecessary once Sachesi and DBBT became available.

    I agree that it sounds like your OS is corrupted, and your best option is a clean install using an autoloader.

    I would first try reinstalling 3216 with a Blitz file using Sachesi or DBBT. If that doesn't allow you to do a backup, try with an earlier Blitz.

    Good luck, and let us know how it goes.
    11-07-18 04:03 PM
  9. goncal's Avatar
    I've never used the Chrome extension. I thought it unnecessary once Sachesi and DBBT became available.

    I agree that it sounds like your OS is corrupted, and your best option is a clean install using an autoloader.

    I would first try reinstalling 3216 with a Blitz file using Sachesi or DBBT. If that doesn't allow you to do a backup, try with an earlier Blitz.

    Good luck, and let us know how it goes.
    That sounds like a good plan thank you. Would you say I can trust the device not to lose any data during reinstallation of 3216 or should I be wary?
    11-07-18 04:22 PM
  10. ppeters914's Avatar
    Forget whether I used Sachesi or DBBT, and whether it was 10.3.3.x or 10.3.3.x Blitzes, but I did it once without losing any data.
    11-07-18 05:06 PM
  11. goncal's Avatar
    Forget whether I used Sachesi or DBBT, and whether it was 10.3.3.x or 10.3.3.x Blitzes, but I did it once without losing any data.
    That really helps thank you.
    11-07-18 05:08 PM
  12. goncal's Avatar
    That really helps thank you.
    Tried that and unfortunately I am getting exactly the same error, whether installing OS Core, Debrick, or just Adding the folder with all .bar files in it...
    11-08-18 07:12 AM
  13. ppeters914's Avatar
    Tried that and unfortunately I am getting exactly the same error, whether installing OS Core, Debrick, or just Adding the folder with all .bar files in it...
    Appears that your OS is totally hosed. Only option is clean install of OS using an autoloader.
    11-08-18 06:05 PM
  14. goncal's Avatar
    Appears that your OS is totally hosed. Only option is clean install of OS using an autoloader.
    Too true. Shall autoload 3216 again next week and restore my 13 Oct backup.

    Thanks for your suggestions everyone. So frustrating that my problem could probably be fixed with the right tools. Or maybe not?

    I have played around a fair bit with rooted Android devices but would rather have this sort of problem on a Passport than have to make do with an Android device. Which I may have to move on to in 2020 anyway.
    11-09-18 03:33 AM
  15. goncal's Avatar
    And now I have a question.

    This is the very first time ever that a bb10 OS installation becomes corrupted for me. In four years. This includes two more Passports and Z30 I manage, and innumerable backups, restores and system updates.

    WHY would a bb10 OS installation corrupt in such a way?

    Is there a Windoze like registry file on QNX systems? (there shouldn't be since this is a Unix like system?)
    11-09-18 08:04 AM
  16. EFats's Avatar
    You are using a 'hack' to mess around with the OS in a way which it was never meant to be done, mixing and matching pieces without full documentation. You don't think that one day it might get messed up??
    11-09-18 10:32 AM
  17. goncal's Avatar
    You are using a 'hack' to mess around with the OS in a way which it was never meant to be done, mixing and matching pieces without full documentation. You don't think that one day it might get messed up??
    Not really :-) our devices cannot be rooted anyway so what we can do with and to them is after all legal. QNX is an amazing and robust OS. Plus I have installed and uninstalled hundreds of apps hundreds of times on my Passport and others and never had a single problem.

    QNX is Unix like and on Unix-like systems whenever you install apps not meant for the system you need to install additional libraries which can conflict with existing / needed ones. On BB10 if you try to install an app which needs different libraries from those supplied with the system it will just fail to install and there is nothing you can do about it therefore no messing about. Just my five cents of course, and that remembering the times I have actually messed around with Solaris / Linux / Android systems :-)

    I suspect the last OTA update (3057 to 3216) might be the culprit. It happened inadvertently and I might have been using the device at the time it was downloading it and maybe something happened. Just saying because quite a few people have reported problems with OTA updates. I for one always try to do it manually.
    Last edited by goncal; 11-09-18 at 11:14 AM.
    11-09-18 10:52 AM
  18. TrumpetTiger's Avatar
    And now I have a question.

    This is the very first time ever that a bb10 OS installation becomes corrupted for me. In four years. This includes two more Passports and Z30 I manage, and innumerable backups, restores and system updates.

    WHY would a bb10 OS installation corrupt in such a way?

    Is there a Windoze like registry file on QNX systems? (there shouldn't be since this is a Unix like system?)
    This sounds like some form of application compatibility issue goncal. I would speculate that during your update to .3216 something got interrupted that caused the full update not to apply, making part of your device have .3216 files and part have earlier files. Since the Calculator app is looking for a particular OS threshold and it's getting conflicting data, it refused to install. That would also explain the issues you had sideloading, and possibly even the backup problems with BB Link.

    Long story short: as you yourself have noted, this is so rare with BB10 it's not worth worrying about. Autoload, restore your backup, and keep on trucking as long as you can with your fellow BB10 diehards.
    11-09-18 03:56 PM
  19. goncal's Avatar
    Totally agree TrumpetTiger. Such a shame that seeing the error log itself (a conflicting file or folder that was supposed to be there and is not, or that is being looked for but should not, or...) there is nothing I can do to fix it. I have already planned to do just that - autoload the current OS and restore the 13 Oct backup. Shame I will lose bbm history from 13 Oct on, which is the main reason why I was reluctant to autoload. Thanks for your views and input.
    11-09-18 04:04 PM
  20. goncal's Avatar
    Just remembered only recently I kept using my Passport when battery was showing 0pc, it was an emergency (hospital for a close friend's husband who very sadly did not make it) and the phone did stutter while I was using it. I even switched off battery saving mode. Maybe ugly things happened there and then.
    11-09-18 04:23 PM
  21. ppeters914's Avatar
    Long story short: as you yourself have noted, this is so rare with BB10 it's not worth worrying about. Autoload, restore your backup, and keep on trucking as long as you can with your fellow BB10 diehards.
    Agreed. Bought my Z10 off craigslist in 2014. Autoloaded 10.2.1 (maybe 10.3.0, too), then nothing but Blitzing after that.

    Sometime in late 2017, various oddities started occurring. That's when I Blitzed back a version, rebooted, then Blitzed up to 3216 again. No change.

    Once I get everything transferred to computer and / or new LG G7, I'll do a clean install with 3216.

    Posted via CB10 / AT&T /Z10 STL100-3 /10.3.3.3216
    11-09-18 05:54 PM
  22. goncal's Avatar
    I autoloaded 10.3.3.3216 back on the Passport last night and I found it odd it would take a long time to flash the device. Turns out the cable I have been using for some time is faulty as I tried a new cable and it autoloaded quickly. A few weeks ago I autoloaded 3216 on my Z30 with the same cable and Z30 would not detect a sim card. After flashing Z30 using the new cable it will detect the simcard. Hopefully the faulty cable has been the culprit all along.
    11-12-18 05:35 AM
  23. brookie229's Avatar
    I autoloaded 10.3.3.3216 back on the Passport last night and I found it odd it would take a long time to flash the device. Turns out the cable I have been using for some time is faulty as I tried a new cable and it autoloaded quickly. A few weeks ago I autoloaded 3216 on my Z30 with the same cable and Z30 would not detect a sim card. After flashing Z30 using the new cable it will detect the simcard. Hopefully the faulty cable has been the culprit all along.
    So the calculator problem is now fixed??

    Posted via CB10
    11-12-18 09:05 AM
  24. goncal's Avatar
    So the calculator problem is now fixed??

    Posted via CB10
    Yes, along with the big problem, not being able to backup or restore and that was a real worry. Calculator problem was just the tip of the iceberg.
    Last edited by goncal; 11-12-18 at 09:28 AM. Reason: typo
    ppeters914 likes this.
    11-12-18 09:13 AM
  25. brookie229's Avatar
    Yes, along with the big problemm, not being able to backup or restore and that was a real worry. Calculator problem was just the tip of the iceberg.
    It's amazing how sometimes just a cable can be the source of problems. I have seen usb cables being the problem when not being able to connect to Link. Anyway glad you have it sorted out.
    11-12-18 09:23 AM
26 12

Similar Threads

  1. Update Unlocked BlackBerry Priv on T-Mobile
    By Garavar in forum BlackBerry Priv
    Replies: 1
    Last Post: 11-07-18, 01:45 PM
  2. Is there an open source browser available for BlackBerry 10?
    By Marc Collin in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 11-07-18, 10:26 AM
  3. What android apps could be used on blackberry leap?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-07-18, 07:23 AM
  4. Back case for BlackBerry Motion?
    By khaled10 in forum BlackBerry Motion
    Replies: 2
    Last Post: 11-07-18, 01:09 AM
  5. Replies: 1
    Last Post: 11-06-18, 01:46 PM
LINK TO POST COPIED TO CLIPBOARD