1. bb10adopter111's Avatar
    I can see my SMS messages in the Hub, but not in the Text Messages View (from the Hub or Desktop shortcut -- unless I search for them!

    If I open the Text Messages view, I see the Grey "empty" message: "No entries in this view" even though I have hundreds of messages. But, if I search for messages in the view, by keyword (or even a space) for example, I can see all of them.

    This started when I switched to a new z10. I've been using the Z10 since the original launch, and never had this problem before.

    Any ideas?

    Posted via CB10
    Last edited by bb10adopter111; 03-19-15 at 11:55 AM. Reason: Clarifying terms (using "View" instead of "App"
    03-19-15 08:04 AM
  2. John Vieira's Avatar
    What app? You mean the hub?

    There is no app. It's just a shortcut to the hub.

    Posted via CB10
    03-19-15 08:39 AM
  3. bb10adopter111's Avatar
    Yes, then, the Hub. I can see the messages in the Hub along side all of my other messages, but not when I click on "Text Messages" for that item/view.

    However, within the Text Messages view, I can find them if I search. It's as if there were a setting to not display text messages in Text Messages view except as search results!

    Posted via CB10
    03-19-15 08:49 AM
  4. TrueKulcha's Avatar
    So the messages are all in the hub without a display problem? But when you open the actual "text" message app you are not able to access the messages without a search? I know some messages have the option within Hub Settings>Hub Management to select how you want them displayed. Check there to see if you don't have "display in hub only" checked off.

    Posted via CB10
    Also try performing a hard reset by holding down up/down volume keys for at least 10 seconds or until the phone powers off and reboots
    03-19-15 09:40 AM
  5. bb10adopter111's Avatar
    So the messages are all in the hub without a display problem? But when you open the actual "text" message app you are not able to access the messages without a search? I know some messages have the option within Hub Settings>Hub Management to select how you want them displayed. Check there to see if you don't have "display in hub only" checked off.

    Posted via CB10
    Also try performing a hard reset by holding down up/down volume keys for at least 10 seconds or until the phone powers off and reboots
    Thanks. You described the situation accurately. In the Hub Management settings for Text messages, there are three choices:

    Show in Hub only
    Show in Separate Account Only
    Show in Both

    The "Show in Hub Only" is grayed out and cannot be selected. I have tried both of the other settings, with Hub restarts in between, as well as multiple reboots and battery pulls to be sure. Nothing has worked yet.

    Posted via CB10
    03-19-15 09:56 AM
  6. ZEDTROSPEKTIV's Avatar
    Screen shots please, unless I'm a none believer I'm pretty sure many will agree on here. I've never had such issue ever, even on 10.0 which was and is the most glitchy software release from blackberry to date (random reboots). It's all good describing the problem but the thing is that us humans have a thing called an imagination and we are capable of making things up, separate yourself from them also supplying a screenshot alongside the description of the problem

    @ZEDTROSPEKTIV Via BlackBerry Passport, previous Z10, Bold 9790, Bold 9700, Curve 3G, Curve 8250 (1st BB)
    03-19-15 10:04 AM
  7. TrueKulcha's Avatar
    What happens if you select "text messages" from within the hub menu? Is it same result or do the messages show up then?

    Posted via CB10
    03-19-15 10:38 AM
  8. bb10adopter111's Avatar
    No, they don't. It's the same result if I select "Text Messages" from within the Hub Menu or from the "Text Messages" shortcut on the Desktop. However, if I select an individual text message from the Hub I can see it and the entire conversation.
    03-19-15 10:40 AM
  9. bb10adopter111's Avatar
    Sure, I can post screenshots, though they won't really show anything interesting, and I have to black out a lot of personal info. Will do it shortly.
    03-19-15 10:41 AM
  10. bb10adopter111's Avatar
    FWIW, here are screenshots:

    1. Screenshot of Text Message Settings:
    Official SMS App won't display messages-img_20150319_114639.png

    2. "Text Messages" view from Hub
    Official SMS App won't display messages-img_20150319_085458.png

    3. Beging Search with no messages visible
    Official SMS App won't display messages-img_20150319_113741.png

    4.Search with a single [space] reveals missing messages
    Official SMS App won't display messages-search-space-.png
    03-19-15 11:03 AM
  11. TrueKulcha's Avatar
    Do you have a recent backup on BlackBerry Link? If so go ahead and make a backup of current (give it a name that will make it unique like "no text" for example) then do a full restore of known working backup. After restoring check to see if text list opens without the search. If that works then it's some glitch in your System Applications and or Device settings.
    You can try doing a restore from the "no text" backup and see if it's good now and if not you may have to just either work with the (presumably working backup) or do a complete reset of OS.

    Posted via CB10
    bb10adopter111 likes this.
    03-19-15 11:45 AM
  12. bb10adopter111's Avatar
    Thanks, TrueKulcha. I think I am going to do a full backup and reload the OS. The issue closely resembles a bug that was supposed to have been resolved by the upgrade from 10.1 to 10.2 here:

    KB34478-Received SMS text messages do not appear within BlackBerry Hub on a BlackBerry 10 smartphone

    I'm running the official AT&T 10.2.1.3014, which I've had no issues with before this. I have to think it's an OS glitch, so hopefully I can resolve it, though probably not before the weekend. I'll update this post after I try.

    If anyone else has any insights, please post!
    TrueKulcha likes this.
    03-19-15 11:52 AM
  13. cronico's Avatar
    I have the same problem in a BlackBerry Leap with 10.3.1.1779 OS version. Any solution? Even the sound notificatio for the text message doesn't works...

    Posted via CB10
    09-03-15 08:25 AM

Similar Threads

  1. Spambox (new app)
    By Britz Software Inc in forum App Announcements
    Replies: 100
    Last Post: 01-23-17, 03:40 PM
  2. Apps ignoring rotation lock once?
    By RandomSkratch in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 03-19-15, 08:56 PM
  3. Google Albums not displayed in Browser correctly
    By rhitdoph in forum Ask a Question
    Replies: 3
    Last Post: 03-19-15, 06:53 AM
  4. How do I uninstall an existing app?
    By CrackBerry Question in forum BlackBerry Z3
    Replies: 1
    Last Post: 03-19-15, 05:28 AM
  5. Cricket Live App for Passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 03-19-15, 12:36 AM
LINK TO POST COPIED TO CLIPBOARD