1. FiveTR's Avatar
    I bought a Samsung EVO 128GB MicroSDXC card. I formatted the card in my phone (Z30 running 10.3.2.556) twice.
    I then plugged it into my PC and transferred a bunch of music and video files to it, as well as some pictures from my old card.
    When I put it into the phone, it recognized the card but didn't show the number of picture, music, video files etc.
    When I went into the Pictures app, it said it was scanning the card but it seemed hung. It never advanced and read any of the media.
    When I put the card back into my PC, all the images and videos were gone but the music was still there.
    My device has Blackberry Balance (it's given to me by my work) and the media card gets encrypted by policy.

    What am I doing wrong? How can I get this card to work?
    03-21-16 10:43 PM
  2. BigBadWulf's Avatar
    If I recall correctly, you'll need to format the card on the PC, transfer the files, then put it in the phone where it will become encrypted.
    PatrickMJS likes this.
    03-21-16 11:28 PM
  3. FiveTR's Avatar
    Format as exFAT, and not NTFS, right?

    Does it matter what folder structure I create to hold all the different types of files?
    When I format on the device, it creates a folder structure for me.
    If I format on the PC, will the device just work with the folder structure I set up?
    03-21-16 11:53 PM
  4. BigBadWulf's Avatar
    Yes, exFAT and maintain the basic file structure. *crosses paws*
    03-22-16 05:41 AM
  5. FiveTR's Avatar
    *crosses paws*?

    What's that?
    03-22-16 06:16 AM
  6. PatrickMJS's Avatar
    *crosses paws*?

    What's that?
    I think the big bad wolf was trying to be funny... as in when you cross your fingers to hope for good luck.

    But of course a wolf can't cross his fingers so all he can do is cross his paws.

    He's hoping his suggestion will work for you. Did it?

    Posted via CB10
    BigBadWulf likes this.
    03-22-16 12:26 PM
  7. anon(9821186)'s Avatar
    Lol

    Posted via CB10
    03-22-16 08:07 PM
  8. FiveTR's Avatar
    I think the big bad wolf was trying to be funny... as in when you cross your fingers to hope for good luck.

    But of course a wolf can't cross his fingers so all he can do is cross his paws.

    He's hoping his suggestion will work for you. Did it?

    Posted via CB10
    I probably won't have time to play with this until the weekend. I'll report back when I try it. Thanks.
    PatrickMJS likes this.
    03-22-16 08:30 PM
  9. FiveTR's Avatar
    Yes, exFAT and maintain the basic file structure. *crosses paws*
    So I formatted it with exFAT, it formatted 124GB, I replicated the folder structure from my old working card, and copied a bunch of MP3s, video files and pictures (about 23GB worth) to the card. I shut down the Z30, put the new card in, turned the Z30 on, it sees the card as a 128GB card didn't see any videos, music, pictures, etc. I saw a message about encryption starting in 5 minutes. I let the device sit for about 30 minutes and went into the Pictures app. it said it's scanning the card, and has been doing that for an hour now. The progress bar hasn't moved at all. It's just a touch past the beginning and isn't advancing at all.

    So what's going on? Why won't this work? I'm starting to think maybe it's just a bad card.

    Any thoughts?
    03-25-16 12:16 PM
  10. BigBadWulf's Avatar
    With 11Gb of images it takes the better part of an hour to scan. How many do you have? Have you looked in file manager or your picture app, to see if there are at least placeholders formed?
    03-25-16 12:28 PM
  11. FiveTR's Avatar
    There are no placeholders. There are very few images, fewer than 20.
    I have lots of MP3s and maybe 100 video files.

    After about an hour, the device just rebooted itself and when it came back up, it recognized 0GB of everything on the card. No files, and no capacity. Nothing. But I was able to format it to 128GB.
    03-25-16 12:51 PM
  12. FiveTR's Avatar
    As a test, I copied only pictures back to the card. There are 21 altogether - 9 in camera and 11 in photos.
    I'll see what happens now and report back.
    03-25-16 12:55 PM
  13. FiveTR's Avatar
    When I put only the jpegs on there, it worked fine.

    I then added the MP3s I have on my 16GB card. I put that card in and left the device sitting for over an hour.
    When I came back, I couldn't unlock the device. The unlock screen wouldn't come up. I tried powering down and up the device, but the problem didn't go away. So I put back my old 16GB card and rebooted the device, and all is working now.

    Maybe my OS version doesn't really support 128GB cards. I am running 10.3.2.556. The card doesn't seem to be defective as I was starting to think it might be, but it seems the device either cannot read all the contents, or something hangs along the way when it's trying.

    Or maybe I'm just not being patient enough to let it do its thing. It scanned the contents of my 16GB card pretty quickly and has no problem reading the stuff on there (same collection of MP3s I tried putting on the 128GB card and the same JPEGs).

    Should I try copying the contents of the 16GB to the 128GB card, including the encryption files, and see what happens then?
    03-25-16 03:43 PM
  14. PatrickMJS's Avatar
    That's an older version of the OS. You could use Link to update the OS if your carrier hasn't pushed it out to your device.

    I'm not saying that will fix your SD issue, but it might. I always try to keep my OS updated as it does usually fix quite a number of issues, maybe this one.

    Worth a try.

    Posted via CB10
    03-25-16 04:02 PM
  15. FiveTR's Avatar
    That's an older version of the OS. You could use Link to update the OS if your carrier hasn't pushed it out to your device.

    I'm not saying that will fix your SD issue, but it might. I always try to keep my OS updated as it does usually fix quite a number of issues, maybe this one.

    Worth a try.

    Posted via CB10
    Unfortunately, I can't do that. My employer gave me the device and they manage it with BES, so I can't update anything.

    I'm copying all the files from the old card to the new one. Maybe that will do the trick.
    When I deleted all the files from the new card first, a few MP3 folders wouldn't delete - it said they were corrupted. So maybe that was the issue. Or maybe they became corrupted BECAUSE of the issue I'm having.

    We'll see if a direct copy helps. Before, I was putting files on the new card from the original source, not from the old card. So we'll see what happens.
    03-25-16 04:47 PM
  16. BigBadWulf's Avatar
    Very odd behavior, but I think you're on the right track. If transferring direct doesn't work, try moving everything but the mp3's that were deemed corrupt.
    03-25-16 08:40 PM
  17. FiveTR's Avatar
    I figured out what the problem was. Turns out the MicroSD card was not really 128GB. It looks just like a Samsung 128GB card but is really either 4GB or 8GB. So that explains the wonky behavior. I will buy another card in a store and hope it's a real card. Luckily, I got my money back for the fake card. So no harm done, but I'm back to Square One.
    04-07-16 10:12 PM
  18. danp2000's Avatar
    I figured out what the problem was. Turns out the MicroSD card was not really 128GB. It looks just like a Samsung 128GB card but is really either 4GB or 8GB. So that explains the wonky behavior. I will buy another card in a store and hope it's a real card. Luckily, I got my money back for the fake card. So no harm done, but I'm back to Square One.
    That happened to me once with a card I purchased on eBay. I guess there's a reason it was priced the way it was. If
    It seems too good to be true it probably is.

    Since then I've waited for Amazon to have a sale and purchased my cards from there. Less chance of having an issue with a "Fake" card.

    T-Mobile  вιaсĸвεггч Passport Autoloaded 10.3.1.2582: Sachesi to 2744 to 10.3.2.680 to 798 to 2204 to 2339 to 2639 to 2789 to 2813 to 2878 with 2814 Radio
    04-08-16 07:34 AM

Similar Threads

  1. Is there a chance for BB Priv's camera to improve?
    By Mac Duguiang in forum BlackBerry Priv
    Replies: 25
    Last Post: 03-22-16, 01:24 PM
  2. Why won't my BlackBerry Z10 swipe to unlock?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 2
    Last Post: 03-22-16, 05:36 AM
  3. Is there a chance for BB Priv's camera to improve?
    By Mac Duguiang in forum BlackBerry Priv
    Replies: 1
    Last Post: 03-21-16, 10:55 PM
  4. Sharing a Bitmoji to BBM on IOS
    By Gatmyer in forum BBM on iOS
    Replies: 0
    Last Post: 03-21-16, 09:25 PM
  5. Keep on getting notification to update gmail password
    By dpure in forum BlackBerry Classic
    Replies: 1
    Last Post: 03-21-16, 08:43 PM
LINK TO POST COPIED TO CLIPBOARD