1. habibvalil's Avatar
    I use Navitel as my navigator. It is some months that it starts very slow. It take 3-4 minutes to get ready.
    In the startup, it stucks in the screen below, meaning that models are getting ready. I don't know what it means and how can be resolved. Previously the startup used to take about 20 secs. Maybe I have changed some setting and I don't know which setting. There is no option to reload a default setting.

    Navitel navigator, slow startup-img_20140816_144204.png

    Posted via CB10
    08-16-14 05:20 AM
  2. jaydee5799's Avatar
    What about deleting it and reinstalling it?
    Wouldn't that reset all the default choices?
    08-21-14 07:46 AM
  3. habibvalil's Avatar
    That didn't help!

    Posted via CB10
    08-21-14 11:06 AM
  4. GSM-S's Avatar
    Does Navitel use folders on your SD card or device? If it does, delete the app and delete the Navitel folders. If the app is an android port, try restarting your BlackBerry 10 device before reinstalling the app. I hope this works for you.

    Posted via CB10
    08-21-14 11:43 AM

Similar Threads

  1. Navigating between containers
    By dg7860 in forum New to BlackBerry App Dev
    Replies: 2
    Last Post: 08-16-14, 08:55 AM
  2. Bold 9930 Navigation
    By Willard88 in forum Ask a Question
    Replies: 3
    Last Post: 08-12-14, 06:05 PM
  3. Do your BBM messages ever slow down?
    By Mord3Kay in forum General BlackBerry Discussion
    Replies: 10
    Last Post: 08-08-14, 01:23 PM
  4. Z10 slows down
    By Mahdi rezaee in forum Ask a Question
    Replies: 6
    Last Post: 08-07-14, 10:57 AM
  5. Slow upload from laptop to z10 via remote files
    By INTz in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 08-06-14, 09:33 PM
LINK TO POST COPIED TO CLIPBOARD