1. anon(5818411)'s Avatar
    My friend is trying to get her miracast working on here Panasonic Viera Smart TV from her Z30. She wasn't able to, so she asks me.
    I Happen to have a Q10 and a Panasonic Viera Smart TV as well, so I thought i'd try it out since usually I just use a HDMI cord.

    My TV is always hooked up to my WIFI and has the exact same setting except IP adress obviously as my WIFI on my phone.

    Both WIFI on my phone and tv are hooked on the same wifi. (i have multiple wifis in my house due to extenders everywhere haha)
    She has both wifis on and connected with the exact same settings as well.

    Both of ours is not working.

    Wifi->Miracast->share screen-> then says HDMI cord not connected.

    We are both running 10.2.1.2141 (Rogers official OS for me and Bell official OS for her) has anyone tried Miracast on this OS specifically? My DLNA doesn't seem to be working either, WIFI direct doesn't find any devices as well.

    Am I missing something here?
    03-22-14 04:32 PM
  2. AnimalPak200's Avatar
    I know with Samsung you have to use the remote to "start screen mirroring" or whatever they call it, and only after I do that does my TV show up as an available miracast recipient. So, you might have to do something similar on your panasonics.



    Posted via CB10
    anon(5818411) likes this.
    03-22-14 05:00 PM
  3. jpvj's Avatar
    Miracast is essentially "Wireless HDMI" so the message "HDMI cord not connected" could simply mean the Miracast failed to connect.

    Not much of a help for your problem though :-(
    anon(5818411) likes this.
    03-22-14 05:02 PM
  4. BernFlo's Avatar
    Funny I have the same situation, Panasonic Viera smart TV and Z30, I can't get it going either. I too would be interested in some assistance.


    Fully awake and catching my Z's, Z10 and Z30!
    anon(5818411) likes this.
    03-22-14 05:06 PM
  5. anon(5818411)'s Avatar
    I know with Samsung you have to use the remote to "start screen mirroring" or whatever they call it, and only after I do that does my TV show up as an available miracast recipient. So, you might have to do something similar on your panasonics.



    Posted via CB10
    I'm going to look into that then thanks
    03-22-14 05:15 PM
  6. anon(5818411)'s Avatar
    I know with Samsung you have to use the remote to "start screen mirroring" or whatever they call it, and only after I do that does my TV show up as an available miracast recipient. So, you might have to do something similar on your panasonics.



    Posted via CB10
    Apparently it's the same with panasonic but my remote doesn't look like this at 0:40
    03-22-14 05:19 PM
  7. anon(5818411)'s Avatar
    i'm going to try out this app later

    https://play.google.com/store/apps/d...ppotvpanasonic

    but I really want to natively do it, i shouldn't need an android app to get the job done
    03-22-14 05:22 PM
  8. anon(5818411)'s Avatar
    Funny I have the same situation, Panasonic Viera smart TV and Z30, I can't get it going either. I too would be interested in some assistance.


    Fully awake and catching my Z's, Z10 and Z30!
    what OS are you using? Is your DLNA not working either? Mine was with 10.2 but not anymore (only used it for music with 10.2)
    03-22-14 05:22 PM
  9. anon(1852343)'s Avatar
    Thought you needed a miracast adapter for this

    Q10 with Telus on 10.2.1.2141
    03-22-14 05:26 PM
  10. anon(5818411)'s Avatar
    Thought you needed a miracast adapter for this

    Q10 with Telus on 10.2.1.2141
    smart TV is running on wifi so it's like having a miracast dongle, wireless DNLA, sometime bluetooth. You can also install apps and go on the internet.

    Think of it kind of like chromecast.
    03-22-14 05:28 PM
  11. AnimalPak200's Avatar
    Thought you needed a miracast adapter for this

    Q10 with Telus on 10.2.1.2141
    Only if your TV/bluray player doesn't already support it.

    Posted via CB10
    03-22-14 05:29 PM
  12. gebco's Avatar
    This may be a long shot, but a while ago I wasn't able to get DLNA working. Finally tracked it down to Developer Mode being on.

    Posted via CB10
    03-22-14 07:55 PM
  13. anon(5818411)'s Avatar
    This may be a long shot, but a while ago I wasn't able to get DLNA working. Finally tracked it down to Developer Mode being on.

    Posted via CB10
    Both mine and hers aren't on

    Posted via CB10
    03-22-14 08:08 PM
  14. decoy7's Avatar
    On my LG I had to turn Miracast on in the TV settings, have you seen settings for Miracast in your Panasonic?

    Q10 SQN100-3/10.2.1.1925
    03-22-14 08:09 PM
  15. anon(5818411)'s Avatar
    On my LG I had to turn Miracast on in the TV settings, have you seen settings for Miracast in your Panasonic?

    Q10 SQN100-3/10.2.1.1925
    I didn't see any but I can look.

    What is odd is DLNA worked with 10.2 and now doesn't work at all. I have a feeling it's my OS

    Posted via CB10
    03-22-14 08:14 PM
  16. FrankIAm's Avatar
    Wait have you ever connected another device to it? Maybe your TV doesn't support it, do you know for a fact that it does?

    You stated it has a wifi capabilities, but that doesn't make it inherently miracast capable!

    Don't mean to sound rude, just saying.

    BlackBerry 101 - Help Channel
    03-22-14 08:23 PM
  17. anon(5818411)'s Avatar
    Wait have you ever connected another device to it? Maybe your TV doesn't support it, do you know for a fact that it does?

    You stated it has a wifi capabilities, but that doesn't make it inherently miracast capable!

    Don't mean to sound rude, just saying.

    BlackBerry 101 - Help Channel
    Yes I just stated I was able to connect with basic DLNA before now it doesn't at all. Wifi direct doesn't find anything and Miracast doesn't work

    Posted via CB10
    03-22-14 08:28 PM
  18. anon(5818411)'s Avatar
    I'll mess around on her Z30 tomorrow to see if I can get hers to work, since I tried everything.

    It works with the panasonic media centre android app. On my Q10.

    Posted via CB10
    03-22-14 08:33 PM
  19. BBZ10wannabe's Avatar
    I have the same OS with my Z30 as you on Rogers. Only difference is my TV is Samsung. I looked in every manual and help setting and the only place I could find the word Miracast was on the Future Shop website where I bought my TV but sure enough just as another poster said activate your screen mirroring from your TV and goto the Miracast tab on your Z30 or Q10 and it will say HDMI not connected but then it your TV will appear in another row. Click that and you are golden. (can't remember if you click screen share first) Just keep pushing buttons until it works

    Posted via CB10
    03-22-14 09:03 PM
  20. farmwersteve's Avatar
    I have a brand new Viera and I don't believe miracast is a function on that tv

    Dnla and miracast are two totally different animals.

    As different as blue tooth and infrared


    I bought a dongle and prefer the dongle even if my tv had it

    This is because my dongle is set to hdmi 3 on my stereo receiver so the audio from my BlackBerry goes through my 5.1 speakers instead of my tv speakers.

    Plus the dongle takes power from a spare usb port, so no need to have it plugged to an ac outlet

    Posted via CB10
    03-22-14 09:15 PM
  21. FrankIAm's Avatar
    Yes I just stated I was able to connect with basic DLNA before now it doesn't at all. Wifi direct doesn't find anything and Miracast doesn't work

    Posted via CB10
    But DNLA =/= Miracast.. I mean, you are talking about IPs and being connected to the same network, which is absolutely not how Miracast works.

    Again, don't mean to sound rude, but are you a 100% sure your TV supports it?

    But DNLA does seem like an issue! Did you check on settings > media sharing?
    Maybe the update switched something off, who knows

    BlackBerry 101 - Help Channel
    03-22-14 09:18 PM
  22. anon(5818411)'s Avatar
    But DNLA =/= Miracast.. I mean, you are talking about IPs and being connected to the same network, which is absolutely not how Miracast works.

    Again, don't mean to sound rude, but are you a 100% sure your TV supports it?

    But DNLA does seem like an issue! Did you check on settings > media sharing?
    Maybe the update switched something off, who knows

    BlackBerry 101 - Help Channel
    I have a brand new Viera and I don't believe miracast is a function on that tv

    Dnla and miracast are two totally different animals.

    As different as blue tooth and infrared


    I bought a dongle and prefer the dongle even if my tv had it

    This is because my dongle is set to hdmi 3 on my stereo receiver so the audio from my BlackBerry goes through my 5.1 speakers instead of my tv speakers.

    Plus the dongle takes power from a spare usb port, so no need to have it plugged to an ac outlet

    Posted via CB10
    100% mine has miracast


    I know DLNA has nothing to do with miracast but it doesn't work either. When DLNA use to work with 10.2, I don't know with miracast because I haven't tried it until today.
    03-23-14 01:06 AM
  23. anon(2313227)'s Avatar
    Miracast has nothng to do with Chromecast/wifi/DLNA.
    You will need to make sure the TV supports WIDI or MIRACAST to use the Z30.
    Just because your TV supports apps and is connected to WIFI does not mean it has Miracast.
    What model is your Panasonic Viera?
    03-23-14 01:33 AM
  24. louzer's Avatar
    I have a Q10 and a Netgear PTV3000 Miracast adapter and I have no problem connecting and using Miracast. The problem I have is Q10 specific. When I connect, I get a mirror of my screen on my TV. The TV is 16:9 and the Q10 is 1:1 aspect ratio. This means that I have a square viewing area whose width is also the height of the TV leaving much of the TV's real estate unused because of the Q10's square screen.

    The media player and picture viewer app both have options in them, once playing in their square space on my TV screen to Miracast. When I choose this option, both apps fill my full screen with the 16:9 ratio.

    My issue is that these are the only two apps that support Miracast. Everything else that I do confines the display to the 1:1 square in the middle of my screen.

    If I use the browser to view a Youtube video, it launches in the media player app, so I can fill my screen with the video. If I use the FastTube app, there is no such option and I get a 16:9 video embedded in the square space on my screen. On the Z30, if you switch to landscape mode, it would fill the whole screen, but since the Q10 doesn't support both landscape/portrait orientation (because they'd be the same with 1:1), there is no way to fill the screen with what's being mirrored.

    The same problem occurs with the CBS and NBC native apps for viewing TV. Since neither invokes the native media player app, TV shows display in a very small 16:9 window contained within the 1:1 window of the mirror.

    I wish that there was a way to fake out the mirror mode to think that my phone has a 16:9 display.
    03-23-14 12:42 PM
  25. farmwersteve's Avatar
    100% mine has miracast


    I know DLNA has nothing to do with miracast but it doesn't work either. When DLNA use to work with 10.2, I don't know with miracast because I haven't tried it until today.
    Thanks for the YouTube link, but my brand new tv doesn't have a miracast specific button, please let me know your exact model of Panasonic tv

    Also, take a picture of your remote and post it if you don't mind, maybe I can see if that will work with mine if I can find that remote.

    Posted via CB10
    03-26-14 11:05 PM

Similar Threads

  1. How to patch Android Apps depending on Google Maps and Google Play Services [terminal versions]
    By christian-georgescu in forum More for your BlackBerry 10 Phone!
    Replies: 23
    Last Post: 06-10-16, 01:52 PM
  2. Q10 Battery Dead in 4hrs on no use.
    By bigballofyarn in forum BlackBerry Q10
    Replies: 12
    Last Post: 03-27-14, 06:50 AM
  3. Cast Your Vote! Best Smartphone Finals: BlackBerry Z30 vs. LG Nexus 5 - TechnoBuffalo
    By Corbu in forum General BlackBerry News, Discussion & Rumors
    Replies: 102
    Last Post: 03-25-14, 05:07 PM
  4. Blackberry Link won't reload OS on STL100-1
    By LW7JVSW3 in forum BlackBerry Z10
    Replies: 2
    Last Post: 03-22-14, 04:48 PM
LINK TO POST COPIED TO CLIPBOARD