10-19-15 10:40 PM
141 123 ...
tools
  1. compuboy04's Avatar
    I am an avid user of my Q10. Have been on the 10.3.1 leaks and have since reverted back to the official production 10.2.1 build from Verizon. Recently I have noticed that battery life has been terrible and the phone would get warm but only when on wifi. Upon further investigation I noticed "System" cpu usage would hover at 50% or higher for hours at a time while "BBM" cpu usage would be at about 5%. It got stranger when I looked at the BBM data use and saw hundreds of megabytes in and out in nearly identical amounts generated by the bbm app.

    Data usage details for the BBM process
    Major Battery Killing Bug in BBM - Confirmed proof-img_20141207_230444.png
    Current CPU usage while the issue is taking place
    Major Battery Killing Bug in BBM - Confirmed proof-img_20141208_113927.png

    Next I checked my wifi access point and confirmed a ton of data was infact traversing the airwaves and the Q10 was the only device connected at the time... It was time to figure out what exactly was happening. I obtained wireshark captures from the access point and the problem became clear as day!

    I, like other home users and TONS of business users use adblocking DNS on my network. The Q10 was requesting a DNS record for "api.mixpanel.com" and getting an invalid 0.0.0.0 reply. Not being able to connect or satisfied with the reply, it tried again... Problem is it did this 50-90 times a second! Are you kidding me???!!!

    Major Battery Killing Bug in BBM - Confirmed proof-11111capture.jpg

    Mixpanel appears to be some sort of mobile analytics company. Not sure why exactly BBM finds it so important to remain in contact with them. Anyways long story short I edited my ad blocking to allow api.mixpanel.com and within seconds the problem corrected itself and the crazy connection attempts stopped.

    Graphs from Cisco device showing over 80 connections per second and a constant 300kbps drop to nothing as soon as it got a valid DNS reply
    Major Battery Killing Bug in BBM - Confirmed proof-2222222capture.jpg

    I have done further testing and tried having the ad blocking respond with valid internal IP addresses or redirects rather than 0.0.0.0 and it has no effect what-so-ever on this issue. The only confirmed fix I found is to allow the device to contact api.mixpanel.com and obtain a valid DNS reply.

    I see this as a MAJOR bug because Blackberry devices cator to business users, many of whom use openDNS, Barracuda, ironport, sonicwall or other solutions that have web filtering and/or adblocking. Why on earth does Blackberry feel the need to basically DDOS your phone and the wifi network it's on if it doesn't like the DNS reply it gets for api.mixpanel.com? Insane!

    I am reporting these findings to the community in hopes it gets to the right people who can report this as a bug to BlackBerry. Please let me know if there is anything else you would like me to do, or if you know of a way I can report this myself. Also hopefully this helps other users who may be suffering with this issue and not even know it!

    ~Dave

    UPDATE:
    Bug has been reported to Blackberry:
    https://www.blackberry.com/jira/browse/BBTEN-2751

    MAJOR UPDATE:
    After doing a security wipe I have confirmed this same bug IS present in 10.3.1.1151 OS. I would like to also note that on this OS version I was running BBM version 10.5.15.15

    Update - 12/10/14:
    I have confirmed that BB does infact actively communicate with api.mixpanel.com but it appears they only use this if you open the shop. It tracks your every move! See post #84

    Also early this morning BB confirmed this bug and said a fix wont be out until next year
    Last edited by compuboy04; 12-10-14 at 01:55 PM. Reason: Found what mixpanel does! Creepy
    12-08-14 11:07 AM
  2. bungaboy's Avatar
    Did you have the "leaks" while you had the "10.3.1 leak" installed?

    Are you saying it's bug on everyone's device?
    12-08-14 11:22 AM
  3. compuboy04's Avatar
    I have not confirmed this on 10.3.1 leaks but know for sure it's an issue with BBM 10.5.13.14 on OS 10.2.1.2976 (latest Verizon official build in USA)

    Yes I am saying this is an issue on everyone's phone that has the same software as me. I do not have the time or patience to load the 10.3.1 leak again to see if there is any change. It would be nice if others in the community could confirm. Generally the issue will happen within 2-3 hours of api.mixpanel.com being DNS blocked on a constant wifi connection
    12-08-14 11:25 AM
  4. mad_mdx's Avatar
    That's interesting and explains a few things about that BBM bug. Contact BlackBerry and demand an explanation?
    compuboy04 likes this.
    12-08-14 11:43 AM
  5. compuboy04's Avatar
    That's interesting and explains a few things about that BBM bug. Contact BlackBerry and demand an explanation?
    I wish it was that easy... My experience dealing with things like this is you get someone who has no idea what your talking about, or who will tell you to reload your OS, and it's a waste of time. Going to post on the Blackberry.com forms too. I could try calling/emailing BB but don't think I will get anywhere
    12-08-14 11:46 AM
  6. Stephen Gooden's Avatar
    As mad-mdx indicated, suggest you log this with BlackBerry support pages. Hopefully an admin responds. Nice find by the way.

    Posted via CB10
    compuboy04 likes this.
    12-08-14 11:46 AM
  7. conite's Avatar
    Did you have "send diagnostics and usage data" turned off under settings / diagnostics?

    Z30STA100-5/10.3.1.1154
    limabo likes this.
    12-08-14 11:53 AM
  8. compuboy04's Avatar
    Did you have "send diagnostics and usage data" turned off under settings / diagnostics?

    Z30STA100-5/10.3.1.1154
    Yes I just checked. This is off
    12-08-14 11:55 AM
  9. GS51's Avatar
    I have confirmed this issue as well it happened on my Z10 today i had to reboot the phone to stop the battery from dropping and the phone from heating up.

    Posted on my Z10 Via CB10
    12-08-14 11:55 AM
  10. X3T's Avatar
    EDIT: My mistake, it was standby using all the cpu.

    I had this a few weeks ago, had no idea it was BBM though. Drained battery flat overnight and missed my alarm.

    Posted via CB10
    12-08-14 12:07 PM
  11. compuboy04's Avatar
    Bug has been reported to BB:
    https://www.blackberry.com/jira/browse/BBTEN-2751

    Not sure if you all are able to see that or only me. Hoping for the best and a fix!
    Good to know this information is helping others out there. As long as DNS replies and communication to api.mixpanel.com is allowed the issue goes away
    wincyUt and moody like this.
    12-08-14 12:10 PM
  12. Dave Bourque's Avatar
    Bug has been reported to BB:
    https://www.blackberry.com/jira/browse/BBTEN-2751

    Not sure if you all are able to see that or only me. Hoping for the best and a fix!
    Good to know this information is helping others out there. As long as DNS replies and communication to api.mixpanel.com is allowed the issue goes away
    If the networking testers are doing their job this will be fixed on official builds of 10.3.1

    Posted via CB10
    12-08-14 12:17 PM
  13. compuboy04's Avatar
    If the networking testers are doing their job this will be fixed on official builds of 10.3.1

    Posted via CB10
    True, however I think this bug may actually be in the BBM software and not the OS. AT least that's what it seems like to me. This could potentially effect everyone right now. Will be interesting to see what BB says

    That being said would be interesting if this effects other platforms if this is a bug in the BBM app itself
    12-08-14 12:23 PM
  14. howards's Avatar
    Not seeing this problem using the same official Verizon OS on my Z30.

    Z30 / STA 100-3 / 10.2.1.3289
    12-08-14 12:52 PM
  15. compuboy04's Avatar
    Not seeing this problem using the same official Verizon OS on my Z30.

    Z30 / STA 100-3 / 10.2.1.3289
    Confirm a DNS queue for api.mixpanel.com returns 0.0.0.0 or another invalid address. Stay connected to wifi and use BBM normally.. It may take several hours to start happening. Sometimes its almost instant. Are you running BBM version 10.5.13.14?
    12-08-14 12:54 PM
  16. bungaboy's Avatar
    Confirm a DNS queue for api.mixpanel.com returns 0.0.0.0 or another invalid address. Stay connected to wifi and use BBM normally.. It may take several hours to start happening. Sometimes its almost instant. Are you running BBM version 10.5.13.14?
    Is BBM version 10.5.13.14 the latest version you can get on that OS?
    12-08-14 01:48 PM
  17. mrfreeze's Avatar
    I wonder if the new beta version of BBM resolves this issue?
    12-08-14 02:00 PM
  18. ThunderShock2005's Avatar
    My Q10 seems to be managing well with BBM in use.

    Major Battery Killing Bug in BBM - Confirmed proof-img_20141208_120438.png

    Yup. Almost 2 days and it looks like it will go even longer. ;-)

    Posted via BlackBerry Q10 on AT&T
    pogly2 likes this.
    12-08-14 02:08 PM
  19. Mirk's Avatar
    My Q10 seems to be managing well with BBM in use.

    Yup. Almost 2 days and it looks like it will go even longer. ;-)

    Posted via BlackBerry Q10 on AT&T
    Did you actually read what the issue was? This is a combined issue between BBM and his Firewall. Unless you have the same Firewall restriction you will not have the problem.
    12-08-14 02:11 PM
  20. compuboy04's Avatar
    I wonder if the new beta version of BBM resolves this issue?
    I'm interested as well but only have one phone and would prefer not to mess with it any more. Especially now that I figured out a temporary fix! I know 10.5.13.14 is the most recent production build of BBM. Got an email back that the Blackberry bug team is looking into this and they requested my wireshark captures.
    12-08-14 02:15 PM
  21. mrfreeze's Avatar
    I see it is assigned to MSOHM.. That's Sacha's bestest friend in the whole wide world.
    bungaboy and moody like this.
    12-08-14 02:19 PM
  22. vetteman93's Avatar
    I have noticed this drain not only on my home wifi but at other locations wifi and also just using the 4G LTE network.
    12-08-14 02:20 PM
  23. compuboy04's Avatar
    I see it is assigned to MSOHM.. That's Sacha's bestest friend in the whole wide world.
    I feel like there's a story here?

    Vetteman93, Whn you notice it happening open Device Monitor and BBM and look at wifi data usage. If you see the same pattern of a few hundred MB both sent and received in near identical amounts along with high System CPU then it's probably the same issue. Many networks do deploy filtering and/or blocking that could cause this bug to become a problem. Have not seen this AT ALL on mobile data
    moody likes this.
    12-08-14 02:23 PM
  24. detritus71's Avatar
    Thanks for the hard work, man! It helped here to fix it provisional.
    compuboy04 likes this.
    12-08-14 02:45 PM
  25. bungaboy's Avatar
    I'm interested as well but only have one phone and would prefer not to mess with it any more. Especially now that I figured out a temporary fix! I know 10.5.13.14 is the most recent production build of BBM. Got an email back that the Blackberry bug team is looking into this and they requested my wireshark captures.
    Can't you use 10.5.15.15?

    Major Battery Killing Bug in BBM - Confirmed proof-bbm.jpg
    mrfreeze and moody like this.
    12-08-14 04:46 PM
141 123 ...

Similar Threads

  1. BLEND drains the battery
    By aldebaran12 in forum BlackBerry Passport
    Replies: 6
    Last Post: 03-25-15, 02:06 AM
  2. Replies: 3
    Last Post: 12-08-14, 11:04 AM
  3. Replies: 1
    Last Post: 12-08-14, 10:23 AM
  4. NYE in Dsseldorf, where to go?
    By H4zN in forum Rehab & Off-Topic Lounge
    Replies: 0
    Last Post: 12-08-14, 06:25 AM
  5. Why am I seeing & VS & in email subject on the Passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 12-08-14, 03:52 AM
LINK TO POST COPIED TO CLIPBOARD