1. muellerto's Avatar
    Yesterday I put in a very new 64GB SD card. I formatted it in my Z30. Then I got the idea to restore the contents from my previous 32GB SD card which I had saved before on my Linux machine. Now my problem: until today I could mount my device via USB, just
    Code:
    mount /dev/sdb1 /mnt
    But now mount tells me there are multiple filesystems on the device, I should specify one using mount parameter -t or I should use wipefs to remove superfluous filesystems. What I'm not familiar with is: what filesystems do I have now on my device? Can I list them somehow? I tried
    Code:
    mount -t vfat /dev/sdb1 /mnt
    But this says "file system is not recognized", and this happens also with exfat, fat, fat32, umsfs and msdos. So, how to solve this? Or is just my Linux fat32-driver not compatible to 64GB partitions? My Windows 7 at work connects like a charme.
    11-28-14 01:01 AM
  2. g33kphr33k's Avatar
    What old Linux implementation are you using where things don't automount in 2014?

    sudo fdisk -l

    That will list all file systems and mountable points it can see locally attached.

    I wish I could afford the Z10 upgrade
    11-28-14 01:14 AM
  3. muellerto's Avatar
    What old Linux implementation are you using where things don't automount in 2014?
    I use Arch Linux x64, a so called bleeding edge distro. But I don't use any automount anymore. I always mount manually. (And how should any automount help?)
    sudo fdisk -l
    Thanks, sure fdisk, didn't come into my mind.
    11-28-14 01:29 AM
  4. bazillus's Avatar
    Tried a different target than /mnt?
    Most distros I know use that path for mounting devices in it (as a folder)

    What message do you get exactly?
    11-28-14 01:33 AM
  5. muellerto's Avatar
    Tried a different target than /mnt?
    Sure, tried it also locally.
    Most distros I know use that path for mounting devices in it (as a folder)
    Most distros use an automounter which then has subfolders mostly under /media or something else. I have a /mnt on my disk and this is my standard mount point for everything. And as I said it worked until yesterday, for many years, with many devices. The problem is not the mount point, the target, the problem is on the source side. I see, there's a thread about formatting a 64GB SD card. Must read this ...
    What message do you get exactly?
    (I'm currently on a Windows machine ... Can tell this not before this evening.)
    11-28-14 01:55 AM
  6. m3mb3rsh1p's Avatar
    If you can still read your old data, copy it to your computer and partition the card(s) anew using Disk Utility (Mac), fdisk (*nix) or diskpart (Windows). Do not use the BlackBerry 10 utilities for now.

    On the card you are having trouble mounting, try mounting the root device ie sdb not sdb1 because it may not have been properly partitioned.

    Posted via CB10
    11-28-14 02:52 AM
  7. muellerto's Avatar
    try mounting the root device ie sdb not sdb1 because it may not have been properly partitioned.
    Another interesting idea. But this would mean the BB device does something not good while formatting.
    11-28-14 03:00 AM
  8. m3mb3rsh1p's Avatar
    I'm not sure about how BlackBerry 10 handles partitions and file systems but suspect it might be related to the issues that sometimes pop up with SD Cards.
    Last edited by m3mb3rsh1p; 11-29-14 at 09:58 AM.
    11-28-14 04:19 AM
  9. tavla's Avatar
    What is the exact error message returned from mount? Can you paste it?

    Are you sure the device is /dev/sdb1 and not some other?

    Posted via CB10
    11-28-14 05:02 AM
  10. alaviss's Avatar
    Please include dmesg output when mount

    Z10STL100-1/10.3.1.1151
    11-28-14 06:14 AM
  11. muellerto's Avatar
    I made a big step forward.

    First, the concrete error message is as follows:
    Code:
    $ mount /dev/sdb1 /mnt
    mount: /dev/sdb1: Weitere Dateisysteme erkannt. Dies sollte nicht passieren,
           verwenden Sie -t <Typ>, um den Dateisystemtyp explizit anzugeben,
           oder wipefs(8), um das Gert zu leeren.
    As I said this means "Multiple file systems recognized. This should not happen, use -t <type> to specify the file system type explicitely or use wipefs(8) to clean the device."

    Then I tried to mount sdb instead of sdb1, the message is as follows:
    Code:
    $ mount /dev/sdb /mnt
    mount: Falscher Dateisystemtyp, ungltige Optionen, der
    Superblock von /dev/sdb ist beschdigt, fehlende
    Kodierungsseite oder ein anderer Fehler
    This means "Wrong file system type, invalid option, superblock is demaged, wrong code page or another error."

    At least fdisk -l gave the following interesting informations:
    Code:
    $ fdisk -l
    
    [...]
    
    Festplatte /dev/sdb: 59,5 GiB, 63864569856 Bytes, 124735488 Sektoren
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgre (logisch/physikalisch): 512 Bytes / 512 Bytes
    E/A-Gre (minimal/optimal): 512 Bytes / 512 Bytes
    Festplattenbezeichnungstyp: dos
    Festplattenbezeichner: 0x00000000
    
    Device     Boot Start       End   Sectors  Size Id Type
    /dev/sdb1       32768 124735487 124702720 59,5G  c W95 FAT32 (LBA)
    See the last line. This FAT32 file system was created by my Z30. OK, I reformatted it in my Linux laptop using mkfs.exfat. But the result is exactly the same.

    Then I made some Internet recherches. What I found is that several Linux distros have two exfat packages, one includes mkfs.exfat and fsckexfat (and othe stuff), but this one does still not allow mounting. If you want to mount you need fuse-exfat. I installed this.

    Now, with fuse-exfat, I must specify the file system, mount -t exfat /dev/sdb1 /mnt, it is still not recognized by itself, but this is successful. I can read and write as I want.
    11-28-14 09:44 AM
  12. m3mb3rsh1p's Avatar
    Thanks for sharing your solution. Good to know about the exfat issue.

    Posted via CB10
    11-28-14 03:05 PM
  13. alaviss's Avatar
    Now, with fuse-exfat, I must specify the file system, mount -t exfat /dev/sdb1 /mnt, it is still not recognized by itself, but this is successful. I can read and write as I want.
    Next time use

    $ LANG="en_US.UTF-8" <command>

    Or

    $ LANG=C <command>

    to avoid having to translate output.

    Btw, you should try running

    $ wipefs /dev/sdb1

    This won't harm your card and will display all file system found inside the card. If there's more than one, consider moving all data outside then run:

    # wipefs -a /dev/sdb1

    This will clean all filesystem signature on the card. After that proceed to reformat the card:

    # mkfs.exfat /dev/sdb1

    After that, Arch Linux should properly detect card fs.

    Z10STL100-1/10.3.1.1151
    ezikiah likes this.
    11-29-14 04:52 AM
  14. muellerto's Avatar
    Btw, you should try running

    $ wipefs /dev/sdb1
    I did this. This shows exactly nothing. Not a single information.

    We talk about exfat here. The exfat file system has been and is still existing on the SD card, the device created it properly. But it seems to be more a Linux problem. My Linux doesn't recognize it properly. I assume indeed even the message is wrong. The message should be that no file system is recognized instead of multiple ones. So, wipefs is no help here, not at all.
    # mkfs.exfat /dev/sdb1

    After that, Arch Linux should properly detect card fs.
    Have you read what I wrote in my previous post above?
    11-29-14 05:29 AM
  15. alaviss's Avatar
    I did this. This shows exactly nothing. Not a single information.

    We talk about exfat here. The exfat file system has been and is still existing on the SD card, the device created it properly. But it seems to be more a Linux problem. My Linux doesn't recognize it properly. I assume indeed even the message is wrong. The message should be that no file system is recognized instead of multiple ones. So, wipefs is no help here, not at all.
    Have you read what I wrote in my previous post above?
    I have already read the previous post and know that you have rw access to your card but I'm pretty curious about the "multiple fs" problem. My Linux (Arch) can detect exfat automatically and know what fs to mount (vanilla kernel, fuse-exfat installed)

    Z10STL100-1/10.3.1.1151
    11-29-14 06:49 PM

Similar Threads

  1. Update problem OTA via cellular data
    By Kiyasudeen in forum BlackBerry Z3
    Replies: 13
    Last Post: 07-31-15, 04:45 AM
  2. Anyone have damage on their passport from the case?
    By RoyaleWChz in forum BlackBerry Passport
    Replies: 55
    Last Post: 01-07-15, 10:08 AM
  3. 7 digital problem
    By eyesaidit66 in forum Ask a Question
    Replies: 2
    Last Post: 11-28-14, 07:34 PM
  4. OS10.3.1.1154 problem on Z10
    By i2know in forum Ask a Question
    Replies: 3
    Last Post: 11-28-14, 06:07 AM
  5. Replies: 1
    Last Post: 11-27-14, 09:30 PM
LINK TO POST COPIED TO CLIPBOARD