03-05-18 09:02 AM
45 12
tools
  1. Vincent Lengkeek's Avatar
    Hi all,

    wanted to test out WhatsApp from the Google App Store on my Passport (to find out if this is a solution when WhatsApp stops BB10 support end of year).

    INstallation worked, registration as well (I think?), but for the last hour or so it is telling me it is searching for back-ups. And this is something I cannot skip or stop to continue.

    What is your experience? Does this take very long? Can I keep the app open in the background, while it searches, or do I have to have it opened?

    Any help would be greatly appreciated :-)
    03-04-16 12:52 AM
  2. noemi-abril's Avatar
    you have to patch for google play services to work ok. geolocation not work until it is patched.
    03-04-16 01:09 AM
  3. Vincent Lengkeek's Avatar
    Hi, thanks for your post.

    I patched the WhatsApp-apk, but that did not do the trick. I also read in another post that patching is actually not necessary for this app.

    Thing is: It knew I am in the Netherlands, I put in my phone number, and I got past the sms-verification part. It just got stuck at the point where it then wants to load a back up from the WhatsApp-servers...
    03-04-16 03:50 AM
  4. noemi-abril's Avatar
    Since whatsapp used copies in the google drive cloud and geolocation should patch if you want to use these functions. If you do not want to use the backup on google drive you off, the same as not using the geolocation due as the map is blank.

    One more thing... if you patch to use this functions you have to Install Google play Services :-/
    BD_BB_8520 likes this.
    03-04-16 04:54 AM
  5. Vincent Lengkeek's Avatar
    I'll try once more.

    BTW: google services are installed

    Posted via CB10
    03-04-16 07:33 AM
  6. yueytan's Avatar
    Be patient. It takes a while but eventually it clears that screen! Especially if you're on a slower device like a Classic or Z10.

    Posted via the CrackBerry App for Android
    03-04-16 09:33 AM
  7. noemi-abril's Avatar
    But... why not use the BlackBerry port instead of Android WhatsCrapp?
    03-08-16 01:12 AM
  8. deba911's Avatar
    Im also facing the same problem. Any idea on how long would it take? Its almost been 2 hours!!!

    Posted via CB10
    07-01-16 01:20 PM
  9. KenV54's Avatar
    Im also facing the same problem. Any idea on how long would it take? Its almost been 2 hours!!!

    Posted via CB10
    I, too, have tried everything. Removing the BB WA, going to Ghost Commander and removing all traces of WA, taking out the SD Card, Whitelisting WA, making sure the permissions are set to access contacts, adding Google Drive, multiple reboots and reinstalls, etc. Some people have no problems, others have this problem. One post in another thread said that if the BB version of WA was ever installed, you could never run the Android WA until you wiped the BB device. Others say they can have both versions on their phone, although only one will be active, not both.

    Bottom line--it's completely a mystery as to what keeps the Android WA "looking for backups" forever.
    07-10-16 07:36 PM
  10. royabsa's Avatar
    I had this issue but bypassed it, but I've sadly forgotten how I did it. Did you try clicking the "BlackBerry" back button?

    At registration, does it say "Restore from back-up?" If so, try and untick that.

    Posted via PassportSQW100-1/10.3.2.2876
    07-11-16 06:18 AM
  11. royabsa's Avatar
    Bottom line--it's completely a mystery as to what keeps the Android WA "looking for backups" forever.
    It's inability to view "Shared Files." It's like the "Shared Files" permission is off, even though it's by default on. The Android Runtime is glitching with WA and thus the app isn't able to locate the backup.

    Posted via PassportSQW100-1/10.3.2.2876
    07-11-16 08:16 AM
  12. KenV54's Avatar
    It's inability to view "Shared Files." It's like the "Shared Files" permission is off, even though it's by default on. The Android Runtime is glitching with WA and thus the app isn't able to locate the backup.

    Posted via PassportSQW100-1/10.3.2.2876
    Thanks. Interesting. I wonder if replacing the special updated Android Runtime from BlackBerry World with the one from 2813 would solve the problem. Will that ART work with 2888?

    Posted via CB10
    07-11-16 10:24 AM
  13. royabsa's Avatar
    Thanks. Interesting. I wonder if replacing the special updated Android Runtime from BlackBerry World with the one from 2813 would solve the problem. Will that ART work with 2888?

    Posted via CB10
    It won't matter as far as I know. People who have the 'old' also have this issue with WA sadly.

    Posted via PassportSQW100-1/10.3.2.2876
    07-11-16 05:22 PM
  14. KenV54's Avatar
    It won't matter as far as I know. People who have the 'old' also have this issue with WA sadly.

    Posted via PassportSQW100-1/10.3.2.2876
    Thanks for the reply. It's strange that some people have the problem and some don't. I wonder if there's any way using Ghost Commander to fix the permissions, although I've looked at that without success.

    Posted via CB10
    07-11-16 06:24 PM
  15. candyd360's Avatar
    Okay.
    Finally Found the Solution.
    Those who have already installed the app, Go to device storage and clear data for the app. Then Follow the steps
    Step1: Open Whatsapp
    Step2: Complete all formalities of verification code. Wait when you get the pop up warning for google play services. (It will come even if you have installed google play by Cobalt)
    Step3: When the error comes for Google Play Services do not press Ok. Instead just press anywhere outside the pop up warning and it will start working.

    Enjoy. Reply with your results.
    yojosefo, tinno, tstrike34 and 3 others like this.
    11-02-16 04:07 AM
  16. rabih2's Avatar
    done, work perfectly
    11-03-16 02:42 AM
  17. joeyjcasilla1's Avatar
    Okay.
    Finally Found the Solution.
    Those who have already installed the app, Go to device storage and clear data for the app. Then Follow the steps
    Step1: Open Whatsapp
    Step2: Complete all formalities of verification code. Wait when you get the pop up warning for google play services. (It will come even if you have installed google play by Cobalt)
    Step3: When the error comes for Google Play Services do not press Ok. Instead just press anywhere outside the pop up warning and it will start working.

    Enjoy. Reply with your results.
    Which whatsapp version ur using? Is it the latest 2.16.310? Did u patched it using cobalts app patcher?

    Posted via CB10
    11-03-16 05:01 AM
  18. rabih2's Avatar
    Which whatsapp version ur using? Is it the latest 2.16.310? Did u patched it using cobalts app patcher?

    Posted via CB10

    mine is 2.16.328 installed from play store working without patching
    11-03-16 05:25 AM
  19. joeyjcasilla1's Avatar
    mine is 2.16.328 installed from play store working without patching
    Cool! Did u get any notice that this.. blah blah blah is app is not supported by ur device etc.. I'm on passport se with Google settings installed

    Posted via CB10
    11-03-16 05:47 AM
  20. rabih2's Avatar
    I'm using passport also...everything working fine
    11-03-16 05:50 AM
  21. MichaNL's Avatar
    Press the back button while it mentions it's loading a backup.
    This will get you passed the load screen.
    11-03-16 06:00 AM
  22. yojosefo's Avatar
    Okay.
    Finally Found the Solution.
    Those who have already installed the app, Go to device storage and clear data for the app. Then Follow the steps
    Step1: Open Whatsapp
    Step2: Complete all formalities of verification code. Wait when you get the pop up warning for google play services. (It will come even if you have installed google play by Cobalt)
    Step3: When the error comes for Google Play Services do not press Ok. Instead just press anywhere outside the pop up warning and it will start working.

    Enjoy. Reply with your results.
    You are a live saver! This did the trick! Was getting annoyed, and whatsapp verification was taking longer and longer, you saved it at the last attempt. Cheers!
    11-04-16 08:21 AM
  23. FRANCIS VITTINI's Avatar
    You're the man!!. Thanks a lot. it worked for me too.

    Thanks!!
    11-04-16 07:23 PM
  24. babugaru1's Avatar
    WhatsApp on Q10 is really laggy. Can't go with Android version
    11-05-16 10:08 AM
  25. joe_that_guy's Avatar
    Okay.
    Finally Found the Solution.
    Those who have already installed the app, Go to device storage and clear data for the app. Then Follow the steps
    Step1: Open Whatsapp
    Step2: Complete all formalities of verification code. Wait when you get the pop up warning for google play services. (It will come even if you have installed google play by Cobalt)
    Step3: When the error comes for Google Play Services do not press Ok. Instead just press anywhere outside the pop up warning and it will start working.

    Enjoy. Reply with your results.
    i swear you some kind of genius....thanks a lot
    clown007_de likes this.
    11-06-16 03:30 PM
45 12

Similar Threads

  1. $250 for the Priv at Verizon?
    By CrackBerry Question in forum Verizon Wireless
    Replies: 6
    Last Post: 03-21-16, 02:45 PM
  2. Why are the installed apps are uninstalled completely?
    By CrackBerry Question in forum Android Apps
    Replies: 2
    Last Post: 03-08-16, 02:58 AM
  3. Priv pictures app takes an age to start
    By presean in forum BlackBerry Priv
    Replies: 5
    Last Post: 03-04-16, 02:27 PM
  4. Does family Mobile from Walmart work with BlackBerry?
    By MarCiano274 in forum Ask a Question
    Replies: 4
    Last Post: 03-04-16, 01:07 PM
  5. Fix for Playbook with completely dead battery
    By hbvideo in forum BlackBerry PlayBook
    Replies: 2
    Last Post: 03-04-16, 12:04 AM
LINK TO POST COPIED TO CLIPBOARD