1. trevorcroft's Avatar
    I am trying to make a shortcut for im > I'm and IM > IM, because I type im a lot but I also say stuff like : IM me that file, referring to instant message...

    In the attached picture you can see my attempts at this, and it fails miserably, now im goes to IM and IM goes to IM.

    This seems like it would be a common thing, does anyone know of a solution?

    IM vs I'm auto correct-img_20160106_164508.png

    Posted via CB10
    01-06-16 05:58 PM
  2. danifulger's Avatar
    Language and introduction. Prediction. Word substitution. Add shortcut . You have two shortcuts of the same type. You could leave an I for I'm and an m for IM.

    Posted on CB10 on Z30, Z 10 10.3.2.2639
    01-06-16 06:16 PM
  3. trevorcroft's Avatar
    Language and introduction. Prediction. Word substitution. Add shortcut . You have two shortcuts of the same type. You could leave an I for I'm and an m for IM.

    Posted on CB10 on Z30, Z 10 10.3.2.2639
    I don't really follow your suggestion of "You could leave an I for I'm and an m for IM.". Would you mind elaborating?


    Posted via CB10
    01-06-16 07:09 PM
  4. FCSC's Avatar
    I = i'm
    M= IM

    Posted via CB10
    01-06-16 09:52 PM
  5. danifulger's Avatar
    I don't really follow your suggestion of "You could leave an I for I'm and an m for IM.". Would you mind elaborating?


    Posted via CB10
    Could you change the stored shortcuts to what is being suggested?

    Posted on CB10 on Z30, Z 10 10.3.2.2639
    01-06-16 11:20 PM
  6. Big_Ern's Avatar
    Leave the shortcut:
    im=I'm
    and create a new shortcut:
    imm=IM

    I did similar so I could type ID without it being converted to I'd. You just type an extra letter when you want IM instead of I'm and it makes it capital for you too so it's clear to the other person

    Posted via CB10
    01-06-16 11:39 PM
  7. BoyTanggol's Avatar
    Leave the shortcut:
    im=I'm
    and create a new shortcut:
    imm=IM

    I did similar so I could type ID without it being converted to I'd. You just type an extra letter when you want IM instead of I'm and it makes it capital for you too so it's clear to the other person

    Posted via CB10
    This is the best solution given to you OP.

    Posted via CB10
    01-07-16 07:00 AM
  8. jafrul's Avatar
    Yup. That's the best way to do a word prediction.
    Like when I type 'ithank' it automatically change to [τ̲̅н̲̅a̲̅и̲̅κ̲̅ ч̲̅o̲̅u̲̅] ヅ with a Smiley.
    Easier to remember too.
    Another example, 'ithanks' becomes {̶̶̲̥̅̊(̥̊​♡̷̬̩̃̊☃τниκч☃♡̷̬̩̃̊)̶̥̲̥̊̅̊}̶ *.

    In other word, I didn't touch the word thank, thanks or thank you.

    Be creative, OP.

    RedBerryan on PassportSQW100-1/10.3.2.2813
    Last edited by jafrul; 01-07-16 at 07:21 PM.
    01-07-16 07:05 AM
  9. BoyTanggol's Avatar
    Yup. That's the best way to do a word prediction.
    Like when I type 'ithank' it automatically change to [τ̲̅н̲̅a̲̅и̲̅κ̲̅ ч̲̅o̲̅u̲̅] ヅ with a Smiley.
    Easier to remember too.
    Another example, 'ithanks' becomes {̶̶̲̥̅̊(̥̊​♡̷̬̩̃̊☃τниκч☃♡̷̬̩̃̊)̶̥̲̥̊̅̊}̶ *.

    In another word, I didn't touch the word thank, thanks or thank you.

    Be creative, OP.

    RedBerryan on PassportSQW100-1/10.3.2.2813
    Yup. You're creative brother. Haha

    Posted via CB10
    01-07-16 08:38 AM
  10. trevorcroft's Avatar
    Leave the shortcut:
    im=I'm
    and create a new shortcut:
    imm=IM

    I did similar so I could type ID without it being converted to I'd. You just type an extra letter when you want IM instead of I'm and it makes it capital for you too so it's clear to the other person

    Posted via CB10
    I like this idea, thank you! Will follow your lead for ID as well as that one comes up often as well.

    Posted via CB10
    01-08-16 01:44 AM
  11. Big_Ern's Avatar
    I like this idea, thank you! Will follow your lead for ID as well as that one comes up often as well.

    Posted via CB10
    You're welcome! Glad to help out

    I do something for "were" and "we're" as I hate when it accidentally changes were into we're
    Remove the were=we're shortcut
    Create new wer=we're
    Create new were=were so that it *always* stays as you type it

    Same for shell and she'll (shell=shell & shel=she'll)

    Same for well and we'll (well=well & wel=we'll)

    Posted via CB10
    01-08-16 08:06 PM
  12. trevorcroft's Avatar
    You're welcome! Glad to help out

    I do something for "were" and "we're" as I hate when it accidentally changes were into we're
    Remove the were=we're shortcut
    Create new wer=we're
    Create new were=were so that it *always* stays as you type it

    Same for shell and she'll (shell=shell & shel=she'll)

    Same for well and we'll (well=well & wel=we'll)

    Posted via CB10
    More great suggestions, thanks! I love this feature of blackberry.

    Posted via CB10
    01-12-16 05:58 PM
  13. Big_Ern's Avatar
    More great suggestions, thanks! I love this feature of blackberry.

    Posted via CB10
    I've learned lots from the crackberry community and always happy to share my own knowledge & tips. Cheers!

    Posted via CB10
    01-13-16 12:43 AM
  14. rthonpm's Avatar
    You're welcome! Glad to help out

    I do something for "were" and "we're" as I hate when it accidentally changes were into we're
    Remove the were=we're shortcut
    Create new wer=we're
    Create new were=were so that it *always* stays as you type it

    Same for shell and she'll (shell=shell & shel=she'll)

    Same for well and we'll (well=well & wel=we'll)

    Posted via CB10
    These were actually built into BBOS devices going back to the very early email only devices like the 957. I was shocked once they were gone in BB10. Luckily I had access to a BB10 device and a little time so I added all of the old contractions back in.

    Posted via CB10
    BerryRipe likes this.
    01-13-16 04:28 AM
  15. CombeMarshal's Avatar
    If you want it to learn the word you are typing as the word you prefer type it in, then when it changes it just swipe left on the keyboard to change it back, it will learn that you prefer that word!

    Posted via CB10
    01-13-16 02:32 PM
  16. Big_Ern's Avatar
    These were actually built into BBOS devices going back to the very early email only devices like the 957. I was shocked once they were gone in BB10. Luckily I had access to a BB10 device and a little time so I added all of the old contractions back in.

    Posted via CB10
    That's why I added those 'autocorrects' into bb10. I loved them in bbos and was really missing them in bb10 as I was quite used to them. I couldn't remember all the others to add them back though, just the few common ones I listed above.


    Posted via CB10
    01-14-16 11:36 PM
  17. Anaik17's Avatar
    I'm not new to CB but don't use it enough to know if I'm in violation of the rules by asking a related question in a previous post. If so, sorry! But I see a pool of knowledgeable people here and no answer elsewhere so here goes:

    My Q10 used to change some typos even though I have the 'show predictions' turned off. *All* typos like 'enogh 'used to change to 'enough' automatically. Now it's just redlined and I have to click on it to get to the corrected word, even when it's the only viable option. What caused this? More importantly, how do I change it back?
    01-15-16 09:36 AM
  18. trevorcroft's Avatar
    I'm not new to CB but don't use it enough to know if I'm in violation of the rules by asking a related question in a previous post. If so, sorry! But I see a pool of knowledgeable people here and no answer elsewhere so here goes:

    My Q10 used to change some typos even though I have the 'show predictions' turned off. *All* typos like 'enogh 'used to change to 'enough' automatically. Now it's just redlined and I have to click on it to get to the corrected word, even when it's the only viable option. What caused this? More importantly, how do I change it back?
    Turn "auto-correct with space bar" to on. Its in settings under language and input / predictions and corrections.

    Posted via CB10
    01-25-16 11:27 PM
  19. Anaik17's Avatar
    Turn "auto-correct with space bar" to on. Its in settings under language and input / predictions and corrections.

    Posted via CB10
    It's already on, I have never changed that since I got the phone...
    Thanks for trying!
    01-30-16 03:32 AM

Similar Threads

  1. PRIV: Task w Due Date vs Calendar
    By JC Crackberry in forum Android Apps
    Replies: 1
    Last Post: 02-09-17, 05:19 PM
  2. Replies: 18
    Last Post: 01-16-16, 11:10 AM
  3. How do I stop bluetooth AUTO connect?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 01-07-16, 10:23 AM
  4. Gmail auto-reply bug
    By wakandan in forum BlackBerry Passport
    Replies: 1
    Last Post: 01-06-16, 11:45 AM
  5. android auto?
    By ezapper2 in forum Ask a Question
    Replies: 1
    Last Post: 01-04-16, 03:19 PM
LINK TO POST COPIED TO CLIPBOARD