1. HanzWurst's Avatar
    Hallo everyone,

    I seem to have an issue with the android runtime on my q10.
    OS versoin is 10.3.2.2836.

    The problem is, that when I install an apk via snap (2.0.0.2) or directly from SD card, I get the error "Unable to install this app". (Other sources are allowed of course. Those particular apps have been installed and running before.)

    During my research I read somewhere it would reset the runtime when installing an android port from Blackberry World. Doing so, instead gives the error:"An error occurred processing your request". (Runtime 10.3.2.371 is the latest version from BB World)

    The previously installed android apps work fine so far. (But snap can not find some android apps it did before)

    I also read from a thread, that setting back the phone will not solve the problem, so I skipt this option.



    How can I solve this problem? Is there a way to wipe the runtime from the phone and do a fresh install?

    Help appreciated!!!
    Last edited by HanzWurst; 09-04-16 at 02:31 PM.
    09-04-16 02:15 PM
  2. BB-JAM215's Avatar
    I uninstalled Snap a while ago after I had problems with it, and after reading reports that it wasn't compatible withn10.3.2. Around that time there was a rumour that the developer was working on a fix, but I haven't seen any news about Snap since.
    09-04-16 03:01 PM
  3. HanzWurst's Avatar
    Thanks for the quick reply.

    I do not think snap is causing this. As apk files pushed to SD neither install.
    Anyhow I deleted snap. Shut down the phone. Pulled the battery a few seconds and rebooted.
    Problem remains.
    09-04-16 04:03 PM
  4. BB-JAM215's Avatar
    Have a look at what others have said about their problems with Snap:
    http://forums.crackberry.com/blackbe...-snap-1070609/

    As mentioned here Snap has not been updated since 2015, so you might want to look at Coblat's software: http://forums.crackberry.com/android...g-page-965257/
    09-04-16 04:22 PM
  5. HanzWurst's Avatar
    Have a look at what others have said about their problems with Snap:
    http://forums.crackberry.com/blackbe...-snap-1070609/

    As mentioned here Snap has not been updated since 2015, so you might want to look at Coblat's software: http://forums.crackberry.com/android...g-page-965257/
    It is definitly not snap that is causing the problem. As I wrote in previous post, I deleted snap but still can not install apks from SD card.
    09-04-16 05:41 PM
  6. HanzWurst's Avatar
    It is definitly not snap that is causing the problem. As I wrote in previous post, I deleted snap but still unable to install apks from SD card.
    09-04-16 05:46 PM
  7. HanzWurst's Avatar
    I played around a little but the problem remains.

    Following steps have been done:

    I downloded a previous version of the runtime including shell from this thread: http://forums.crackberry.com/bb10-le...please-986137/

    Pushed both bar files (androis and shell) to phone via sachesi. => Runtime completely malfunctioning. Already installed android apps won't launch.

    But anyhow the idea was to trigger a new installation of the runtime via update from BB world. Doing so did bring the installed android apps back to work.
    But installing new ones is still not possible.

    Can not install any android app.

    Does someone have a clue?
    09-04-16 05:56 PM
  8. HanzWurst's Avatar
    Sorry for double posting. I did not realize, that it takes several minutes until the posts show up.
    09-04-16 06:12 PM
  9. BB-JAM215's Avatar
    Your page should automatically refresh after posting, but sometimes it helps to do a manual refresh.

    So then, what method are you using to install Android APKs? Is that the problem?
    09-04-16 10:46 PM
  10. HanzWurst's Avatar
    See post 7.
    (This took over an hour to show up. I think my post are under review since I am new to this forum.)
    09-05-16 02:17 AM
  11. The_Dark_Knight_Forever's Avatar
    Snap has just been fixed! Check out www.redlightoflove.com. It's been updated to version 3.0 (out of Beta). I've confirmed this with the app developer.

    Posted via CB10 with my awesome  Z30 STA100-5/10.3.2.2876 on T-Mobile USA who keeps disrupting & improving the wireless industry.
    09-05-16 11:55 PM
  12. HanzWurst's Avatar
    sorry guys,

    but seems like this is running a little bit of topic. This is not an issue of snap. (Though I mentioned snap in the first post)

    I am unable to install any android app. Even though the apps have been running on the phone before. (So updating is impossible)
    When I put an apk from PC to SD card and try to install (this is just a tap on the apk, can't do much wrong there), I always get the error: "Unable to install this app"
    When I try to install an android port from BB world I get:"An error occurred processing your request"


    Ergo: Android runtime is faulty.


    Tried some fixes myself. See post 7. Without success.

    The idea now is to reset the whole OS. Maybe do a fresh install of the OS (flashing it with sachesi???). I read, that this can be done with autoloaders.
    Has someone links, where to get them. Are there risks to brick the phone?
    09-07-16 04:18 AM
  13. ppeters914's Avatar
    The idea now is to reset the whole OS. Maybe do a fresh install of the OS (flashing it with sachesi???). I read, that this can be done with autoloaders.
    Has someone links, where to get them. Are there risks to brick the phone?
    You're getting confused....at least if seems that way from your posts

    First, you say it isn't a Snap problem, and Snap is uninstalled. Then how are you installing apps? You can't just click on them to install.

    Reinstalling clean definitely would not hurt. Use an autoloader for your device. I recommend 10.3.2.2813, which doesn't have the Android uninstall issue.

    Sachesi is a non-destructive destructive reload.

    All this has been explained multiple times in multiple threads.


    Posted via CB10 / AT&T /Z10 STL100-3 /10.3.2.2813
    09-07-16 04:41 PM
  14. HanzWurst's Avatar

    Then how are you installing apps? You can't just click on them to install.




    Posted via CB10 / AT&T /Z10 STL100-3 /10.3.2.2813
    Nice to be able to teach experienced people some new tricks here.

    You can download an APK from any Playstore clone of your choice (and trust) from the web to your PC. Put that on your SD and then navigate to the APK in the file manager. Fire the installation by a simple tap on the APK.
    (You can also extract APKs from android phones. On the android navigate (ES file explorer recommended) to /data/app/ and copy the apk to where you want it. I usually push them via bluetooth directly to my Q10.)


    I will report about the resetting of the OS, after found the time again to take care about it.
    09-09-16 03:42 AM
  15. BB-JAM215's Avatar
    This may be what you need:
    http://forums.crackberry.com/android...dvice-1077271/

    Just remember that this link only works with the BB10 browser (don't use the BlackBerry World app).
    09-10-16 10:41 PM
  16. hooligan66's Avatar
    I've been using one market instead,no side loading required

    Posted via CB10
    09-10-16 11:21 PM
  17. HanzWurst's Avatar
    This may be what you need:
    http://forums.crackberry.com/android...dvice-1077271/

    Just remember that this link only works with the BB10 browser (don't use the BlackBerry World app).
    Runtime was on latest version, so this did not help. Thanks anyway.
    09-14-16 03:24 PM
  18. HanzWurst's Avatar
    SOLVED.

    Did a reload of the OS via autoloader downloaded from here:
    https://supportforums.blackberry.com...r/td-p/2466747

    Did a restore of previously saved backup afterwards.

    Runs like a charm now.
    09-14-16 03:27 PM

Similar Threads

  1. Video Codecs on PlayBook
    By bb10adopter111 in forum BlackBerry PlayBook
    Replies: 3
    Last Post: 09-13-16, 02:11 AM
  2. How to install Viber on BlackBerry 10?
    By veerendar naidu in forum Android Apps (Amazon Store & APK Files)
    Replies: 1
    Last Post: 09-06-16, 01:42 PM
  3. Example Title on Blackberry Z30 - American Pride
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 09-06-16, 01:20 PM
  4. My email is not being pushed to my device, can you fix it?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-06-16, 12:55 PM
  5. How to set alarm for one future time/day - Priv
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-06-16, 12:44 PM
LINK TO POST COPIED TO CLIPBOARD