1. RLTurn77's Avatar
    I originally posted in the Z30 forum, but thought this might be more appropriate here as I can't figure out how to get the two old devices that I wiped and are on the welcome screen to not show up in Link under my BBID. I'm def not signed in. Does someone else have to sign in to device? Anyone else have old devices when logging in to BlackBerry Link?

    So, I shattered my Z30 screen and am using my previous Z10, but just logged in to BlackBerry Link and it showed all of my devices even the broken Z10 and now Z30. I actually did a device wipe/factory reset on these devices, but they are still showing as associated with my BBID.

    After turning on from the wipe it asks to sign in with a BBID which I did not and then the device goes back to the welcome screen.

    Funny thing is I logged on to BlackBerry Protect for the first time and my old Verizon Z30 showed up and my sister has been using that for a few months now with her BBID. Not sure if it would actually let me do anything with it, but was tempted to prank her with a note lol. Any input would help. Thanks!

    Posted via CB10
    Posted via CB10
    12-31-14 05:37 PM
  2. Alain_A's Avatar
    when you go to link there is a button that says to remove device. Click on each then remove. The remove device button is there when you connect a phone to it. Once the phone is connected click on the device


    geez misread....bbid out of a device====security wipe
    12-31-14 05:45 PM
  3. RLTurn77's Avatar
    when you go to link there is a button that says to remove device. Click on each then remove. The remove device button is there when you connect a phone to it. Once the phone is connected click on the device


    geez misread....bbid out of a device====security wipe
    Sorry for the confusing post, but yeah I've done a security wipe and when I log in to BlackBerry Link two devices that were wiped and no longer working right are still showing. It's weird because on the devices it asks to login on the welcome screen so I should be logged out? Hmm???

    Posted via CB10
    12-31-14 06:03 PM
  4. Alain_A's Avatar
    Sorry for the confusing post, but yeah I've done a security wipe and when I log in to BlackBerry Link two devices that were wiped and no longer working right are still showing. It's weird because on the devices it asks to login on the welcome screen so I should be logged out? Hmm???

    Posted via CB10
    in link there is a remove device button or forgot about this device
    12-31-14 06:51 PM
  5. RLTurn77's Avatar
    OK so I did a search and nobody really has an answer; just a few suggestions.

    I'm currently in BlackBerry Protect to remove the devices not in use and that have been wiped as that was posted as a possible solution when I searched.

    It's taking quite a while in Protect to remove one device so not sure how this will go, but we shall see. Maybe this will help others if it works. When logging in to Link I see a list of devices that have been wiped and no longer in use.

    It was also noted on my search some were annoyed that returned devices that have been wiped still show up as associated with their BBID when logging in to Link. Protect is still trying to remove an old device that has been since wiped and I'm getting a bit inpatient lol. Guess I'll give it some more time!

    Posted via CB10
    12-31-14 06:55 PM
  6. RLTurn77's Avatar
    in link there is a remove device button or forgot about this device
    It is when I sign back in with my BBID, I'm given a list of devices to refresh that are associated with my BBID to manage.

    Protect isn't helping much either as it won't let me remove an old Verizon Z30 that is now in use on my sister's number with her ID!

    Posted via CB10
    12-31-14 07:11 PM
  7. Alain_A's Avatar
    It is when I sign back in with my BBID, I'm given a list of devices to refresh that are associated with my BBID to manage.

    Protect isn't helping much either as it won't let me remove an old Verizon Z30 that is now in use on my sister's number with her ID!

    Posted via CB10
    huh, maybe uninstall link from puter and re-install it, I gather you have a new BB, then plug the new device to re-install link.
    That is what I did then when I fired up link I could see my old device and I click on the remove device button
    12-31-14 07:25 PM
  8. RLTurn77's Avatar
    huh, maybe uninstall link from puter and re-install it, I gather you have a new BB, then plug the new device to re-install link.
    That is what I did then when I fired up link I could see my old device and I click on the remove device button
    Thanks for trying to help out! I actually just received a new device today and installed BlackBerry Link fresh. When I was done moving some files onto the BB, I simply hit remove device for the new one.

    The issue is, if you notice on Link you have the option to sign in with your BBID. This is not necessary, but I did just to see if the devices were up to date and was shocked at the list of devices available. Two I still have, one with a broken screen and I just did another security wipe on them even though I was not signed in to the devices with my BBID anyway.

    I did a search and saw a post about deleting from the protect website. Unfortunately, this kept freezing and on top of that my old Z30 that was passed on to my sister was there for me to manage as well. She has her own number and is signed in on her BBID. I think I'm going to just give up for now, but would be nice if the devices I'm currently using with my BBID were the devices showing and none of the rest.

    I read a post about someone who had to return multiple devices, obviously doing a wipe in between, and was frustrated that they were showing as well. Could not find a resolution, but would be open to any more suggestions. Thanks for the feedback.

    Posted via CB10
    12-31-14 08:32 PM
  9. Alain_A's Avatar
    you're welcome
    12-31-14 10:01 PM
  10. anon5860953's Avatar
    ... I read a post about someone who had to return multiple devices, obviously doing a wipe in between, and was frustrated that they were showing as well. Could not find a resolution, but would be open to any more suggestions. ...
    I'm having this same situation.

    I returned a Z10 to Verizon about a year or so ago; I signed out of BBID on the device and performed a security wipe prior to returning. Also, If I remember correctly, I also removed it from my Blackberry Protect devices since it's not listed there now. Every time I sign into Blackberry Link, my old device is listed again. I click the "Remove Device" and it gets removed from the list. I sign out and sign back in to BBID, and the old device reappears. Link and Protect correctly list my currently owned Z10 device. I've just been ignoring the orphaned listed device, but it sure would be nice to have Link only display device(s) that I actually have.

    On a happier note, I just received my new Z30 that I'm upgrading from a Z10.
    02-23-15 09:33 AM

Similar Threads

  1. $$ for a developer to create an app for BB10
    By Honkii in forum Developers Lounge
    Replies: 12
    Last Post: 02-26-15, 07:11 PM
  2. Just got a z30 in addition to my passport.
    By dmateo in forum BlackBerry Z30
    Replies: 20
    Last Post: 01-16-15, 08:21 PM
  3. How do I transfer pictures from a Z10 smartphone to computer?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 01-01-15, 01:50 PM
  4. Replies: 6
    Last Post: 01-01-15, 02:10 AM
  5. How do you RENAME a bookmark?
    By jmac0408 in forum BlackBerry PlayBook
    Replies: 6
    Last Post: 12-31-14, 08:17 PM
LINK TO POST COPIED TO CLIPBOARD