1. jedwards73's Avatar
    My sent messages for my work EAS (Exchange 2010) account, where still showing up in the hub despite the fact I turned off "Show Sent Messages" in Display and Actions in BlackBerry Hub Settings. Emails I sent using my gmail (imap) were (correctly) not displaying in the Hub. However, email sent using the Exchange Active Sync account were still showing up and cluttering my hub. My belief is I sent the emails, I know what they say, I don't need to see them again. If you look under the EAS account settings you can choose which folders to Sync, however "Sent Items" is grayed out and you can't uncheck it.

    I got it fixed today and I'm so happy I thought I would share.

    1. Turned on "Show Sent Messages".
    2. Deleted my EAS account.
    3. Turned off "Show Sent Messages".
    4. Added back my EAS account.



    Now if I can just get my Z10 to automatically connect to my Ford Sync, the first time and every time. I would be ecstatic. And speaking of BT, I need to be able to turn up the phone's main volume when connected to BT. Time to start searching for Bluetooth in the forums.

    Edit: I got the BT connection problem fixed by deleting both my Z10 & 9850 profile from Sync and then re-adding the Z10.
    Last edited by jedwards73; 04-05-13 at 12:18 PM. Reason: added update on BT
    04-04-13 03:49 PM
  2. Brett Callegari's Avatar
    Thank you
    This worked perfectly on my activesync account.
    04-05-13 12:08 PM
  3. kill_9's Avatar
    You could also organize emails by conversations. The need for delete an account, disable Sent Items synchronization, and adding the account again is counterintuitive.

    Posted via CB10 from the BlackBerry Z10
    04-06-13 05:56 AM
  4. jedwards73's Avatar
    I don't keep any emails in my inbox. They all get filed away in sub folders, which I don't sync. So if I grouped by conversation, all I would see is a bunch of sent items.

    Your right it is counterintuitive to have to go through all those steps to fix a bug. It should have worked right the first time, and then I wouldn't have to do anything.

    BTW, when I disabled "Show Sent Messages" for my boss's Z10. It worked perfectly. So it isn't an all emcompassing bug. But given the threads I have seen at least a handful of people have run into it.
    04-08-13 10:46 AM
  5. 04Hokie's Avatar
    1. Turned on "Show Sent Messages".
    I do not have a z10, but my boss does. He asked me to help him fix this problem with his phone. This looks like a great solution, but I'm apparently not smart enough to find the "Show Sent Messages" toggle. Please advise.

    Thank you!
    04-29-13 09:15 AM
  6. jedwards73's Avatar
    I do not have a z10, but my boss does. He asked me to help him fix this problem with his phone. This looks like a great solution, but I'm apparently not smart enough to find the "Show Sent Messages" toggle. Please advise.

    Thank you!
    From the Hub, click on the overflow button (3 dots), then Display and Actions. There you will find "Show Sent Messages".
    04Hokie likes this.
    04-29-13 09:43 AM
  7. CADGuru's Avatar
    Here is what worked for me.
    In Dispaly and Actions, With Show Sent Items already "OFF" I switched to "Single Messages" - waited for it to finish then switched back to "Conversation". Once finished Sent items were no longer displayed.
    05-07-13 01:43 PM
  8. kraems17's Avatar
    My sent messages for my work EAS (Exchange 2010) account, where still showing up in the hub despite the fact I turned off "Show Sent Messages" in Display and Actions in BlackBerry Hub Settings. Emails I sent using my gmail (imap) were (correctly) not displaying in the Hub. However, email sent using the Exchange Active Sync account were still showing up and cluttering my hub. My belief is I sent the emails, I know what they say, I don't need to see them again. If you look under the EAS account settings you can choose which folders to Sync, however "Sent Items" is grayed out and you can't uncheck it.

    I got it fixed today and I'm so happy I thought I would share.

    1. Turned on "Show Sent Messages".
    2. Deleted my EAS account.
    3. Turned off "Show Sent Messages".
    4. Added back my EAS account.



    Now if I can just get my Z10 to automatically connect to my Ford Sync, the first time and every time. I would be ecstatic. And speaking of BT, I need to be able to turn up the phone's main volume when connected to BT. Time to start searching for Bluetooth in the forums.

    Edit: I got the BT connection problem fixed by deleting both my Z10 & 9850 profile from Sync and then re-adding the Z10.
    You are a lifesaver. Thanks. Fixed the sent items bug that was driving me nuts.
    05-08-13 07:00 PM
  9. sin-co's Avatar
    This was very annoying and was making me reconsider my Z10, thank you @jedwards73, you my friend are a lifesaver!
    05-30-13 01:34 PM
  10. legaldeejay's Avatar
    "Here is what worked for me.
    In Dispaly and Actions, With Show Sent Items already "OFF" I switched to "Single Messages" - waited for it to finish then switched back to "Conversation". Once finished Sent items were no longer displayed."

    I just came across this post because I was having the same problem. I already had it set to "Single Messages", switched to "Conversation", then switched back to "Single Messages", and it worked.

    This is an obvious bug which should be fixed.
    emanwis likes this.
    06-12-13 09:49 AM
  11. Y2Kiko's Avatar
    Hi, I want some recomendation to see my sent emails in the Hub from my enterprise account that uses Lotus Traveler.
    Thanks in advice.
    07-10-13 08:39 PM
  12. jedwards73's Avatar
    Hi, I want some recomendation to see my sent emails in the Hub from my enterprise account that uses Lotus Traveler.
    Thanks in advice.
    I don't know anything about Lotus Traveler, but try going to "Settings", then "Accounts", then your enterprise email account, then "Edit Folder Settings". Hopefully you will see a list of folders available to Sync. Check the box next to "Sent Items" if it isn't already.
    07-11-13 08:06 AM
  13. schmikey_393's Avatar
    Thanks for the fix.

    I actually wanted the reverse (sent msgs were not showing when SHOW SENT MESSAGES was set to on), but the fix still worked....

    cheers
    09-10-13 01:29 PM
  14. epfltd's Avatar
    Will this work with gmail
    09-28-13 08:14 AM
  15. jedwards73's Avatar
    Will this work with gmail
    Not sure, but worth a shot to try.
    09-30-13 08:26 AM

Similar Threads

  1. How to fix Network Signal Coverage.
    By ruffhunter in forum General BlackBerry News, Discussion & Rumors
    Replies: 9
    Last Post: 11-03-16, 10:04 PM
  2. How To Block PIN, SMS, MMS Messages
    By chinesecatt in forum BlackBerry OS
    Replies: 144
    Last Post: 10-12-13, 07:52 AM
  3. Camera With Error Message - How To Fix
    By kmaygard in forum BlackBerry Curve Series
    Replies: 6
    Last Post: 07-23-09, 07:59 PM
  4. Contact Birthday spread over 2 days - how to fix it?
    By defcon3 in forum General BlackBerry News, Discussion & Rumors
    Replies: 6
    Last Post: 07-03-09, 11:59 PM
  5. how to delete one of my messages folder
    By FReQ Z in forum BlackBerry Curve Series
    Replies: 1
    Last Post: 12-07-07, 09:38 AM
LINK TO POST COPIED TO CLIPBOARD