02-05-16 07:03 PM
61 123
tools
  1. cbvinh's Avatar
    Looking at Task Manager, it looks like whenever com.amazon.mShop.android starts running, my Z30's System CPU usage spikes, 50%+, and there's huge lag. If I kill it, everything is good. It keeps coming back though...
    11-13-15 06:15 PM
  2. cbvinh's Avatar
    When I loaded the Amazon Store app, it hung to ask if my login was correct and waited for me to click on Continue. I wonder if this little thing, login verification, was causing all my troubles? It couldn't proceed and just started to chew CPU cycles? I clicked on Continue and things are good.
    11-13-15 07:17 PM
  3. weiberry's Avatar
    Looking at Task Manager, it looks like whenever com.amazon.mShop.android starts running, my Z30's System CPU usage spikes, 50%+, and there's huge lag. If I kill it, everything is good. It keeps coming back though...
    Can you enable Parent Control and disable Amazon App Store?
    11-14-15 12:24 AM
  4. weiberry's Avatar
    Well. Battery drainage was back again. I deleted android version of Wechat. I reinstalled BB10 Wechat. I am sure it works this time. Cause I remember the good old day with good battery life before I installed the android Wechat.
    11-14-15 08:17 PM
  5. cbvinh's Avatar
    My problem appears to be solved. When I examined Settings->Accounts->Gmail, my Calendar had a red "not connected"-type error message. I deleted the Gmail account, Delete All (Email, Contacts, Calendar), and re-added it.

    System CPU usage is low again, 2-6%, and practically no battery drain.

    I guess I was wrong about the Amazon apps and the Android Runtime. They're fine.

    The culprit appears to be Accounts that have components disconnected and the System tries really, really hard to reconnect.
    11-16-15 07:58 PM
  6. weiberry's Avatar
    I don't think I ever had that "not connected" type of issues. Today my system CUP usage is high again. One thing is strange: I deleted CrackBerry app in BB World. When I click on it on BB World, it shows "Open". I am not able to either uninstall or to delete it. I can not install the app.

    Really have a love and hate situation for BlackBerry 10 phones.
    11-17-15 06:00 PM
  7. weiberry's Avatar
    My Passport cooled down and system CPU usage seems to be lowered, after tried all the tips listed in different posts. Thank you, guys! Good to have a usable phone back.
    Hopefully I solved the problem now, using Blackberry World Recovery Tool.

    Also, I just got an updated to same BB10 OS from ATT. The file is 3MB. Hope this helps too.
    11-17-15 07:29 PM
  8. rbtg's Avatar
    i fixed mine by sec wipe and start from scratch , i don't have any clue what was causing high drainage ,after so long without any issues and no new apps , now i'm better then before and cpu it's running a little lower.
    11-17-15 07:52 PM
  9. weiberry's Avatar
    High System CPU Usage, 9 PM to 9 AM-img_20151117_192455.png

    During standby my cell is still draining. Hope I attached the screen shot properly this time.

    Posted via CB10
    letrantrung likes this.
    11-17-15 08:26 PM
  10. cbvinh's Avatar
    Wow, that's still a lot of System CPU...

    For me, while idle, the System CPU is < 2%. It's the best I've seen.
    11-17-15 08:35 PM
  11. cbvinh's Avatar
    Okay, I saw the high CPU use again, but it didn't seem to affect performance at all when it happened. Before, there was so much lag.
    11-19-15 02:05 AM
  12. weiberry's Avatar
    I found in CrackBerry another thread. One of the suggestions was to delete Kindle. So I did. The CPU usage dropped immediately!! So glad that I finally fixed the problem. I have Kindle fire. So Kindle app is not a killer for me. Passport with great battery is the greatest phone in the world.
    High System CPU Usage, 9 PM to 9 AM-img_20151119_130033.jpg

    See the screen shot. The right part is after I deleted the Kindle app.
    11-19-15 02:06 PM
  13. cbvinh's Avatar
    I found in CrackBerry another thread. One of the suggestions was to delete Kindle. So I did. The CPU usage dropped immediately!! So glad that I finally fixed the problem. I have Kindle fire. So Kindle app is not a killer for me. Passport with great battery is the greatest phone in the world.
    Click image for larger version. 

Name:	IMG_20151119_130033.jpg 
Views:	442 
Size:	96.5 KB 
ID:	381278

    See the screen shot. The right part is after I deleted the Kindle app.
    I've never had the Kindle app...
    11-19-15 04:41 PM
  14. weiberry's Avatar
    High System CPU Usage, 9 PM to 9 AM-img_20151120_063142.png
    High System CPU Usage, 9 PM to 9 AM-img_20151120_063150.png

    How about this? ;-) This phone is a beast.

    Posted via CB10
    11-20-15 07:37 AM
  15. cbvinh's Avatar
    Click image for larger version. 

Name:	IMG_20151120_063142.png 
Views:	388 
Size:	92.1 KB 
ID:	381340
    Click image for larger version. 

Name:	IMG_20151120_063150.png 
Views:	389 
Size:	74.5 KB 
ID:	381341

    How about this? ;-) This phone is a beast.

    Posted via CB10
    This is pretty much what mine looks like too, though on a Z30. Idle sips so little power, it's amazing! I'm hoping no more big drains again...
    11-20-15 01:34 PM
  16. Omnitech's Avatar
    The culprit appears to be Accounts that have components disconnected and the System tries really, really hard to reconnect.

    Well-known issue.

    However battery drain seems to be really problematic on 10.3.2 OS builds in general, in my experience.

    Also remember that if you're having a problem with Android apps, you should try a cold boot, which resets the Android runtime. The regular restart does not.

    You can do that by fully powering down, waiting until screen goes black and all logos go off and then about another minute. Then power the phone on again.
    11-23-15 06:34 PM
  17. cbvinh's Avatar
    Well-known issue.

    However battery drain seems to be really problematic on 10.3.2 OS builds in general, in my experience.

    Also remember that if you're having a problem with Android apps, you should try a cold boot, which resets the Android runtime. The regular restart does not.

    You can do that by fully powering down, waiting until screen goes black and all logos go off and then about another minute. Then power the phone on again.
    Thanks. I'll give this a try as well. So far, it seems like the reconnect with the Gmail account seems to be holding, and staying away from Bedside mode seems to have helped too (the drains have been overnight with Beside mode on).
    11-23-15 06:45 PM
  18. Omnitech's Avatar
    Thanks. I'll give this a try as well. So far, it seems like the reconnect with the Gmail account seems to be holding, and staying away from Bedside mode seems to have helped too (the drains have been overnight with Beside mode on).
    I used to really like bedside mode (but only when plugged-in, had no interest in having a dead battery in the morning), but then I decided that I really wasn't excited about leaving the display backlight running for ~8 hrs every night either, 7.9 hours of which I probably wasn't looking at it.

    BB10 is really bad about getting wedged in various ways and not giving any notice whatsoever to the user about what is going on, the only way people figure out there is a problem is the device ends up burning hot or the battery goes dead in 3 hours. Very frustrating.
    11-23-15 07:01 PM
  19. cbvinh's Avatar
    I used to really like bedside mode (but only when plugged-in, had no interest in having a dead battery in the morning), but then I decided that I really wasn't excited about leaving the display backlight running for ~8 hrs every night either, 7.9 hours of which I probably wasn't looking at it.

    BB10 is really bad about getting wedged in various ways and not giving any notice whatsoever to the user about what is going on, the only way people figure out there is a problem is the device ends up burning hot or the battery goes dead in 3 hours. Very frustrating.
    My issue with Bedside mode lately is that it doesn't seem to prevent the battery drains. (I was kind of expecting it to go into a lower power state, but it doesn't seem to.) I usually have the phone plugged in and press the power button to shut off the display, but if I didn't, I figured the mostly black AMOLED would use very little power.

    Oh, and exiting Bedside mode doesn't seem consistent, as I sometimes find my phone still in Bedside mode after exiting.

    Yeah, I wish the System CPU usage could be broken down further.
    11-23-15 08:35 PM
  20. Omnitech's Avatar
    Yeah but beyond the stats in device monitor that you have to go looking for, I think for important things like that there should be a popup notification or something like that. BB10 is very bad about not giving technical feedback that way. (A lot of people may not want to be bothered, but as the techie sort I want as much info as possible about things going on "invisibly"..)
    11-23-15 09:46 PM
  21. Douken's Avatar
    I think you guys have it easy.


    High System CPU Usage, 9 PM to 9 AM-img_20160108_222201.png

    Check out GTR Lifestyle at C001247FA
    01-09-16 01:26 AM
  22. ZeroBarrier's Avatar
    I think you guys have it easy.


    Click image for larger version. 

Name:	IMG_20160108_222201.png 
Views:	501 
Size:	80.0 KB 
ID:	387071

    Check out GTR Lifestyle at C001247FA
    Do you have a complaint? Your system shows very little CPU usage, so I don't understand why you're posting that picture.

    Stop going off of 48 hour information, the vast majority of you can't read the information given in the 48 hour format properly and freak out for no reason other than big numbers.

    Posted via CB10
    01-09-16 02:23 PM
  23. cbvinh's Avatar
    The massive CPU drain happened again yesterday using the latest OS Version 10.3.2.2876. I went to Settings and tried to go to Accounts to check the Calendar sync, which was the culprit last time. Accounts would ghost for a bit as if it was loading, but it would go back to normal, not switching to the Accounts options. Something in Accounts is screwed up. I ended up having to Restart.
    01-18-16 02:35 AM
  24. R3d13's Avatar
    I have a similar issue and created a thread in the Passport section a while back. My battery drains almost entirely overnight, but only when I turn Data Services OFF. No apps or services show any usage other than "System".

    FYI, depending on your settings, turning Beside Mode ON can turn Battery Saving mode ON as well, which in turn can disable wireless connections. This would disable data services, and in my case at least, cause the battery drain / high CPU usage.
    01-18-16 07:47 AM
  25. cbvinh's Avatar
    I have a similar issue and created a thread in the Passport section a while back. My battery drains almost entirely overnight, but only when I turn Data Services OFF. No apps or services show any usage other than "System".

    FYI, depending on your settings, turning Beside Mode ON can turn Battery Saving mode ON as well, which in turn can disable wireless connections. This would disable data services, and in my case at least, cause the battery drain / high CPU usage.
    The drains I saw happened in both Beside and non-Beside Mode and also happened during the day as well. The only commonality I've observed is connections to Contacts or Calendar were listed as not connected. The most recent occurrence made the Accounts options in Settings not even accessible. And yes, high CPU was all in System.
    01-18-16 01:25 PM
61 123

Similar Threads

  1. Replies: 6
    Last Post: 10-22-17, 08:36 AM
  2. Where to get technical support?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 11-01-15, 11:27 AM
  3. Replies: 6
    Last Post: 11-01-15, 07:55 AM
  4. How do you add birthdays to your calendar?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 11-01-15, 05:04 AM
  5. Why didn't they add force touch to Priv?
    By bap3221 in forum BlackBerry Priv
    Replies: 15
    Last Post: 10-31-15, 02:41 PM
LINK TO POST COPIED TO CLIPBOARD