1. anon(10605386)'s Avatar
    My last update attempts are constantly failing due to "There was a problem while parsing the package". Anyone any helpful advise?

    Thanks a lot
    05-14-19 03:09 PM
  2. Bla1ze's Avatar
    - Is it saving as an APK file? If not, change the extension.
    - Are you downloading a compatible version? Common error if the app isn't supported is the error you're seeing.
    05-14-19 03:53 PM
  3. anon(10605386)'s Avatar
    First I tried to it the usual way (same more than 2 years): I downloaded the complete Signal apk from the Signal.org, then ran the file. But that doesn't work anymore ("Unable to install the app").
    Then I went to Hub notification ("Signal update - A new version of Signal is available, tap to update"), tapped it, and got "Parse error - There was a problem while parsing the package".
    05-14-19 04:19 PM
  4. Bla1ze's Avatar
    First I tried to it the usual way (same more than 2 years): I downloaded the complete Signal apk from the Signal.org, then ran the file. But that doesn't work anymore ("Unable to install the app").
    Then I went to Hub notification ("Signal update - A new version of Signal is available, tap to update"), tapped it, and got "Parse error - There was a problem while parsing the package".
    Latest build (4.39.4) notes Android 4.4 and up. BlackBerry 10 is stuck on 4.3. So seemingly as suspected, no longer supported. 4.36.2 was the last build to use anything lower.. Android 4.0+, so seems you might be stuck there.
    05-14-19 04:48 PM
  5. brookie229's Avatar
    Bye, bye Signal. Another messaging app goes by the wayside on BB10.
    05-14-19 04:51 PM
  6. anon(10605386)'s Avatar
    OMG, therefore But to be honest, despite of the lack of the updates, it still works flawlessly
    05-14-19 05:03 PM
  7. anon(10605386)'s Avatar
    By the way, thanks for the replies
    05-14-19 05:04 PM
  8. Bla1ze's Avatar
    By the way, thanks for the replies
    Glad to help!
    anon(10605386) likes this.
    05-14-19 05:56 PM
  9. dreray's Avatar
    When I try to update it says 'this device not compatible with this version" if anyone knows how I can update and keep my signal private messenger please let me know!!! Say my version will expire in 7 days.
    05-15-19 05:21 AM
  10. Bla1ze's Avatar
    When I try to update it says 'this device not compatible with this version" if anyone knows how I can update and keep my signal private messenger please let me know!!! Say my version will expire in 7 days.
    You don't. As noted in earlier posts, if you're using it on BlackBerry 10, the Android runtime is too old now and you're stuck using an older version. Signal dropped support for anything 4.3 and under.
    05-15-19 02:50 PM
  11. dreray's Avatar
    I don't mind using an older version of the app. I just wondering if I will still be able to use it. On my page of messages there's a banner that say" I got 7 days bfor this version expire". Hope I can still use old version on bb10 after that deadline
    05-15-19 03:13 PM
  12. Bla1ze's Avatar
    I don't mind using an older version of the app. I just wondering if I will still be able to use it. On my page of messages there's a banner that say" I got 7 days bfor this version expire". Hope I can still use old version on bb10 after that deadline
    Yeah, I'm not sure about that. Have never been to a point where a version expired to say if that's just a warning or if the app will fully stop working. This is the only thing I can find - https://support.signal.org/hc/en-us/...istration-Lock
    05-15-19 03:35 PM
  13. dreray's Avatar
    Thanks. Hope this will work. Love my BlackBerry but if the signal app won't run anymore am going to have to look for alternative.
    05-16-19 11:00 PM

Similar Threads

  1. PRIV: Booting and Heating Problems after buttons replacement?
    By normalblackberryprivuser in forum BlackBerry Priv
    Replies: 2
    Last Post: 05-18-19, 01:19 AM
  2. WhatsApp is having security concerns at the moment!
    By DrEd14 in forum General BBM Chat
    Replies: 66
    Last Post: 05-16-19, 04:34 PM
  3. How to use the BlackBerry Hub+ Calendar 'Join Now' feature
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 05-14-19, 12:22 PM
  4. Update android security patch
    By KenCrook in forum BlackBerry KEYone
    Replies: 4
    Last Post: 05-14-19, 06:27 AM
  5. Slack update no send button
    By bendiep1991 in forum BlackBerry KEY2
    Replies: 2
    Last Post: 05-13-19, 11:08 PM
LINK TO POST COPIED TO CLIPBOARD