1. adrianocolvero's Avatar
    Hello everyone, how are you all going?

    So, i update my beloved Z30 to the latest 10.3.3.2205, everything seems to be working ok aside from battery juice drecreasing faster and a pretty annoying bug...

    The entire UI feels a lot slower than it should be, menu transition effects and opening/closing apps animations got terribly laggy! I did the installation using autoloader file 3 times, same results.

    I noticed it starts running fast and free of lags but after like 1 or 2 minutes powered on the problem starts, seems like it could be related to some OS app that loads after boot.

    Anyone else getting this issue?
    Theres any workaround or fix for this please?

    Best regards, thank you all for help
    07-12-17 06:51 PM
  2. Invictus0's Avatar
    Are you running any Android apps on your device? If so open them and then close them through Device monitor and see if that fixes the issue.
    07-12-17 11:08 PM
  3. scrannel's Avatar
    You might want to give it a few days to "settle in". I update two Z30s OTA w/o issue.
    07-13-17 08:35 AM
  4. adrianocolvero's Avatar
    Are you running any Android apps on your device? If so open them and then close them through Device monitor and see if that fixes the issue.
    It happens before i install any apk, clean installation.
    07-13-17 06:48 PM
  5. adrianocolvero's Avatar
    You might want to give it a few days to "settle in". I update two Z30s OTA w/o issue.
    I waited 1 week first time, unfortunatelly still lagging on menu transitions, it's so annoying, makes my phone slow and not enjoyable to use. I have a Z10 too, but in it's case everything is working fine after update.
    07-13-17 06:50 PM
  6. scrannel's Avatar
    I waited 1 week first time, unfortunatelly still lagging on menu transitions, it's so annoying, makes my phone slow and not enjoyable to use. I have a Z10 too, but in it's case everything is working fine after update.
    My Shop BBerry Z10 would only update to .2163.
    07-13-17 07:57 PM

Similar Threads

  1. Using SIM card adapter with Z30
    By markmall in forum BlackBerry Z30
    Replies: 13
    Last Post: 07-29-17, 07:04 PM
  2. Keyone HD voice calling HELP
    By joseph11204 in forum BlackBerry KEYone
    Replies: 1
    Last Post: 07-12-17, 08:27 PM
  3. Replies: 2
    Last Post: 07-12-17, 04:16 PM
  4. Priv slow while using Google Maps
    By tulitig8r in forum BlackBerry Priv
    Replies: 2
    Last Post: 07-12-17, 11:44 AM
  5. Save 50% on IPVanish VPN while you help save net neutrality
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 07-12-17, 09:50 AM
LINK TO POST COPIED TO CLIPBOARD