1. vaibhav_pawar's Avatar
    Anyone knows why right cord of headphone is not working.. cord is brand new.. I restarted mobile but still problem is there...

    I am frustrated bcoz can't live without music.

    Is it phone's hardware problem or OS bug after update.?

    Thanks.

    Posted via CB10
    06-02-14 08:29 AM
  2. DaFoxGrey's Avatar
    Try the headphones in another device or radio to make sure both channels are working. Headphone cords can get damaged easily, and if one side breaks you loose audio on that side.

    Make sure the headphone jack is fully plugged into the BB10 device, it is common for the plug to go in about 2/3's of the way and seem like it has bottomed out. This is due to an extra "click" inside of the headphone jack socket that may be used for the devices FM radio that requires the headphone cord as an antenna. Just use a bit more force in pushing the jack into the socket.

    Make sure the music you have saved to the BlackBerry is in stereo and not mono.
    06-02-14 08:39 AM
  3. jaydee5799's Avatar
    Do the headphones work somewhere else? Or is it the headphones themselves that are bad?
    06-02-14 08:39 AM
  4. techtechnique's Avatar
    I had the exact same problem. I tested a number of pairs of earphones and after rebooting the phone, I was about to arrange a warranty repair when I pulled the battery.
    This fixed it and it's never happened since.


    Posted via CB10
    06-02-14 08:48 AM
  5. vaibhav_pawar's Avatar
    I had the exact same problem. I tested a number of pairs of earphones and after rebooting the phone, I was about to arrange a warranty repair when I pulled the battery.
    This fixed it and it's never happened since.


    Posted via CB10
    Thanks for reply.

    What u did for rebooting and have u given it to BlackBerry store for servicing.


    Posted via CB10
    06-02-14 11:19 AM
  6. techtechnique's Avatar
    All I did was pull the battery without shutting the phone down beforehand, left it out for a couple of minutes then put it back in.
    Once booted up, the headphone issue was gone.
    No, I didn't take it in for repair.

    Posted via CB10
    06-02-14 12:16 PM
  7. 0rji's Avatar
    Please I'm having the same issue with my z30 and the battery cannot be removed. What do I do?

    Posted via CB10
    08-16-14 10:35 AM
  8. assilva's Avatar
    I had this and ended up cleaning lint and dirt out of the headphone jack. A little compressed air.

    Posted via CB10
    08-16-14 06:49 PM
  9. gariac's Avatar
    If the headset is new, it may not be compatible with BlackBerry.

    I've gone wireless. Actually less hassles unless you count charging.


    Posted via CB10
    08-16-14 08:09 PM

Similar Threads

  1. Blackberry World not working
    By Shashank Ajmera in forum BlackBerry World
    Replies: 9
    Last Post: 07-28-14, 10:12 PM
  2. "Save Message" is not available in OS10. What a pity!
    By tinbilly in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 06-02-14, 07:26 AM
LINK TO POST COPIED TO CLIPBOARD