1. piflintstone's Avatar
    I search the forums for my isses but found no thread that had the same problem - similiar yes (with no solution) but not the same.

    I recently got a Q5 for my wife for testing pruposes (shes using a Photon Q currently and needs a keyboard). I am quite adapt with Android and iOS, already programmed some small apps for android...so no complete noob.

    However, the woes I ran into on this little blackberry are starting to annoy me to a degree that by the end of the day I will have smashed the little bugger at the wall.

    Problem: I have set up my wifes gmail acount, contacts work, calendar works, gmail works as far as to receive mails and to send mails - and thats about it. I can NOT delete mails nor will a read email reflect its status change on gmail.
    So, if I delete a message or read it, it will be gone or read on the BB, but gmail still shows it diddely-fine as new email. Manually refreshing on the BB does not help, I already set the sync cycle to 5 minutes and it wont do a thing.

    On top of that I can NOT tick the damn "Trash" folder to have it synced - its just greyed out.

    I have so far re-setup her email acount 15-20 times, completely reset the BB 2 times and reinstalled the latest OS on it, I also have checked gmail IMAP/Label settings - everything is just the way it should be. I even unticked all the imap folders to even show - only the ones necessary without custom folders are shown.

    God this is terribly annoying and I have not the slightest idea how to fix this. Any help would be highly appreciated!

    Thanks.
    Droidophobe likes this.
    04-10-15 05:36 AM
  2. sbx9900's Avatar
    if you delete the email from BB, there is an option if you would like to delete it only from BB or from the server. If you delete it only from BB, of course, it will still show in the gmail account when you look in the computer.
    04-10-15 05:53 AM
  3. piflintstone's Avatar
    Okily dokily.....obviously I have delete on hub and server activated, no idea how you came to think I would ask for help if not.

    Is it normal to have Trash greyed out and non tickable? Could anyone at least confirm that? Holy god...2015 and I found a device not capable of showing email....
    04-10-15 07:39 AM
  4. sbx9900's Avatar
    Okily dokily.....obviously I have delete on hub and server activated, no idea how you came to think I would ask for help if not.
    I apologize if I did not find it "obvious" since you did not explicitly state that in your original post. I am not a psychic to know what you already did or did not do. I was simply trying to cover some or all the possible bases that I know about since I cannot possibly know how adept (not adapt) you are with BB devices just by judging your intelligence by the number of misspelled words and the lack of apostrophes in your original post.

    But anyway, I am hoping that someone will help you sort your troubles out.
    04-10-15 08:22 AM
  5. piflintstone's Avatar
    I apologize if I did not find it "obvious" since you did not explicitly state that in your original post. I am not a psychic to know what you already did or did not do. I was simply trying to cover some or all the possible bases that I know about since I cannot possibly know how adept (not adapt) you are with BB devices just by judging your intelligence by the number of misspelled words and the lack of apostrophes in your original post.

    But anyway, I am hoping that someone will help you sort your troubles out.
    FYI, how good is your german, french or spanish? These are the languages I speak, being a german native speak, so sorry if my english insulted you. Btw, I typed the post on a blackberry....

    You would have found the answer by looking at the rest of my post, the problem lies in messages not going anywhere. I actually managed to get the damn email client to at least archive the messages now. Mind you, I am actually deleting the message, all the settings in gmail are done for DELETING and not friggin archiving.
    Unbelievable....on my xperia Z, imap works fine for gmail (not to mention the gmail app), on the god damn ipad air it is working fine with imap, its working fine on my works ip6 but hey, on the blackberry I feel like being thrown 10 years back in time....

    I already tried everything in all the tutorials around....obviously the solution is to abandon gmail and move to whatever.
    04-10-15 11:20 AM
  6. sbx9900's Avatar
    FYI, how good is your german, french or spanish? These are the languages I speak, being a german native speak, so sorry if my english insulted you. Btw, I typed the post on a blackberry....
    FYI, my German, French or Spanish are not any good for I don't speak those languages, but I speak other languages though, and I won't bother asking you how good you are in the other languages I speak. As I can see, you don't have the psychic powers to know that I'm not a native English speaker nor a writer at that.

    Oh, by the way, I also type a lot on a BlackBerry, but my Q10 or my 9900 or my other BlackBerries in the past for that matter do not commit a lot of spelling errors despite the double typing issues. It must have something to do with the user...perhaps.
    04-10-15 11:48 AM
  7. piflintstone's Avatar
    Whatever, your help did not help so please move on, thank you a lot.
    Droidophobe likes this.
    04-10-15 12:17 PM
  8. Droidophobe's Avatar
    I'm having the same, or similar, problem. When I deleted Gmails from my phone, it would remove them from the phone, but when it deleted them from the Gmail inbox, it archived them rathering than moving them to Trash. So I followed these instructions... How to prevent deleted Gmail messages from archiving when synced using IMAP | CrackBerry.com

    Now when I delete Emails on the phone, it doesn't delete them from from Gmail at all. Bad to worse.

    Any suggestions? Moving from Gmail is not an option for me.
    andy957 likes this.
    04-10-15 06:59 PM
  9. Soapm's Avatar
    You're right, mines does this also. I guess I never noticed since I clean out the box from outlook.
    04-10-15 09:48 PM
  10. piflintstone's Avatar
    I tried everything and I found that it does partly work now. Followed the guide that states to untick All Mail and Important inside Gmail options. It does work for new mail and new mail only - also not for all recipients.
    The behaviour now is the following:

    New Mail from most recipients (new mail sent after the Blackberrys first gmail access) - does delete and move to trash
    New Mail received prior to BB first gmail access - delete on Device, archive in gmail
    Mail I received on some date prior to BB first access that is already read - delete on Device, archive in gmail
    Mail I received on some date prior to BB first access but is moved to inbox and marked unread - delete on Device, archive in gmail
    New Mail sent to myself will never delete - if recipient is "me" they will delete on the BB but always go to archive in gmail.

    No idea why this is not working decently. I tested the same on 3 iPads (4, Air, Air2) and 3 iPhones (3Gs, 4, 6 & 6+) now, all of them on different iOS releases (the 4 and 3GS on rather old ones - the others on their latest available ones), all of them set to IMAP access only and each single device works. I can sync All Mail, I can delete old mail, I can delete read mail, I can delete new unread mail, I can enable all Labels etc.
    So, either Apple does magic or BB is just terrible....
    These issues were first reported in 2013 and so far there was no fix? Come on, even the most hardcore BB user should by now come to the conclusion that this is a friggin joke.

    Most mails will now delete - mails sent to myself will not (never) delete, those will always archive. All Mail is not available and not searchable. The same applies to trash. BB rendered gmail more or less uselss. Without All Mail and trash I (me personally) can not use gmail because I follow the usage guidelines intended for gmail - you do not need to delete, just use the search field.
    BTW: If I enable a single custom label in gmail options to be available to IMAP - delete will no longer work. I even set up new and virgin gmail accounts to test it - does not work.

    My solution now was to hand over my BB to my 5 year old daugther. She likes the keyboard the device seems to hold up well, even being tossed around did not hurt it too much. I went back to an iPhone 6 - at least my company has a choice between BB and iPhone.
    I think its a shame, the device was great to use, it was extremely fast (even though having a weak CPU) and everything felt fluid. The app store is terrible, lacking pretty much everything but having no working gmail solution is a no go. Apple had the same problems with Gmail and IMAP but at least they ironed it out within a few month. Blackberry ignores the problem for 2 years now, I wish them all the best for their future - they will need it.
    04-13-15 01:03 AM

Similar Threads

  1. 10.3.1.1779 upgrade - Notication profiles not working
    By sonicpix in forum BlackBerry Passport
    Replies: 5
    Last Post: 04-12-15, 10:14 AM
  2. How do I transfer contacts and memopad from my Bold 9900 to Classic?
    By CrackBerry Question in forum BlackBerry Motion
    Replies: 3
    Last Post: 04-10-15, 11:36 AM
  3. Sync Q10 contacts to gmail
    By LanaNu in forum BlackBerry Q10
    Replies: 5
    Last Post: 04-10-15, 07:55 AM
  4. Why do my contacts returns produce No Results?
    By parentint in forum BlackBerry 10 OS
    Replies: 0
    Last Post: 04-10-15, 04:38 AM
LINK TO POST COPIED TO CLIPBOARD