1. Harry_III_UK's Avatar
    Anyone else having this problem?

    My Q10 seems to randomly lose connection to Gmail.

    It doesn't tell you that it has (annoying) the only way I know is when I check the web based Gmail for new e-mails and find there are some there that are not on my Q10.

    It seems to happen when the Q10 switches networks - like it isn't initiating the connection correctly when it hands over.

    The strange thing is that it doesn't necessarily happen with all my Gmail accounts. Nor does it happen with all the services within a Gmail account. So, if I go into the "settings" menu on the Q10 it can have "Gmail 1" with everything working and "Gmail 2" with CardDAV and CalDAV working for contacts and calendar but the e-mail showing as "not connected".

    Likewise, e-mail can be working in "Gmail 1" but then it loses its connection to CardDAV for contacts - or any combination of CardDAV, CalDAV and e-mail working or not working at random.

    A working day's pattern of handover would be from home WiFi to cellular network to office WiFi to cellular network to office WiFi to cellular network to home WiFi.

    I've ditched the application specific passwords and gone through the Q10 to authorise the device to act with the account (side note - this also used to happen when I used application specific passwords so this seems to make no difference):

    From within the Gmail web interface:
    Account >> Security >> Connected Applications and Sites

    And there you can see that "Blackberry" is authorised to access the Gmail account.

    I even upgraded the s/w and o/s this weekend and that made no difference either - other than I've now lost Dark Theme of course :-(

    Here are the technical details of what the Q10 is currently running - I've included all the irrelevant bits for completeness:

    s/w: 10.1.0.4181
    o/s: 10.1.0.4633
    Build: 556195
    Flash: 11.1.121.150
    AIR: 3.1.0.150
    Crypto: 5.6.2.44391
    WLAN: 1.1
    Radio: 10.1.0.4634
    Web Kit: 10.1.0.4624
    Browser: 10.1.1.336

    So far, a re-boot seems to work although in the past when I was using application specific passwords, that did NOT always work, nor did re-entering the password. Sometimes the only option was to delete and re-create the Gmail account on the device - hardly a satisfactory solution.

    I really was hoping that an upgrade to the latest official o/s version for me would have worked - especially since it has added the option of being able to retrieve e-mails "indefinitely".

    On the whole, Outlook.com seems to be a far more robust e-mail solution for the Q10 than Gmail. Activesync idiosyncrasies perhaps? Yes, I had my Gmail when Activesync was supported - and it is still supposed to be fully supported on those "early adopter" Gmail accounts so, I am at a complete loss to explain this.

    Any help gratefully received!

    Thanks,

    Harry
    Attached Thumbnails Gmail connection lost at random on BB10-screen-shot-2013-10-22-21.33.01.png   Gmail connection lost at random on BB10-screen-shot-2013-10-22-21.32.32.png  
    10-22-13 03:52 PM
  2. pkcable's Avatar
    10-23-13 09:11 PM
  3. RicochetSEW's Avatar
    I am having the same problem on my Q10… GMail constantly going to "not connected". Tired of reinstalling the account and/or restarting my phone. Sometimes, if I wait it will connect on it's own again??? Maybe a Google server problem? Is Outlook working any better? I am willing to change to another email service geared for BB10 if need be. Cheers and respects,

    Q10
    SQN110-3
    10.1.0.4181
    10-30-13 11:56 PM
  4. RicochetSEW's Avatar
    10-31-13 12:55 AM
  5. Harry_III_UK's Avatar
    Great link - thank you!

    I thought this was an interesting bit...

    "Gmail has identified 15 or more unique connections (IP addresses) simultaneously to the Gmail server in one second and therefore has terminated the connection.

    This can be due to multiple devices and/or email clients (for example, Microsoft Outlook) trying to access the Gmail server at the same time.

    It can also be due to the BlackBerry 10 smartphone being used in a high density cell tower area or being used while traveling or roaming. The smartphone connects to multiple cell towers, however, the IP is not released from each previous tower. A new IP is assigned each time the smartphone connects to a new cell tower and so this causes multiple IPs to connect with Gmail at the same time."


    <snip>

    "If in a high density cell tower area, obtain a static IP from the wireless service provider for the BlackBerry 10 smartphone (or any other device) so that only one IP is used (per device) to connect to the Gmail account. This option is typically offered for a fee."

    ... but if that was the case, when my BlackBerry has been inside all night then Outlook desktop shouldn't lose its connection due to too many IP addresses (the article suggests > 15 IP addresses at the same time) as neither the phone nor the desktop client have roamed.

    It doesn't seem to be a problem unique to BlackBerry though - my friends with iPhones are also reporting the same problem.

    In fact, just before I typed this, my Outlook desktop client on my Mac was reporting it was unable to connect and asking whether I wanted to re-input my password. I just said no, and it fixed itself. Mystery.

    I think it is just one of those Gmail things - and it would be interesting to know whether the same problem occurs on Android devices.

    My suspicion is that it is something to do with the idiosyncrasies of Gmail's active sync.

    Outlook dot com mail "the web based e-mail service formally known as Hotmail" (TWBESFKAH) doesn't seem plagued with the same problems though and seems to be an altogether more reliable connection. Outlook TWBESFKAH has NEVER to date lost its connection - touch wood!

    Was I dreaming, or once upon a time didn't RIM offer their own BlackBerry e-mail service?
    10-31-13 03:46 AM
  6. RicochetSEW's Avatar
    Turning Off Push on my Q10 and the Manual Clearing of Signing Out Sessions under Details in Gmail seem to have fixed my problem… will see.
    10-31-13 04:25 AM
  7. RicochetSEW's Avatar
    Happy to report that I have had no problems with my GMAIL connection nor synch'ing since making the above settings.
    11-01-13 11:51 PM

Similar Threads

  1. Replies: 72
    Last Post: 06-20-14, 08:47 AM
  2. funny how playbook still the best tablet at the end of 2013
    By fyngfyn in forum BlackBerry PlayBook
    Replies: 111
    Last Post: 11-17-13, 09:49 PM
  3. Stream audio (a2dp) TO BB10 device?
    By wx_junkie in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 10-30-13, 04:34 PM
  4. Positive press on Z30 from TechRadar
    By iqnetcomdotca in forum BlackBerry Z30
    Replies: 17
    Last Post: 10-24-13, 03:19 PM
  5. Very Upsetting on what some users are saying about BBM
    By digi_ice in forum General BBM Chat
    Replies: 48
    Last Post: 10-22-13, 08:23 PM
LINK TO POST COPIED TO CLIPBOARD