1. HotFix's Avatar
    Previously I had formatted my SanDisk class 10 SD card 64GB card in my Z30 which used the FAT32 file system. After learning that ExFAT is supported in 10.2.1.3175, I decided to take advantage of that preferred format and performed the following steps:

    1. Decrypted my SD card (I keep it encrypted so I can carry work files on it as well as personal files). This took a couple of days.
    2. Popped the card out and stuck it in my laptop.
    3. Copied everything off to a temp folder on my laptop.
    4. Fill (not Quick) formatted the SD card to ExFAT format, using the default allocation size.
    5. Copied all of the files from the temp folder back to the card.
    6. Popped the card back into my Z30 and rebooted it since the indexing seemed to be stalled. That seemed to fix it although I had to re-download my ring tones from the computer onto the SD card as they didn't seem to want to work.
    7. Once the indexing seemed to return to normal I re-encrypted the card, which went much faster.

    Now when I play songs from my play lists, every once and a while I get an error in the middle of a playing song like this:
    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140613_171733.png

    Anyone else experience this since switching out their SD cards to use the ExFAT format?

    I don't know if it is because I encrypted the card and maybe the brand new ExFAT hasn't been fully flushed out with encryption. Maybe it's somehow the format I did messed something up, because one person on the forums is adamant people are damaging their SD cards by using the FAT32 format (although I don't see how that is possible and didn't have issues until I switched back to the native ExFAT format).

    I searched on the forums and some people reported older OS media players had a similar issue with a "(1)" error even though this is a "(9)" error, but this is the latest OS and if it was the media player I would think other people would be seeing it.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-13-14 10:14 PM
  2. Jonesy1966's Avatar
    Doesn't the new OS update allow you to format exFAT on the device itself? If so, I would dump everything off the card again, reformat on the phone and recopy everything back. I have no idea if this will work TBH, but I get the impression from what I've recently read that it will.
    06-14-14 10:12 AM
  3. HotFix's Avatar
    Doesn't the new OS update allow you to format exFAT on the device itself? If so, I would dump everything off the card again, reformat on the phone and recopy everything back. I have no idea if this will work TBH, but I get the impression from what I've recently read that it will.
    I was under the impression you had to already have the ExFAT on the card for it to download the driver to support ExFAT.

    I would be willing to try it if someone else who doesn't have an encrypted card tries it first. I fear it will take me 2+ days to decrypt my card again for me to repeat the process above but this time format it in the device.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-14-14 11:37 AM
  4. Jonesy1966's Avatar
    I was under the impression you had to already have the ExFAT on the card for it to download the driver to support ExFAT.

    I would be willing to try it if someone else who doesn't have an encrypted card tries it first. I fear it will take me 2+ days to decrypt my card again for me to repeat the process above but this time format it in the device.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    I'll be quite happy to give it a go but if I can't get to it today it won't be until Monday, my partner created a "to do" list
    06-14-14 11:46 AM
  5. HotFix's Avatar
    I'll be quite happy to give it a go but if I can't get to it today it won't be until Monday, my partner created a "to do" list
    I would greatly appreciate and am in no hurry as my songs play most of the time without this issue. And the once or twice a day I run into it. I can restart the song and it plays all the way through.

    If the device gives you the option of which file system to use, that would be awesome. Even if it doesn't, as long as the card is still an ExFAT format, that's all I'm after.

    Thanks!

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-14-14 11:50 AM
  6. doubleuc's Avatar
    I think my 32 gig which I've not formatted ever is on the standard fat32, since that last update I've had your error message 3 times playing random music over bluetooth..

    Had to reboot to play music each time.

    Posted via CB10
    06-14-14 05:11 PM
  7. uber_geek's Avatar
    I reformatted my 64g SanDisk card to exFat and reloaded it several weeks ago myself. However, I am not encrypting it. I play music via blue tooth all the time and don't see this issue. But yesterday while using the 'play on' option to send music to my son's LG TV, I saw it several times. Each time I just restarted the song and it played on through the second time without error. I did not restart the phone or even the music player.
    I've been running 3175 for about six weeks now.

    Posted via CB10
    06-15-14 07:54 AM
  8. jonty12's Avatar
    I'm having this problem with video, pictures, and audio. Started with a new 64gb card (that $16 deal that was posted). I installed 3175 and popped in the new card. Worked for a while, then randomly started getting that error. Viewing pictures in picture viewer would show a broken icon. Thought it was the card. Reboot sometimes worked. Running a fix via a card reader on a PC fixed it for a while. Then it would return. I started losing important files and moments (e.g. Pics and video from my wife's grad school graduation).

    I assumed it was the cheap card. I bought a more expensive, recommended by GoPro card to replace the cheap one. Put it in yesterday. Same, if not worse problems. Nothing saves to the card. If anything does, immediately get that (or similar) error. The card formats successfully in the phone but then, after attempting to use it, I get no such directory exists errors and nothing saves to it.

    I've tried both cards in my PC, and both work. There seems to be an exFat problem on 3175.

    Posted via CB10
    06-15-14 12:46 PM
  9. jonty12's Avatar
    Some screen shots (saved to device, since card doesn't work)...

    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140615_125357.png
    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140615_125405.png
    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140615_125423.png

    Error when trying to access any of those folders...


    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140615_125432.png



    Posted via CB10
    06-15-14 12:57 PM
  10. jonty12's Avatar
    So now I reformatted the card...

    New card info after reformat:


    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140615_125850.png

    Accessing camera directory on card after reformat:


    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140615_125933.png

    Properties of first picture taken after reformat:


    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140615_130036.png

    What happens after trying to take second picture:


    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140615_130118.png

    Trying to access "camera" folder on card after above error:


    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140615_130427.png

    Posted via CB10
    06-15-14 01:05 PM
  11. jonty12's Avatar
    Sorry for what in retrospect seems like a hijack, but all of this started with the "unsupported media" error after installing 3175 and using an exFAT formatted card.

    Posted via CB10
    06-15-14 01:13 PM
  12. HotFix's Avatar
    Sorry for what in retrospect seems like a hijack, but all of this started with the "unsupported media" error after installing 3175 and using an exFAT formatted card.

    Posted via CB10
    I don't think you hijacked the thread at all. If nothing else you make me think the support for ExFAT in 3175 just isn't mature which could certainly explain why I am getting the errors I am seeing that I started this thread with.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-15-14 01:52 PM
  13. HotFix's Avatar
    I got tired of the random errors so I decided to decrypt my 64 GB card and see if that made a difference. Surprisingly unlike when it was FAT32, it didn't take days to decrypt. Rather I started it at ~11PM last night and it was done by ~5PM the next day. What a night and day difference.

    I did get these errors both during and after decrypted my card had finished:
    Getting "The file can't be played due to an unexpected error (9)" after reformatting SD card to ExFA-img_20140620_083957.png

    I had to hard reset my phone and let it reindex the card, but now it is playing again. If I continue to get the errors above, I will format the card in the device and see of it let's me choose ExFAT.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-20-14 05:50 PM
  14. HotFix's Avatar
    The (9) errors persist after removing encryption so I will once again copy the data off the card and format it. This time I will do it in the device to see if it chooses FAT32 or ExFAT.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-25-14 08:49 AM
  15. HotFix's Avatar
    I emptied my card onto my laptop, stuck the SD card back into my Z30, and formatted it.

    When I popped it back into my laptop I checked and verified the file system was ExFAT. So it looks like once you have ExFAT support in you BlackBerry 10 OS, it will continue to use that format.

    The bad news is after copying all of my files back down to my SD card through the SD card slot of my laptop, I am still getting the dread (9) errors playing music stored on my card. The errors seem random, and it's not as of the file is messed up because if I play the errored music file again it plays fine.

    I have to guess at this point it's an ExFAT implementation issue with BlackBerry 10.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-25-14 06:40 PM
  16. peter0328's Avatar
    I emptied my card onto my laptop, stuck the SD card back into my Z30, and formatted it.

    When I popped it back into my laptop I checked and verified the file system was ExFAT. So it looks like once you have ExFAT support in you BlackBerry 10 OS, it will continue to use that format.

    The bad news is after copying all of my files back down to my SD card through the SD card slot of my laptop, I am still getting the dread (9) errors playing music stored on my card. The errors seem random, and it's not as of the file is messed up because if I play the errored music file again it plays fine.

    I have to guess at this point it's an ExFAT implementation issue with BlackBerry 10.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    You should email Michael Clewley with logs.

    Posted via CB10
    06-25-14 07:12 PM
  17. m3mb3rsh1p's Avatar
    After losing files from my SD Card a couple of times, I did some investigating and discovered that the issue could be related to improper paritioning and formatting.

    BB10 does not partition SD cards and if you modify the file system while the OS is running, it will not refresh properly causing corruption of data written to the card once you reboot.

    I strongly advise against using BB10's built-in formatting tools until this issue is fixed.

    First you need to make sure that your card is properly partitioned using another system eg Windows Disk Utility, fdisk etc. Erase all partitions then create one primary partition and format it on your computer. From here you should shut down the phone and insert the card so that the OS has a clean start.

    It should work properly after this. I strongly suggest you do not use the phone to re-format the card and reboot the phone every time you do format on another system. Also, do NOT use the BB10 "erase" feature. I don't know what it does but I fear that it affects the partitions or FAT and doesn't do a full format which causes the OS to read old information. I have seen garbage files on my SD card after doing this.

    Hopefully BlackBerry will fix this to follow the conventional practice.
    06-25-14 07:14 PM
  18. HotFix's Avatar
    First you need to make sure that your card is properly partitioned using another system eg Windows Disk Utility, fdisk etc. Erase all partitions then create one primary partition and format it on your computer. From here you should shut down the phone and insert the card so that the OS has a clean start.
    That's actually what I reported I did. I am getting transient (9) errors when playing music filed from my SD card

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    06-25-14 09:14 PM
  19. HotFix's Avatar
    So apparently none if my videos I copied from my computer to the SD card were playable and even some of the songs wouldn't play either.

    Luckily I have a 4GB thumb drive that I used to re-copy the files from my computer to my Z30 thanks to USB On The Go.

    BlackBerry really needs to iron out the issues with the ExFAT support. This is getting ridiculous (including not being able to use Link to talk to the SD card).

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    peter0328 likes this.
    06-27-14 07:55 PM
  20. HotFix's Avatar
    To close the loop on this - I gave up and replaced my SanDisk 64GB card with a new Samsung 64GB card. I left the card the default ExFAT format, as in I didn't format it, and now everything is working how it should.

    Odd that something was wrong with my SanDisk card. I may try formatting it to ExFAT using the SD card consortium tool to see of that is any better. I'm in no hurry as the Samsung card is working fine.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    07-20-14 09:57 PM
  21. TXBBguy's Avatar
    I've had the same issue since I replaced my SanDisk 8GB with the Amazon special Samsung 32GB card.

    I've formatted, reformatted, copied, downloaded, etc, all to no avail. I pretty much blamed it on the Samsung MB-MG32DA/AM microSDHC card.

    However, I will try m3mb3rsh1p's method of formatting via Windows

    Z10, AT&T STL100-3, 10.2.1.2179
    08-04-14 11:54 AM
  22. HotFix's Avatar
    To close the loop on this - I gave up and replaced my SanDisk 64GB card with a new Samsung 64GB card. I left the card the default ExFAT format, as in I didn't format it, and now everything is working how it should.

    Odd that something was wrong with my SanDisk card. I may try formatting it to ExFAT using the SD card consortium tool to see of that is any better. I'm in no hurry as the Samsung card is working fine.

    Posted via CB10 via Z30STA100-5/10.2.1.3175
    I spoke too soon. This brand new, never been formatted, high speed card is also reporting the "(9)" error as well. It's only happened a few times, buy enough that leads me to believe there is a lack of operational maturity with the new ExFAT drivers in BlackBerry 10.2.1.

    Hopefully BlackBerry learns of these issues and addresses them at some point in the near future.

    Posted via CB10 via Z30STA100-5/10.2.1.3247
    08-06-14 08:51 PM
  23. creda2lord's Avatar
    I actually experience my video not playing due to unexpected error on my z10 . My goodness!!! Just downloaded game of thrones and is not playing. wow what is wrong. So I deleted some document that I could let go, videos, pictures, Facebook chat,whatsApp chat, goggle mails.just name it the whole essence is to free ur memory space.i did IT WORKED!!!! Hope it works for somebody.
    05-01-16 03:37 PM
  24. Rohit Rana1's Avatar
    i have z10 smartphone i did encrypt so all file of my phone is corrupt then i format the phone so please help me out
    of this issue . i face the problem sine 3 month . so some file not play
    01-22-17 06:51 AM

Similar Threads

  1. Replies: 48
    Last Post: 01-26-15, 10:54 AM
  2. switching from windows phone to Q10
    By lkanaday in forum BlackBerry Q10
    Replies: 3
    Last Post: 06-14-14, 01:09 PM
  3. Quick search from the home screen misses the first letter.
    By skstrials in forum BlackBerry Q10
    Replies: 3
    Last Post: 06-14-14, 12:46 PM
  4. Media card in my old 9850
    By baspeed in forum BlackBerry Z10
    Replies: 2
    Last Post: 06-14-14, 01:48 AM
  5. blackberry z30 wont connect to laptop
    By Souleye Diongue in forum BlackBerry Z30
    Replies: 2
    Last Post: 06-14-14, 12:07 AM
LINK TO POST COPIED TO CLIPBOARD